Go Back   Home > Forums > >
Home Forums Rules Articles diyAudio Store Blogs Gallery Wiki Register Donations FAQ Calendar Search Today's Posts Mark Forums Read

Audio Alto with MA drivers?
Audio Alto with MA drivers?
Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 3rd May 2011, 10:03 AM   #1
djanci is offline djanci  Croatia
diyAudio Member
 
Join Date: Feb 2009
Default Audio Alto with MA drivers?

Hi Mark,

Looking at last Hi-Fi SHOW LJUBLJANA 2010 pic gallery I was stunned when I saw showroom of a new Slovenian loudspeaker manufacturer. It looks to me that all their loudspeakers are using your drivers but there is no info that could confirm that on their website Audio Alto. Can you confirm that?

Cheers

Click the image to open in full size.
  Reply With Quote
Old 4th May 2011, 12:00 AM   #2
vizion is offline vizion  United States
diyAudio Member
 
Join Date: Apr 2007
That's a nice-looking KT-88 amp too.
  Reply With Quote
Old 4th May 2011, 04:50 AM   #3
Scottmoose is offline Scottmoose  United Kingdom
diyAudio Member
 
Scottmoose's Avatar
 
Join Date: Mar 2005
Location: UK
Appears to be Alpair 10s & 6 x series-parallel (presumably 2 parallel packs of 3 units in series) CHR70, respectively.
  Reply With Quote
Old 11th December 2012, 07:15 PM   #4
Studio Au is offline Studio Au  United Kingdom
diyAudio Member
 
Join Date: Sep 2008
Location: Bristol
Do the alpairs work well for Omni?
  Reply With Quote
Old 11th December 2012, 07:20 PM   #5
Scottmoose is offline Scottmoose  United Kingdom
diyAudio Member
 
Scottmoose's Avatar
 
Join Date: Mar 2005
Location: UK
How do you define 'work well?'
  Reply With Quote
Old 11th December 2012, 07:44 PM   #6
planet10 is offline planet10  Canada
frugal-phile(tm)
diyAudio Moderator
 
planet10's Avatar
 
Join Date: Oct 2001
Location: Victoria, BC, NA, Sol III
Audio Alto with MA drivers?
Quote:
Originally Posted by Studio Au View Post
Do the alpairs work well for Omni?
People have been very pleased with the microTower, particularily the castle version.

dave
__________________
community sites t-linespeakers.org, frugal-horn.com, frugal-phile.com ........ commercial site planet10-HiFi
p10-hifi forum here at diyA
  Reply With Quote
Old 12th December 2012, 03:49 AM   #7
chrisb is offline chrisb
diyAudio Member
 
Join Date: Aug 2002
Location: victoria BC
Quote:
Originally Posted by Studio Au View Post
Do the alpairs work well for Omni?
Quote:
Originally Posted by planet10 View Post
People have been very pleased with the microTower, particularily the castle version.

dave
two people that I know of for sure, but they don't use what the posted photo seems to display as a conical deflector in the very near field, and really don't qualify as an "omni" .
__________________
kinda burnt out - taking a break
  Reply With Quote
Old 12th December 2012, 08:34 AM   #8
Scottmoose is offline Scottmoose  United Kingdom
diyAudio Member
 
Scottmoose's Avatar
 
Join Date: Mar 2005
Location: UK
Semi-omni I call them. Then again, a lot of nominally omnidirectional speakers aren't entirely either. YMMV.
  Reply With Quote
Old 12th December 2012, 09:01 AM   #9
planet10 is offline planet10  Canada
frugal-phile(tm)
diyAudio Moderator
 
planet10's Avatar
 
Join Date: Oct 2001
Location: Victoria, BC, NA, Sol III
Audio Alto with MA drivers?
Quote:
Originally Posted by Scottmoose View Post
Then again, a lot of nominally omnidirectional speakers aren't entirely either
I can't think of a single one -- outside of a subwoofer -- that is.

dave
__________________
community sites t-linespeakers.org, frugal-horn.com, frugal-phile.com ........ commercial site planet10-HiFi
p10-hifi forum here at diyA
  Reply With Quote
Old 12th December 2012, 11:58 AM   #10
Studio Au is offline Studio Au  United Kingdom
diyAudio Member
 
Join Date: Sep 2008
Location: Bristol
I remember reading a comment by Mark saying his speakers weren't design for Semi-moni or using reflection/acoustic lens/deflectors. I can't remember the exact reason...

Something I would love to try. Perhaps I will while my alpair a are not yet soldered into their cabinets.
  Reply With Quote

Reply


Audio Alto with MA drivers?Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Audio Innovations Alto canfixit Solid State 27 28th September 2014 09:31 PM
Crown MA-12000i / MA-5000i / MA-9000i jack2040 Solid State 4 8th March 2011 02:21 PM
ma audio hk-4000 ,no sound to subs ?MA AUDIO HK-4000,NO OUTPUT TO SUBS WRENCH030380 Class D 2 8th March 2011 12:38 AM
MA AUDIO HK2000D mike49504 Car Audio 1 11th November 2010 07:04 PM
MA Audio Tom7227 Class D 0 31st August 2010 09:18 PM


New To Site? Need Help?

All times are GMT. The time now is 08:47 PM.


Search Engine Optimisation provided by DragonByte SEO (Pro) - vBulletin Mods & Addons Copyright © 2017 DragonByte Technologies Ltd.
Resources saved on this page: MySQL 15.79%
vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2017 DragonByte Technologies Ltd.
Copyright ©1999-2017 diyAudio
Wiki