looking for effecient 4" driver for FAST system - Page 3 - diyAudio
Go Back   Home > Forums > Loudspeakers > Full Range

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 29th March 2011, 03:15 PM   #21
diyAudio Member
 
audiobomber's Avatar
 
Join Date: Jul 2004
Location: Sudbury, Ontario Canada
The main drivers in a sealed cabinet running full range are rolling off at 12dB/octave and the sub is likely filtered with LR4 low pass. This combination of BW2 and LR4 will never sound very good, IME. You need either a lower frequency LR2 on the sub to create a proper LR2 cross, or else add a BW2 to the mains and keep the LR4 on the subs (option 2 is lower distortion and plays louder).
__________________
Dan
  Reply With Quote
Old 29th March 2011, 05:42 PM   #22
diyAudio Member
 
Josephjcole's Avatar
 
Join Date: Jun 2004
Location: Wisconsin
audiobomber
I'm not sure that my plate amp is 4th order... I got it a couple of years ago from MCM electronics for $35. Taking a quick survey of the cheapest amps around they all seem to be running 2cnd order crossovers. Certainly when you get up into the higher quality plate amps they are 4th order. I'm guessing mine is 2cnd order, though I haven't tested it to find out.
It's interesting though. I've never heard anyone speak of having issues with integration when they have sealed main speakers crossed over to a sub run by a plate amp.
Do you have more details? what was your situation? What did it sound like? I would be curious to hear your impressions of the mismatched roll offs when running a sealed main speaker and a plate amp with 4LR.
Joe
  Reply With Quote
Old 30th March 2011, 12:35 AM   #23
diyAudio Member
 
audiobomber's Avatar
 
Join Date: Jul 2004
Location: Sudbury, Ontario Canada
Quote:
Originally Posted by Josephjcole View Post
I've never heard anyone speak of having issues with integration when they have sealed main speakers crossed over to a sub run by a plate amp.
Do you have more details? what was your situation? What did it sound like? I would be curious to hear your impressions of the mismatched roll offs when running a sealed main speaker and a plate amp with 4LR.
Joe
I use a pair of Bamberg Sound Lab S5-MTM's and a pair of 10" subs. I tried running the mains full range and the subs low passed LR4, and it always sounded bad. The subwoofer bass lags behind the bass from the mains and kills the pace and rhythm. You get bass but lose the music.
__________________
Dan
  Reply With Quote
Old 13th April 2011, 04:36 AM   #24
Bigun is offline Bigun  Canada
diyAudio Member
 
Bigun's Avatar
 
Join Date: Jan 2009
Blog Entries: 2
Quote:
Originally Posted by Josephjcole View Post
I stopped by Madisound yesterday and picked up a pair of 930sf drivers. Thanks everyone for the suggestions, much appreciated!
Sound impressions ???
__________________
"The test of the machine is the satisfaction it gives you. There isn't any other test. If the machine produces tranquility it's right. If it disturbs you it's wrong until either the machine or your mind is changed." Robert M Pirsig.
  Reply With Quote
Old 13th April 2011, 12:50 PM   #25
diyAudio Member
 
Josephjcole's Avatar
 
Join Date: Jun 2004
Location: Wisconsin
Sorry,
so far i've just been listening to them in my studio through an old 1970's reciever that I picked up at a garage sale, so I can't really give any meaningful impressions (the reciever is a little noisy). I'm really busy through Easter weekend, but hopefully after that I can set them up in the living room and give you some listening impressions while I have them plugged into a amp that doesn't produce any nastiness. It's nice to have music in the studio I can say that much though... I'm hoping eventually to get an inexpensive tripath amp for the studio....
Joe
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
FAST and SIMPLE driver for HEXFETS (linear use). ontoaba Solid State 29 11th February 2011 12:19 AM
Driver/enclosure to complement Alpair 10.2 FR Pensil in a FAST system? southernoise Markaudio 24 7th February 2011 01:04 PM
FAST system in a vehicle 901Fixer Car Audio 0 26th November 2010 07:56 PM
FAST System hm Full Range 9 25th May 2007 07:06 AM
Looking for a 8" Driver for Servo System ptstv Subwoofers 1 23rd May 2007 07:48 PM


New To Site? Need Help?

All times are GMT. The time now is 11:33 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2