Tannoy Royale speakers...need help - diyAudio
Go Back   Home > Forums > Loudspeakers > Full Range

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 11th December 2010, 08:07 PM   #1
diyAudio Member
 
Sonance84's Avatar
 
Join Date: Aug 2010
Location: Las Vegas, NV
Question Tannoy Royale speakers...need help

Hey everyone, I need some advice about these drivers/speakers that I picked up. What did I find??

pictures: ImageShack Album - 14 images (not sure how to add pics to the thread yet)

I picked up a pair of Tannoy Royale 15/85 integrated loudspeaker system speakers. The back tag says HPD/410. I was thinking that there would be Monitor Royal 15/85 dual concentric speakers in them...but there is 2 drivers per cabinet. They have HPD/385/8 networks in them and the horn tweeter looks just like the back of a Monitor Royal 15/85. The woofers on the other hand are different from each other and I can't tell if they are original or not.

Upon testing them out, I found that only 1 woofer and 1 tweeter works...in different cabinets! I then proceeded to take the drivers out ant test them with a multimeter and got these results:

15" speaker 1: 10.5 ohm - non working
15" speaker 2: 5.7 ohm - working
tweeter 1: 11.0 ohm - working
tweeter 2: 10.2 ohm - non working

Does that sound right? The 5.7 ohm 15" seems low, but thats the sub that works. Is there any way to fix the drivers to make them work properly again...IF they aren't working?

The cabinets are in really bad condition and the guy I bought them from said he used these for many house parties. That should have been my warning sign.

Are these speakers valuable to people who know how to refurbish them? I don't have the time right now and was planning on flipping these, but in non-working condition, I might be stuck with them. Any help with these speakers would be appreciated, thanks!

Cory
__________________
H.H. Scott 299D (NOSValves resto), Marantz SA8003, Denon DP-3000 / Acos Lustre GST 1 / Shure M97xE, Klipsch Forté (Bob Crites upgrades), Kimber Kable 8VS, Soundstring Omega, Pangea AC-14SE, Furman PST-8
  Reply With Quote
Old 12th December 2010, 01:46 AM   #2
diyAudio Member
 
Sonance84's Avatar
 
Join Date: Aug 2010
Location: Las Vegas, NV
Default update...

I cleaned the pots on the crossovers which in turn made all 4 drivers work. Sounded pretty good too. Need to re-flow the solder joints on 1 crossover though...bad connection somewhere.

Hope these can be used by someone.
__________________
H.H. Scott 299D (NOSValves resto), Marantz SA8003, Denon DP-3000 / Acos Lustre GST 1 / Shure M97xE, Klipsch Forté (Bob Crites upgrades), Kimber Kable 8VS, Soundstring Omega, Pangea AC-14SE, Furman PST-8
  Reply With Quote
Old 12th December 2010, 01:58 AM   #3
AndrewT is offline AndrewT  Scotland
diyAudio Member
 
Join Date: Jul 2004
Location: Scottish Borders
There are a lot of Tannoy parts in there, so these must have been genuine Tannoy speakers at some time.

I do not recognise the baskets as Tannoy.
I do not recognise either bass cone as Tannoy.
The alnico magnet looks genuine, but the ceramic magnet cannot be from an early HPD.

Try to find pics of the Royal drivers and the older and newer HPD in the Hilberlink site. Or is it Hilberink?
__________________
regards Andrew T.

Last edited by AndrewT; 12th December 2010 at 02:08 AM.
  Reply With Quote
Old 12th December 2010, 02:05 AM   #4
diyAudio Member
 
Sonance84's Avatar
 
Join Date: Aug 2010
Location: Las Vegas, NV
Quote:
Originally Posted by AndrewT View Post
There are a lot of Tannoy parts in there, so these must have been genuine Tannoy speakers at some time.

I do not recognise the baskets as Tannoy.
I do not recognise either bass cone as Tannoy.
The alnico magnet looks genuine, but the ceramic magnet cannot be from an early HPD.

Try to find pics of the Royal drivers and the older and newer HPD in the Hilberlink site.
I forgot to add that the woofer are in fact Eminence 15" drivers with the EIA code 67. One of them must have been re-coned at some point.

I found pics of the Royals and HPD's and they look sweet! I was hoping that was what I was getting in the deal, only to find out somebody hacked them up prior.

At least the drivers work. I need to just sell them as I can't afford to find the proper basket to mate them to.

Thanks for the help!
__________________
H.H. Scott 299D (NOSValves resto), Marantz SA8003, Denon DP-3000 / Acos Lustre GST 1 / Shure M97xE, Klipsch Forté (Bob Crites upgrades), Kimber Kable 8VS, Soundstring Omega, Pangea AC-14SE, Furman PST-8
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
tannoy 615 mk 11 floor standing speakers tricia Multi-Way 2 27th July 2009 06:38 PM
Tannoy Speakers....NEED SOME ADVICE! chris-la-dies Swap Meet 2 16th February 2009 04:28 AM
Brett's Horn Speakers ( Moved from Tannoy Gold Thread) cyclotronguy Multi-Way 10 28th October 2004 09:18 PM
Does anyone know what a Tannoy Stratford speakers are like??? beta_sound Multi-Way 7 6th July 2004 12:36 AM
TANNOY Mercury M20 Speakers TheNoodPoopler Swap Meet 8 2nd June 2004 12:05 AM


New To Site? Need Help?

All times are GMT. The time now is 05:37 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright ©1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2