Go Back   Home > Forums > >
Home Forums Rules Articles diyAudio Store Blogs Gallery Wiki Register Donations FAQ Calendar Search Today's Posts Mark Forums Read

Forum Problems If there is a forum related problem please leave a message here so an Admin will see it.

Getting Redirected Several Times
Getting Redirected Several Times
Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 21st November 2017, 03:16 AM   #21
Jason is offline Jason  Australia
:)
diyAudio Administrator
 
Jason's Avatar
 
Join Date: Oct 2000
Location: Melbourne
Getting Redirected Several Times
While I'm investigating all the ways this code could be getting on to pages, I've spoken to our ad tech partners and we have now reverted everything back to barest of bones. If this issue pops up again, please get a screenshot, copy the url and email the (long, Base64 encoded) string and screenshot to badads@diyaudio.com. I'm hopeful, however, that this issue will now be resolved by the action taken.
  Reply With Quote
Old 21st November 2017, 04:05 AM   #22
Pano is offline Pano  United States
diyAudio Moderator
 
Pano's Avatar
 
Join Date: Oct 2004
Location: SW Florida
Getting Redirected Several Times
Thanks Jason, and good catch all!
  Reply With Quote
Old 21st November 2017, 09:39 PM   #23
DiyGazza is offline DiyGazza  United Kingdom
diyAudio Member
 
Join Date: Nov 2009
Location: Kent, England
Great, Thanks for taking the time and effort to look into the matter
  Reply With Quote
Old 2nd December 2017, 04:41 PM   #24
1audiohack is offline 1audiohack  United States
diyAudio Member
 
1audiohack's Avatar
 
Join Date: Dec 2010
Location: Las Vegas Nevada
Hi All;

I am getting this “open in app” redirection again over and over this morning. Grrrrr.

Thanks for all you do.

Barry.
  Reply With Quote
Old 2nd December 2017, 11:32 PM   #25
Jason is offline Jason  Australia
:)
diyAudio Administrator
 
Jason's Avatar
 
Join Date: Oct 2000
Location: Melbourne
Getting Redirected Several Times
I'd like to thank everyone for last week reporting these problems. Your feedback was really valuable.

First of all, I want to make clear that your security is my #1 priority. We need to keep the wheels of the forum running, so we need ad revenue, but not at the cost of frustrating our member or worse, potentially exposing them to malware. As a result of your feedback last week we totally disabled 3rd party ads until a solution could be found.

Our ad tech partners had been mulling a solution to this issue for some time with a company called Confiant (co-incidentally the same people who wrote the above blog post quoted by PRR). To explain it simply, Confiant offers a "malware scanner" for ads, to ensure anything dodgy is blocked before being served and never gets past their "gatekeeper".

I'm very happy to announce that about 48 hours ago we re-launched using their technology. From now on, every single ad impression from 3rd parties will be passed through Confiant to ensure that they are scanned.

Barry - based on what I have been told, it should be impossible for such a "open in app" redirection to make it through Confiant. Perhaps it came from another source (such as Google). It's possible "one slipped through the net", but this makes it even more important from now on to get the details of any such occurrence (which should now be as rare as a blue moon - we're paying for this protection and it should work well).
  1. If you think the action of clicking a link is opening the popup, please follow the steps below to try and capture the ad code that was on the original page.
  2. If you think the new page that is loaded is causing the behavior, please try to capture the ad code from the new page
  3. If you are able to copy the URL from the status bar in your screenshot, that would be great (I know sometimes these things take focus away from the URL bar and make it impossible to copy that information)
  4. Please advise your config (OS, Browser)

How to report a bad bad:
  1. Take a screenshot of the ad (or redirect / app in this case)
  2. Hover your mouse over the ad. Right-click on the ad and select "inspect". Take a screenshot of the code snippet that appears highlighted.
  3. Using ctrl+F (PC) or command+F (Mac) and search for "[sovrn] Banner". If you find a match, take a screenshot of any code snippets that appear (if any).
  4. Send screenshots to badads@diyaudio.com. This will go straight to myself and I will take immediate action to permanently block that advertiser / network and find out how they got through.

Last edited by Jason; 2nd December 2017 at 11:35 PM.
  Reply With Quote
Old 3rd December 2017, 06:34 AM   #26
1audiohack is offline 1audiohack  United States
diyAudio Member
 
1audiohack's Avatar
 
Join Date: Dec 2010
Location: Las Vegas Nevada
Hi Jason;

The “open in app” redirect hit me four times to get to this page. The screen freezes at this point and all I can do is go back and reopen the page until it lets me through.

I never open the popups here or anywhere for that matter. It happens just navigating from thread to thread on just multi way for instance.

I am on an iPhone 6s.

I will see if I can glean any information.

Thanks again.
Barry.

Last edited by 1audiohack; 3rd December 2017 at 06:37 AM.
  Reply With Quote
Old 3rd December 2017, 02:08 PM   #27
1audiohack is offline 1audiohack  United States
diyAudio Member
 
1audiohack's Avatar
 
Join Date: Dec 2010
Location: Las Vegas Nevada
This is all I am able to see;

The redirect opens a box in the middle of the screen that says Open in “App Store?”

The box at the top of the screen that tells me where I am only says data.

The screen seems inactive if I try to use the buttons that say yes or cancel.

I tried to send the screen to myself and what it is trying to send is:

data:text/html;base64.PCFETONUWBFIGhOb...

Thats all I can see.

When I try to send it to me I get a wont send error, use a proper 10 digit number. What it looks like it is trying to use is this number:

+1(1)(216)116-11

If I send it to “notes”, nothing shows up.

This is all I can see from here. If you have further suggestions for me I will be glad to help.

All the best,
Barry.
  Reply With Quote
Old 4th December 2017, 12:31 AM   #28
DiyGazza is offline DiyGazza  United Kingdom
diyAudio Member
 
Join Date: Nov 2009
Location: Kent, England
Just like to report that since my first and second run in's with redirection, I have had no further problems on a PC running Win 7 and IE 11.

I spent an Hour possibly two reading through "6L6's" Excellent guide to building the "Pass F5" last night, so lots of pages and lots of photos, but all went without a hitch.
  Reply With Quote
Old 4th December 2017, 08:25 PM   #29
Jason is offline Jason  Australia
:)
diyAudio Administrator
 
Jason's Avatar
 
Join Date: Oct 2000
Location: Melbourne
Getting Redirected Several Times
Well, I'm not sure what to make of this. I've just been advised by our ad tech partners that they made a big mistake in requesting me to switch them back on / miscommunication in their chain of command. They didn't actually have Confiant turned on for us yet. I have now reverted to our old system and switched them off. Sigh. Obviously, it's impossible for me to give you accurate information when I am not given accurate information myself, and Barry (and everyone else) I sincerely apologize for this error.
  Reply With Quote
Old 5th December 2017, 03:58 AM   #30
1audiohack is offline 1audiohack  United States
diyAudio Member
 
1audiohack's Avatar
 
Join Date: Dec 2010
Location: Las Vegas Nevada
I am grateful that you are working on it.

The worst part is that if I get off the site, I cannot even get back on since there is no back arrrow available. I get stuck on the frozen Open in App page.

Thanks again and sorry to be a pain.

All the best,
Barry.
  Reply With Quote

Reply


Getting Redirected Several TimesHide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
B+ discharge times! M Gregg Tubes / Valves 40 18th November 2011 09:56 PM
response times vitalstates Forum Problems 10 25th March 2010 07:43 PM
Times displayed an hour out godfrey Forum Problems 4 14th March 2010 06:33 AM
NE555 two times delay sunrise Solid State 15 14th March 2009 10:55 PM


New To Site? Need Help?

All times are GMT. The time now is 05:05 PM.


Search Engine Optimisation provided by DragonByte SEO (Pro) - vBulletin Mods & Addons Copyright © 2017 DragonByte Technologies Ltd.
Resources saved on this page: MySQL 15.00%
vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2017 DragonByte Technologies Ltd.
Copyright ©1999-2017 diyAudio
Wiki