Site slowdown - Page 4 - diyAudio
Go Back   Home > Forums > Site > Forum Problems

Forum Problems If there is a forum related problem please leave a message here so an Admin will see it.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 3rd May 2013, 09:43 AM   #31
AndrewT is offline AndrewT  Scotland
diyAudio Member
 
Join Date: Jul 2004
Location: Scottish Borders
Why do Members have to wait for Google analytics to download?
Dastatic? Is that needed by Members?

Why are these external links needed at all?
__________________
regards Andrew T.
  Reply With Quote
Old 3rd May 2013, 09:58 AM   #32
just another
diyAudio Moderator
 
wintermute's Avatar
 
Join Date: Aug 2003
Location: Sydney
Blog Entries: 22
Hi Andrew, I assume the google analytics is to do with the advertising engines... dastatic is one of Jason's domains. Could be for the images on the site, though I'm not sure of that, as I had to allow javascript from that domain for something to work properly (but can't remember what it was, possibly the menus along the top of the screen)...

DastaTic.com - Dasta Tic

Tony.
__________________
Any intelligence I may appear to have is purely artificial!
Some of my photos
  Reply With Quote
Old 3rd May 2013, 10:37 AM   #33
Jason is offline Jason  Australia
:)
diyAudio Administrator
 
Jason's Avatar
 
Join Date: Oct 2000
Location: Melbourne
Blog Entries: 1
Quote:
Originally Posted by AndrewT View Post
Why do Members have to wait for Google analytics to download?
The Google analytics code is asyncronous meaning it works in the background and does not (should not) delay page loading.

Quote:
Originally Posted by AndrewT View Post
Dastatic? Is that needed by Members?

Why are these external links needed at all?
Static image content (images that do not change / are not dynamic) is, arguably, best loaded from a domain other that the cookie laden primary domain of a website (we use dastatic.com, as opposed to the main domain of diyaudio.com). This is best practice to make things ever so slightly faster.

Cookies would normally be included in all the request headers for a website. On a typical website with a few hundred images on the page, that's a lot of extra data. Using an independent domain, which has no cookies at all, results in a few less byes being sent per request. While you'll find if you're using a modern browser, most small images on diyAudio are actually embedded in the HTML to save requests using the "url:data;base64" format, there are still plenty too large to use that embedded format and they were possible should be coming from datstatic. Or from Amazon Cloudfront via cdn(x).diyaudio.com.
  Reply With Quote
Old 3rd May 2013, 04:09 PM   #34
JMFahey is online now JMFahey  Argentina
diyAudio Member
 
JMFahey's Avatar
 
Join Date: Mar 2009
Location: Buenos Aires - Argentina
Quote:
I find that when I'm getting really cruddy response, it helps a lot to disable javascript in the browser.

Particularly annoying is when my browser's "hanging", and the status bar tells me it's waiting for googleads, googleanalytics or daststic.com. Sometimes I can view the page source and see that the entire page has loaded, right down to the </html> tag, but the dang browser won't render anything because it's still waiting for something I don't care about and never comes. Then I switch off javascript, refresh the page and it comes up in a jiffy.
Quote:
Why do Members have to wait for Google analytics to download?
Dastatic? Is that needed by Members?

Why are these external links needed at all?
Quote:
I had to allow javascript from that domain for something to work properly (but can't remember what it was
FWIW: Javascript is a resources burner, specially because it can be called from somewhere else and bring poorly coded script.
Yet disabling all of it at once makes for incomplete or impossible navigation.
I use the NoScript add on for Firefox, which lets me choose.

Just now, I'm navigating this page with no problems at all.
Enabled: google.com , diyaudio.com , dastatic.com
Blocked: google-analytics.com , googlesyndication.com .

Works like a charm

Try it
  Reply With Quote
Old 3rd May 2013, 04:15 PM   #35
AndrewT is offline AndrewT  Scotland
diyAudio Member
 
Join Date: Jul 2004
Location: Scottish Borders
when my screen hangs waiting for a response from DIY audio, I see in the bottom left corner
waiting for dastatic, or waiting for google, or javascript.
There are many others but they are not nearly as frequent.
But the sum of all these "waits" is a long delay in loading a page.
While the page is still loading I can scroll to a section, but as soom as the next piece of info has finished loads the scroll returns to the bottom of the page. If I scroll again the same reset happens.
It's better to wait for all the "waits" to complete and then scroll back through the two or three new posts. BUT that can be a long WAIT.
__________________
regards Andrew T.
  Reply With Quote
Old 4th May 2013, 06:59 AM   #36
diyAudio Member
 
Join Date: Apr 2013
Quote:
Originally Posted by JMFahey
FWIW: Javascript is a resources burner, specially because it can be called from somewhere else and bring poorly coded script.
Indeed it is.... I always have it DISABLED unless i need it (mediaconverter.org,etc) stuff usually loads much faster as a result


THANK YOU JAS0N for trying to make things even better
  Reply With Quote
Old 4th May 2013, 08:56 AM   #37
AndrewT is offline AndrewT  Scotland
diyAudio Member
 
Join Date: Jul 2004
Location: Scottish Borders
I did a search for "no script" in the Firefox add-ons.
It came back with 8 choices. Three have been updated this year.

Any recommendations?
__________________
regards Andrew T.
  Reply With Quote
Old 5th May 2013, 04:41 AM   #38
diyAudio Member
 
Join Date: Apr 2013
Why not just totally disable scripts bud??

99% of all sites will work w/o them......... (Then just enable them when needed )
  Reply With Quote
Old 8th May 2013, 02:11 PM   #39
diyAudio Member
 
Join Date: Feb 2009
i have never had more then 5sec delay.
  Reply With Quote
Old 19th May 2013, 08:43 AM   #40
AndrewT is offline AndrewT  Scotland
diyAudio Member
 
Join Date: Jul 2004
Location: Scottish Borders
Was "Search" switched off last night?
Maybe part of Jason's search for server resource sucker?
__________________
regards Andrew T.
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Linn Axis Power Supply:No Slowdown telecine Analogue Source 2 2nd October 2010 06:27 PM
Looking for site beamnet Tubes / Valves 3 19th September 2007 02:26 AM
Platter slowdown caused by stylus drag on modulated grooves GUILHERME Analogue Source 8 29th June 2004 08:58 PM
New site Jason Everything Else 42 1st July 2002 10:14 AM
my site filippo22 Multi-Way 0 13th July 2001 09:53 AM


New To Site? Need Help?

All times are GMT. The time now is 05:12 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2