constant timeouts - diyAudio
Go Back   Home > Forums > Site > Forum Problems

Forum Problems If there is a forum related problem please leave a message here so an Admin will see it.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 6th June 2012, 07:32 AM   #1
Luke is offline Luke  New Zealand
diyAudio Member
 
Join Date: Sep 2001
Location: Wellington NZ
Send a message via AIM to Luke
Default constant timeouts

Hi Mods,

I have been noticing poor response times form your web servers for several nights now. It is getting to the point where it has taken me 15 minutes to get to this page. I have done the usual clear web cache, cookies etc, but this has gotten to website down now. The browser tells me the connection was reset by the server.
I haven't done a network trace yet, but it could be something like a reverse proxy is struggling at your end, maybe IPS is terminating the session, or timeouts because a web server is not able to reach dependant services.
Please investigate.
__________________
If you give a man a fish he will eat for a day. But if you teach a man to fish he will buy an ugly hat. And if you talk about fish to a starving man then you are a consultant. Dilbert
  Reply With Quote
Old 6th June 2012, 08:55 AM   #2
Jason is offline Jason  Australia
:)
diyAudio Administrator
 
Jason's Avatar
 
Join Date: Oct 2000
Location: Melbourne
Blog Entries: 1
Hi Luke. Are you having any other problems with US based websites? Our server is in Texas, at Liquidweb. No problems are apparent - graphs indicate load at about 0.05 per CPU, memory fine, network traffic fine with no drops and showing regular patterns. Are the pages loading ok or is out our peripheral files (graphics, etc) which are served by Amazon Cloudfront not loading?

Has anyone else been experiencing problems?

Thanks for the report, Luke.
  Reply With Quote
Old 6th June 2012, 10:20 AM   #3
Luke is offline Luke  New Zealand
diyAudio Member
 
Join Date: Sep 2001
Location: Wellington NZ
Send a message via AIM to Luke
Hi Jason,

I loaded flagfox and tried a few sites, its amazing how many american sites are now served out of asiapac region, but anyway the gist is that some usa sites were a bit slower, digg.com wouldnt load fully, others we just a bit slower. Its not conclusive if its a usa problem.
I did a wireshark capture and I didn't see what I expected to.

3 way handshake is fine.
I do a http get and get nothing
I then follow up with two more retransmissions and get an http syn ack from you(http not TCP),
I then respond with dup ack (often means packet loss)
then begin the repetitive game of tcp retransmission and dup ack.
after a minute or so my browser says had enuff and ends with a fin.

Traces can be a difficult to figure out but this looks to me that Im not getting much back, it could be a duplex problem, ie, some of what I send gets to you and only some of what you send gets back, ie a network problem, we have a session but half of it gets lost in transit.
Cant add much else sorry, but the key is to see if others are experiencing problems, or find someone else that can debug wireshark traces

I also found another american website that timed out, it could be a NZ problem, and as we traverse aussie for one leg, you guys might be seeing too, or its on the leg to NZ. I will check out a local networking site and see if there are any reports.

Apparently my ISP has reported slow downs on international BW. Most of where I go is fine (international), a bit slower, but diya is consistently bad and timing out. Its much, much worse than the others. It seems it may be an ISP fault at my end even if it doesn't really appear to be so.
__________________
If you give a man a fish he will eat for a day. But if you teach a man to fish he will buy an ugly hat. And if you talk about fish to a starving man then you are a consultant. Dilbert

Last edited by Luke; 6th June 2012 at 10:35 AM.
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Cosmological constant.... mikeks The Lounge 402 21st February 2005 04:27 PM


New To Site? Need Help?

All times are GMT. The time now is 05:51 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2