Peavy basic 60 - diyAudio
Go Back   Home > Forums > Site > Forum Problems

Forum Problems If there is a forum related problem please leave a message here so an Admin will see it.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 4th December 2011, 02:29 PM   #1
diyAudio Member
 
Join Date: Feb 2010
Default Peavy basic 60

The amp stops at odd interfuls, could it be the Temp breaker ?
  Reply With Quote
Old 6th December 2011, 10:58 AM   #2
amptech is offline amptech  Scotland
diyAudio Member
 
Join Date: Jan 2009
Location: Glasgow
Send a message via MSN to amptech
A bit more information on this fault so a speedy out come can be made..such as, does it cut out when powered for the first few minutes of being on? or pop a fuse..etc.
  Reply With Quote
Old 6th December 2011, 11:17 AM   #3
amptech is offline amptech  Scotland
diyAudio Member
 
Join Date: Jan 2009
Location: Glasgow
Send a message via MSN to amptech
I would agree with enzo, check the send and return first. there's two ways to check the front end is working via sending the signal out to a 'spare amp' and try all the front control's next, if all is ok, move to the power amp stage check speaker connection and the speaker.
  Reply With Quote
Old 6th December 2011, 08:30 PM   #4
diyAudio Member
 
Join Date: Feb 2010
Thanks To all The input jack was the problem !
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Peavey Classic 60/60 bias mod advice RIC Tubes / Valves 7 4th November 2013 10:34 PM
WTB: 120VCT (60-0-60) transformer for balanced power supply jmillerdoc Swap Meet 2 14th April 2011 06:08 PM
Peavy windsor tube head issue rockster363 Tubes / Valves 5 21st September 2010 05:42 AM
Yamaha M-60 power amp for sale (w/ impaired C-60 preamp) rainzoneman Swap Meet 10 3rd December 2009 01:44 PM
Will someone please help me find a pedal schematic for a peavy amp galamoth Instruments and Amps 0 26th November 2006 07:41 PM


New To Site? Need Help?

All times are GMT. The time now is 01:06 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2