Can any RF expert help with an avionics problem? - diyAudio
Go Back   Home > Forums > General Interest > Everything Else

Everything Else Anything related to audio / video / electronics etc) BUT remember- we have many new forums where your thread may now fit! .... Parts, Equipment & Tools, Construction Tips, Software Tools......

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 4th July 2005, 09:02 PM   #1
OliverD is offline OliverD  Germany
diyAudio Member
 
OliverD's Avatar
 
Join Date: Nov 2002
Location: Germany
Default Can any RF expert help with an avionics problem?

I have an old (70's) navigation (ILS/VOR) receiver (108.00 - 117.95 MHz) with a defective synthesizer. I really need to fix it, but I have difficulties understanding the circuit.

As far as I understand, there are two independent oscillators, one with 4 crystals of 13.616, 13.666, 13.716 and 13.766 MHz respectively and another one with 10 crystals from 75.994 MHz to 84.994 MHz in 1 MHz steps. A very complicated multi-level switch, mechanically connected to the frequency dial, is switching different combinations of crystals, capacitors and resistors to the oscillator circuits. The oscillators seem to be very simple circuits.

However, the synthesizer doesn't produce any output most of the time. Sometimes only a group of frequencies work while at other times I receive the local airport's VOR station at various frequencies.

Can you help me by explaining how this circuit is supposed to work and what could possibly be wrong?

Any hints greatly appreciated.
  Reply With Quote
Old 7th July 2005, 12:07 AM   #2
diyAudio Member
 
Join Date: May 2005
Location: Iowa
I'm trying to wrap my mind around this. You say there are two different banks of CRYSTALS, and then another oscillator, seemingly an RC one?

If so, I believe what this is called is a double conversion superhet. The antenna input is mixed with the highest value crystals, and then that output is mixed again by the lower value and then that output is mixed again by the RC circuit to select the fine tuned channel.

Now, you are receiving a signal you know to be on whatever frequency, I'll just use 111MHz cause it's easy, on multiple settings in the receiver? My first guess is pretty obvious but maybe not that useful, and it's that big switch. If you are getting it on multiple stations, I would tend to discount the RC oscillator because it is very simple. But that big switch has a great many contacts, and if one of those is sticking or something, it could cause you to stay in the same frequency band and make you think it's coming in on multiple frequencies.

Whatever the case, you have a cool device there! Old radios are always very interesting so whatever you do, keep it. In another 10 years you may come back and figure it out, or if you're older, when a grandchild or a nephew or neice is discovering the wild world of electronics, they may want it and they might figure out what's wrong with it.
  Reply With Quote
Old 7th July 2005, 03:20 AM   #3
Stocker is offline Stocker  United States
diyAudio Member
 
Join Date: Dec 2003
Location: Austin
Ditto on the switch as a first suspect.

From an electronics tech.
__________________
Jesus loves you.
  Reply With Quote
Old 7th July 2005, 09:13 PM   #4
OliverD is offline OliverD  Germany
diyAudio Member
 
OliverD's Avatar
 
Join Date: Nov 2002
Location: Germany
Thank you very much for your help!

Quote:
Whatever the case, you have a cool device there! Old radios are always very interesting so whatever you do, keep it. In another 10 years you may come back and figure it out, or if you're older, when a grandchild or a nephew or neice is discovering the wild world of electronics, they may want it and they might figure out what's wrong with it.
Indeed, its build quality is outstanding, even compared to current avionics. My problem however is that these NAV receivers are ridiculously expensive, and I'd rather fix this old one asap instead of buying a new one. I have to have one installed on the aircraft for it being airworthy.

Quote:
I'm trying to wrap my mind around this. You say there are two different banks of CRYSTALS, and then another oscillator, seemingly an RC one?
Not really sure, but I think there are only two oscillators (only two transistors on the board anyway), one using the first bank of crystals, the other one using the second. There are two coaxial outputs from the assembly. The RC circuits belong to the crystal oscillators, I think. I could post some pictured if that would help.

Quote:
Now, you are receiving a signal you know to be on whatever frequency, I'll just use 111MHz cause it's easy, on multiple settings in the receiver?
First, the unit failed to receive on certain frequencies from time to time. Instead of hearing the morse code identifier with background noise, you would only hear clicking sounds... Later on, most of the frequency range was dead (clicking sounds or dead silence). Some stations of known frequency can be received on multiple settings, as you say.

Unfortunately, I don't think the switch is the problem. It looks like new, all the contacts (which are in fact traces on PCBs) are gold plated, wipers loaded with "real" springs and there is no visible wear at all. The aircraft is mostly operated locally for aero-tows, so the frequency dial remained on the local airport's VOR station most of the time.

Could it be that some crystals failed? Is there any method of testing them?
  Reply With Quote
Old 9th July 2005, 08:19 AM   #5
diyAudio Member
 
Join Date: May 2005
Location: Iowa
Hmmm. In that case, I think you're quite right in discounting the switch.

I suppose the oscillators are drifting but I find it hard to believe they are drifting in the right directions and just happen to be tuning to the right places so you get the same station on multiple dial settings.

The stuff you said about the outputs of the speaker is interesting. Give me awhile to think about it.

And if you can, post as many pictures as possible.
  Reply With Quote
Old 9th July 2005, 08:48 AM   #6
Enzo is offline Enzo  United States
diyAudio Member
 
Join Date: Sep 2004
Location: Lansing, Michigan
NEVER ASSUME. Check the switch contacts with an ohm meter to be sure. When troubleshooting, talking yourself into not checking something because it "couldn't" be what is wrong is the kiss of death.

If there are two osc. on your board, scope the outputs. Even a 30MHz scope will deflect at 75MHz even if greatly reduced most of the time. In any case, I'd be looking for absent oscillation rather than wrong.

SO by switching around, does this osc circuit fail on certain settings and not others? If so, then the core of it - I will also assume your transistor is for that for now - works. That transistor has no way of knowing which setting you made. SO that leaves the rest - the switch contacts, wires, the passive components.

If the unit is 30-35 years old, caps may have become leaky, so find the caps in a dead setting circuit and check or maybe subbing is easier than testing.

ANy cracks on the pc board?

Do ALL connections to this switch assembly go to this board? Or are there other destinations as well?

We want to make sure the problem is on this board rather than elsewhere. Isolate the problem.

I gotta think things are hard wired, but if there are connectors involved between boards or subassemblies, they are suspect.

For that matter, are all the Xtals OK? WHo knows what may have happened to them since it last worked. One good drop....

Beg, borrow, or buy at a hamfest a freq meter or counter and measyre the output freq of these things. Are they remotely where they ought to be - at the labelled freq?
  Reply With Quote
Old 11th July 2005, 10:46 AM   #7
Rahul is offline Rahul  India
diyAudio Member
 
Join Date: Mar 2004
Location: Lucknow , North central India
Send a message via Yahoo to Rahul
Hi!

Your Receiver seems to be of 70s vintage. When early solidstate comm gear started appearing they used a crystal mixing type synthesizer.

One bank usually controlled coarse freq setting in steps of 1mhz or 100khz depending upon tuning range of receiver. A second set provided finer tuning maybe 10khz in your case. Being a VHF set it is quite possible there may be few multiplier stages also.

Sets that had a smooth analog tuning had a LC local oscillator for second conversion.

These two oscillators had number of Xtals and these needed to be set to precise freq. Eack of the xtal has an associated trimmer capacitor for this setting. Over years it is these trimmers that often fail even though they might appear good. Replacement is only solution.

The board must be having a TP for oscillator signal. I suggest fashion out a small RF probe using germanium diode and measure the oscillator output for each xtal on a multimeter. Google will bring up lot of RF probe designs.

Regards

Rahul
__________________
We can make it work
  Reply With Quote
Old 16th July 2005, 12:14 AM   #8
mr l is online now mr l  Australia
diyAudio Member
 
mr l's Avatar
 
Join Date: Dec 2003
Location: frankston VIC
what brand of nav rxer is it?
  Reply With Quote
Old 16th July 2005, 11:10 AM   #9
diyAudio Moderator
 
pinkmouse's Avatar
 
Join Date: Apr 2002
Location: Chatham, England
Don't all these type of repairs need to be certified airworthy, or done by someone registered and insured?
__________________
Rick: Oh Cliff / Sometimes it must be difficult not to feel as if / You really are a cliff / when fascists keep trying to push you over it! / Are they the lemmings / Or are you, Cliff? / Or are you Cliff?
  Reply With Quote
Old 17th July 2005, 06:15 PM   #10
OliverD is offline OliverD  Germany
diyAudio Member
 
OliverD's Avatar
 
Join Date: Nov 2002
Location: Germany
It's a Becker NR-200.

Pinkmouse, of course these repairs need to be performed by authorized technicians and signed off afterwards. Luckily, there's someone at the local avionics shop who will sign the forms for me. He will hook the unit up to a test rig and confirm I didn't mess it up.

He also offered me a "cheap" second-hand unit, which I will buy, so it's not that urgent anymore. Anyway, it would be nice to repair the old one to have a spare just in case.

I will post pictures after the new unit is installed.
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
TL expert please help Jimmy154 Multi-Way 7 25th August 2009 05:17 PM
expert tweeks for PA? Pbassred Multi-Way 4 7th December 2003 09:57 PM
Little help from the expert please.... Mikka Solid State 14 7th June 2003 04:23 AM
Little help from the expert please.... Mikka Parts 1 6th June 2003 06:50 AM
Little help from the expert please.... Mikka Everything Else 0 4th June 2003 10:36 AM


New To Site? Need Help?

All times are GMT. The time now is 09:47 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2