Go Back   Home > Forums > >
Home Forums Rules Articles diyAudio Store Blogs Gallery Wiki Register Donations FAQ Calendar Search Today's Posts Mark Forums Read

Everything Else Anything related to audio / video / electronics etc) BUT remember- we have many new forums where your thread may now fit! .... Parts, Equipment & Tools, Construction Tips, Software Tools......

M3900 Multimeter Malfunction, can it be fixed?
M3900 Multimeter Malfunction, can it be fixed?
Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 16th June 2013, 02:45 PM   #1
csom is offline csom
diyAudio Member
 
csom's Avatar
 
Join Date: Dec 2012
Location: Homeless, sweet homeless.
Unhappy M3900 Multimeter Malfunction, can it be fixed?

Hi all,
A digital multi-meter (model - M3900, made by Mastech, bought last year ) is behaving in a strange manner. The display is not instantaneous like my other cheap one. It's showing a slow and gradual display of the reading.

For example, suppose I am taking a measurement of 12V AC, it is showing like 8....9....10....11.....12
and when I remove the probes, its going down like 11,10,9....0
And it's taking a considerable amount of time unlike my other one.

Can it be fixed?

Any help will be really helpful!
Thanks in advance.
__________________
Warm regards, Som
  Reply With Quote
Old 16th June 2013, 02:49 PM   #2
Mooly is offline Mooly  United Kingdom
diyAudio Moderator
 
Mooly's Avatar
 
Join Date: Sep 2007
M3900 Multimeter Malfunction, can it be fixed?
Probably not worth or possible to fix at component level. If you are 100% sure the meter has not suffered spillage or some other accidental amage then I would remove the batteries and place (press) tinfoil over the whole PCB to remove any residual charge that may be holding some logic in a confused state.

If thats not an immediate fix then repeat leaving the foil in place but also leave it in a hot place for 48 hours and retest.

Other than that its probably pancaked
  Reply With Quote
Old 16th June 2013, 02:53 PM   #3
csom is offline csom
diyAudio Member
 
csom's Avatar
 
Join Date: Dec 2012
Location: Homeless, sweet homeless.
Thank you sir )
I will clean the PCB with thinner and then do as per your suggestion and of course report you back.
I guess time to gift myself a new meter.
Could you kindly recommend a model that can measure capacitance too or that can be suitable for me in my hobbyist's situation?
__________________
Warm regards, Som
  Reply With Quote
Old 16th June 2013, 05:56 PM   #4
Mooly is offline Mooly  United Kingdom
diyAudio Moderator
 
Mooly's Avatar
 
Join Date: Sep 2007
M3900 Multimeter Malfunction, can it be fixed?
I wouldn't use any chemicals on it unless the PCB is contaminated.

Haven't bought a meter in years so wouldn't know off hand what to recommend. Always worth buying a good one though.
  Reply With Quote
Old 16th June 2013, 06:12 PM   #5
csom is offline csom
diyAudio Member
 
csom's Avatar
 
Join Date: Dec 2012
Location: Homeless, sweet homeless.
Just finished cleaning and dried.
Then double checked the existing tinfoil.
Latency lowered now.
But still the problem is there.
So ...... time to go shopping.

Thank you so much Mooly for you always extending helping hand. ))
__________________
Warm regards, Som
  Reply With Quote
Old 16th June 2013, 06:27 PM   #6
Mooly is offline Mooly  United Kingdom
diyAudio Moderator
 
Mooly's Avatar
 
Join Date: Sep 2007
M3900 Multimeter Malfunction, can it be fixed?
Your welcome. Good luck with the meter shopping
  Reply With Quote
Old 16th June 2013, 08:04 PM   #7
Elvee is offline Elvee  Belgium
diyAudio Member
 
Elvee's Avatar
 
Join Date: Sep 2006
Quote:
Originally Posted by csom View Post
Hi all,
A digital multi-meter (model - M3900, made by Mastech, bought last year ) is behaving in a strange manner. The display is not instantaneous like my other cheap one. It's showing a slow and gradual display of the reading.

For example, suppose I am taking a measurement of 12V AC, it is showing like 8....9....10....11.....12
and when I remove the probes, its going down like 11,10,9....0
Probably a relatively minor (but difficult to locate) problem: bad contact, split PCB track, fractured PTH, etc.
Could also be a blown fuse: sometimes, they leave a slightly conductive metal spray.
Check the main function switch, input connectors, etc: anything mechanical
__________________
. .Circlophone your life !!!! . .
♫♪ My little cheap Circlophoneİ ♫♪
  Reply With Quote
Old 16th June 2013, 09:05 PM   #8
csom is offline csom
diyAudio Member
 
csom's Avatar
 
Join Date: Dec 2012
Location: Homeless, sweet homeless.
Thank you so much Elvee.
I re-soldered what I could earlier. Inspected the PCB carefully.
I will do it again in the daylight and post my success or failure.
__________________
Warm regards, Som
  Reply With Quote

Reply


M3900 Multimeter Malfunction, can it be fixed?Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Transformer malfunction??' Coconuttopdrop Analog Line Level 12 18th April 2012 05:53 PM
EL84 fixed fixed bias razorrick1293 Tubes / Valves 3 20th November 2011 04:33 PM
Z-680 Sub Malfunction HELP PLZ!!! corsairfire Subwoofers 3 23rd June 2005 07:36 AM


New To Site? Need Help?

All times are GMT. The time now is 10:53 AM.


Search Engine Optimisation provided by DragonByte SEO (Pro) - vBulletin Mods & Addons Copyright © 2018 DragonByte Technologies Ltd.
Resources saved on this page: MySQL 15.79%
vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2018 DragonByte Technologies Ltd.
Copyright ©1999-2018 diyAudio
Wiki