Go Back   Home > Forums > General Interest > Everything Else

Everything Else Anything related to audio / video / electronics etc) BUT remember- we have many new forums where your thread may now fit! .... Parts, Equipment & Tools, Construction Tips, Software Tools......

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 21st April 2013, 02:57 PM   #1
diyAudio Member
 
Join Date: Apr 2013
Default no center output on Sony STR-K502P

I have a Sony STR-K502P home receiver. While watching a program the other day the center channel stopped working. Prior to that I had recently noticed a clicking noise like a relay switching off and right back on. I am assuming this was one of the blue rectangular relays on the main board. I have taken it apart a couple of times since and resoldered some cold joints but nothing seems to have done the trick. I also placed a non conductive thin layer of foam underneath the main board just in case it was a grounding issue. Should I replace the center channel relay? How do I determine which one is for the center channel and a part number for it. I also read in a forum that my output transistors could be bad. There are 2 for each channel. Again, which ones are for the center channel and how can I get a rating or a part number?
  Reply With Quote
Old 25th April 2013, 04:40 AM   #2
diyAudio Member
 
Join Date: Jul 2003
Location: Dona paula, Goa
It would be better if you can get hold of a schematic, but you can also trace back the connection from the speaker terminal.

Gajanan Phadte
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Sony Str-de698 microp Solid State 1 19th June 2008 08:25 PM
STR-DE975 center channel problem speekergeek Chip Amps 1 11th June 2005 05:58 PM
Sony str-de695 invisiview Swap Meet 0 8th September 2004 03:10 PM
Output problem Sony STR-DE915 gila Analogue Source 0 23rd June 2004 02:48 PM


New To Site? Need Help?

All times are GMT. The time now is 11:06 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2