Go Back   Home > Forums > >
Home Forums Rules Articles diyAudio Store Blogs Gallery Wiki Register Donations FAQ Calendar Search Today's Posts Mark Forums Read

Everything Else Anything related to audio / video / electronics etc) BUT remember- we have many new forums where your thread may now fit! .... Parts, Equipment & Tools, Construction Tips, Software Tools......

Old Sony MHC 1600 display problems
Old Sony MHC 1600 display problems
Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 16th March 2013, 07:20 PM   #1
SDWE61988 is offline SDWE61988
diyAudio Member
 
Join Date: Mar 2013
Default Old Sony MHC 1600 display problems

Hello,

I have an old sony MHC 1600 stereo system that seems to be working fine with the exception of the Display on the main componet assy. Does anyone know where I could find a service manual? I know it is an old obsolete system, but I would like to fix it, if it something simple.

Thanks,
  Reply With Quote
Old 16th March 2013, 11:00 PM   #2
JonSnell Electronic is offline JonSnell Electronic  United Kingdom
diyAudio Member
 
JonSnell Electronic's Avatar
 
Join Date: Dec 2012
Location: The Jurassic Coast, England. GB
If you have 4V A/C on the filament and -28V or more on most of the pins, the display has probably failed. Manual is here;
SONY HCD-H1600 Service Manual free download, schematics, eeprom, repair info for electronics
Hope that helps.
  Reply With Quote
Old 17th March 2013, 03:58 PM   #3
SDWE61988 is offline SDWE61988
diyAudio Member
 
Join Date: Mar 2013
Thank you. I will have to open it up this week and see if I can verify the filament. The display does light up faintly after about 15 minutes of operation. I suspected it was the problem. It is probably impossible to find a replacement new. Is there some boneyard somewhere for old audio/video systems (like a junk yard for cars or planes) on-line or otherwise that might have something like that?
  Reply With Quote
Old 19th March 2013, 05:55 AM   #4
gmphadte is offline gmphadte  India
diyAudio Member
 
Join Date: Jul 2003
Location: Dona paula, Goa
If the display lights up after some time, check power supply for charred pcb, broken solder, faulty component, and other ageing problems.

Gajanan Phadte
  Reply With Quote
Old 8th December 2013, 12:48 AM   #5
MarkF is offline MarkF  Germany
diyAudio Member
 
Join Date: Dec 2013
I have had with two MHC-1600 this problems with the same cause: The display-IC needs 32V which is made with a Villarde-cascade from 20V AC. C278 - 47u/50V - is the first cap in this cascade. It was defective on both motherboards. Bacuse the voltage across the cap is around 53V a 50V-type is "programmed" to fail, so for replacement a 63V-type is recommended.
  Reply With Quote

Reply


Old Sony MHC 1600 display problemsHide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Sony MHC-RG444s radulupu Digital Source 15 4th April 2013 06:48 PM
Old Sony MHC 1600 bump219 Digital Source 25 14th February 2012 10:28 AM
Sony MHC-16i00 display problem ginom Solid State 1 23rd January 2011 07:46 PM
MHC 1600 CD drive jefftuba Parts 0 24th May 2006 12:29 AM
Sony - MHC-1600 Stereo / CD Player Rusty777 Solid State 4 20th March 2005 05:09 PM


New To Site? Need Help?

All times are GMT. The time now is 03:04 PM.


Search Engine Optimisation provided by DragonByte SEO (Pro) - vBulletin Mods & Addons Copyright © 2017 DragonByte Technologies Ltd.
Resources saved on this page: MySQL 15.79%
vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2017 DragonByte Technologies Ltd.
Copyright ©1999-2017 diyAudio
Wiki