crate glx1200h buzzes all the time - diyAudio
Go Back   Home > Forums > General Interest > Everything Else

Everything Else Anything related to audio / video / electronics etc) BUT remember- we have many new forums where your thread may now fit! .... Parts, Equipment & Tools, Construction Tips, Software Tools......

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 5th March 2013, 03:57 AM   #1
diyAudio Member
 
Join Date: Mar 2013
Default crate glx1200h buzzes all the time

i have a crate glx1200h half stack. whenever i turn the amp on it buzzes loudly. i have tried turning down all knobs, unplugging all plugins, and hooked the head up to a different cabinet. no matter what whenever i turn on the amp it buzzes loudly all the time. has anyone ever had this problem? can anyone give me some tips on how to troubleshoot this problem?
  Reply With Quote
Old 5th March 2013, 06:54 AM   #2
Enzo is offline Enzo  United States
diyAudio Member
 
Join Date: Sep 2004
Location: Lansing, Michigan
Yes.

First, this really ought to be in the instrument amp section, so if you can't find this thread, they may have moved it there.

Look at your speaker cones, when you turn the power on, does the cone move one direction and stay there? If so turn it off immediately and do not turn it on with a speaker connected until it is fixed. That would mean ther was DC on the speaker leads. Disconnect the speaker and verify with a meter if there is DC on the speaker wires. DC will damage your speakers.

That is one reason for loud hum. The other is a loss of filtration. Wiggle your main filter caps and see if the hum intermits. If so, they need to be resoldered. Otherwise you may have a bad one. Bad filter cap will not put DC on the output.


Other things are possible, such as a problem on one of the 15v supplies or a missing one.
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Preamp buzzes when volume is at zero? deicide67 Tubes / Valves 19 11th October 2012 10:46 PM
Rebuilt Quad 306 channel but now buzzes steevo Solid State 0 30th April 2010 10:19 AM
Guitar Amp buzzes off of power inverter, will this filter work? silentblackhat Solid State 14 9th November 2006 11:39 PM
gainclone: one channel buzzes Jimmy154 Chip Amps 5 11th December 2005 07:36 AM
DAC buzzes and hisses with Denon DVD3910 but not old DVD player HeadSh0T Digital Source 6 13th May 2005 05:07 AM


New To Site? Need Help?

All times are GMT. The time now is 06:34 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2