How can I stop crackling noise from speakers? - diyAudio
Go Back   Home > Forums > General Interest > Everything Else

Everything Else Anything related to audio / video / electronics etc) BUT remember- we have many new forums where your thread may now fit! .... Parts, Equipment & Tools, Construction Tips, Software Tools......

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 5th May 2012, 02:27 AM   #1
diyAudio Member
 
Join Date: May 2012
Default How can I stop crackling noise from speakers?

I have a pair of Behringer MS20's speakers connected to an Apple TV via an optical cable. When I power on the speakers, and start to play music, there's a loud crackling sound, and I cannot hear the music. I then pause the music, then hit the play button again (on my iPhone or iPad), and the music plays fine. This is reproducable every time I power on the speakers. I have a similar setup in another room except they speakers are Behringer MS40's. I tried swapping the optical cable, the shielded speaker cable, the speakers themselves, and with the MS40's connected, the crackling occurs. I then tried plugging the speakers into a different outlet, and no crackling.

I'm almost certain the problem is with the outlet, which my TV and other equipment are also plugged into as well. Can anyone recommend how I might mitigate this crackling noise? Is there some type of line filter I could use?

-Thanks
  Reply With Quote
Old 5th May 2012, 03:07 AM   #2
diyAudio Member
 
Inductor's Avatar
 
Join Date: Feb 2006
Location: Cascais
Try disconnecting the TV antenna first and see if sound is better. Also your country/flag my help with the new connections, for pro-members technicians/engineers.
I had a similar problem with a KEF subwoofer (active) that was making a zummm sound, easy solution, I stopped using subs. My problem (had no antennas) I think that was with the different ground connections from different Amp-sets and maybe not using shielded cable, also from the mains (caps?) Surge Suppressors/Protectors, this in my case.

Last edited by Inductor; 5th May 2012 at 03:19 AM.
  Reply With Quote
Old 5th May 2012, 03:59 AM   #3
wwenze is offline wwenze  Singapore
diyAudio Member
 
Join Date: Mar 2008
Your symptoms sound like the speakers are unable to lock the signal properly on the first try, but you say a different power socket solves it, hmm...

Maybe the SPDIF connection is borderline useable, and extra noise from the AC killed it. Try a lower sampling rate/bit-depth? Or perhaps another source.
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
crackling noise in crown amp ampcabinets Solid State 4 25th April 2011 09:35 AM
Crackling noise in left channel. fritz39 Solid State 1 20th January 2009 11:57 PM
Help! New Yaoin MC-100B with intermittent crackling noise from speakers dynaudio_tube Tubes / Valves 1 1st July 2008 01:40 PM
Help with crackling noise Free0 Digital Source 0 15th June 2004 01:37 AM
Crackling/static noise from CD63ki SimontY Digital Source 5 3rd August 2003 09:23 PM


New To Site? Need Help?

All times are GMT. The time now is 07:05 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2