diyAudio

diyAudio (http://www.diyaudio.com/forums/)
-   Everything Else (http://www.diyaudio.com/forums/everything-else/)
-   -   RF interference with Topping PT-60 amp........ (http://www.diyaudio.com/forums/everything-else/208666-rf-interference-topping-pt-60-amp.html)

JoeDJ 12th March 2012 08:58 PM

RF interference with Topping PT-60 amp........
 
I got my Topping PT-60 amp (from PE) the other day but, it has serious probelm.
Today, I turned on my radio tuner and it was a disaster.

No matter what I did..... no matter where the amp or tune were pluged in, I get massive RF interference on the FM band when tunring on the amp.
I tried different FM radios....... tried plugging things in different circuits, different rooms, etc....... tried a different mains.......

This in not just ground hum. I just get white/pink noise on most all stations. Unplug the amp and stations are crystal clear.

I called PE, talked to tech support and will be Returning it.

Any idea what may cause this?
At this point, I don't know if I want a refund or a replacement.

DF96 12th March 2012 09:32 PM

Oscillating emitter follower?

JoeDJ 12th March 2012 11:14 PM

It's packed up and ready to be shipped back .
It's a shame if all PT-60s exhibit this as the amp sounds very good otherwise.

BTW, none of the other amps that I got have this problem including the really cheaply made Lepai 2020.

At the price of the PT-60, it should not be an issue!

JoeDJ 16th March 2012 11:43 PM

The PT-60 hs been shipped back to PE....they received it yesterday morning.
I miiss the amp already for its great sound.

I told PE that if it can be detgermined to be defective, I would like a replacement.
However, if it can be deterimined that all PT-60s have this same problem, I would like a refund.
I will call them monday to get an update on the matter.

JoeDJ 27th March 2012 08:55 PM

I just got off the phone to PE.
They said they can not reproduce the problem (at least that is what they claim) but, they will sending me a replacement.

I hope the new one does not have the same problem.


All times are GMT. The time now is 04:59 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio


Content Relevant URLs by vBSEO 3.3.2