Troubleshooting receiver - diyAudio
Go Back   Home > Forums > General Interest > Everything Else

Everything Else Anything related to audio / video / electronics etc) BUT remember- we have many new forums where your thread may now fit! .... Parts, Equipment & Tools, Construction Tips, Software Tools......

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 26th March 2003, 06:59 PM   #1
diyAudio Member
 
Join Date: Mar 2003
Location: Denver
Default Troubleshooting receiver

Hey all,

I got a free receiver Technics SU-G86 recently. It powers up fine, but no sound out of left speaker whatsoever. The right side has sound, but I have to turn it all the way up to hear it, regardless of the input.

I'll check fuses inside it, but thought I would humbly ask you the experts about what else I can check. I do have solder exp. and a multimeter.

Thanks in advance!
  Reply With Quote
Old 28th March 2003, 07:22 PM   #2
diyAudio Member
 
Join Date: Jul 2002
Location: South Africa
Hi,
can You see what's the output? IC (like some STK) or discrete (transistors)? If STK, change it, if discrete, measure and exchange faulty outputs and/or drivers, check resistors around them. I've found broken or dirty volume controls on some Technics things, so spray that with contact spray and see if there is signal after the control.
Hope this helps,
Jack
  Reply With Quote
Old 26th March 2004, 02:18 PM   #3
diyAudio Member
 
SVI2004A's Avatar
 
Join Date: Mar 2004
Location: Albany Western Australia
Send a message via MSN to SVI2004A
lol no dont change that ic yet....

you hear sound out of the R ch chances are that its not the output ic

the SVI / RSN series incorporate relay drive into the IC (thump/dethump/overload/dc det)

the fact you hear sound must imply you hear a click after ~4 sec

i have an amp infront of me atm doing the same thing... the fault is in the front end somewhere - possibly muting control

please post more info

- Baily
__________________
.:Ride the Lightning...Feel the Thunder:. - Technics Triple Thunder www.welcome.to/Technics oh yes ppl plz send me them dead (or Alive) STK or SVI ICs
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Troubleshooting Amp Mark245 Solid State 6 23rd December 2008 04:12 AM
troubleshooting Pioneer receiver Jim Karr Solid State 3 12th April 2005 06:49 AM
help troubleshooting amplifier/receiver please JMB Solid State 6 25th October 2004 04:14 PM
Hey i need help with receiver........EXPERTS HELP(two channel receiver) Andre Baptiste Parts 1 1st May 2004 10:20 AM


New To Site? Need Help?

All times are GMT. The time now is 10:36 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2