How to measure JLH Class A with a Scope - Page 9 - diyAudio
Go Back   Home > Forums > General Interest > Everything Else

Everything Else Anything related to audio / video / electronics etc) BUT remember- we have many new forums where your thread may now fit! .... Parts, Equipment & Tools, Construction Tips, Software Tools......

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 28th December 2012, 11:50 AM   #81
diyAudio Member
 
Join Date: Mar 2011
Default Measuring a JLH amp

Hi,

I'm quite a newbie in amp building and measurements and having looked at this thread with great interest I decided to revive it with my newbie questions...

I built a JLH-2005 mono-bloc based on Geoff's website and PCB from the following link:
JLH-2005 NOTES

It is built with 2 pairs of MJ15003 for output transistors matched at a hfe around 70. For the power supply I built two set of PCBs, a capacitance multiplier or a voltage regulator. I'm presently using the cap multiplier.
I set-up the quiescent current at roughly 1,4 A per output transistor measured across the 0R1 resistors (Q1A=0,142V, Q1B=0,142V, Q2A=0,138V, Q2B=0,141V).
Voltages measured on the output transistors seems fine, with a Vbe ~ 0,8V.

When taking AC measurements on the speaker output, I have a AC voltage of around 4mV with a frequency around 800 kHz as per the attached image.

I took this measurement in different conditions with no change:
- 1 pair of output transistor instead of 2
- Switching Q3 from a 2SC2911 to a BD139-16
- Swapping the capacitance multiplier to the voltage regulator
- Modifying the quiescent current

However, the following has an impact on the AC peak-to-peak (p-2-p) voltage of the measurement with modifying the frequency:
- Measuring at the speaker output using the chassis as a ground (the voltage moves to around 150 mV p-2-p)
- Moving a hand around the CCS and signal input part of the amplifier PCB (increases the voltage to around 50 mV p-2-p)
- Touching a heatsink with the hand reduces the voltage

I'm wondering what could cause such behavior and what I shall do to confirm and get rid of it provided it makes sense...
- Is the amp oscillating and what could cause this?
- Is the amp catching some RF ?
- ?

Looking forward to receiving any suggestion,
Jean-Francois.
Attached Images
File Type: jpg IMG00348-20121228-0942.jpg (205.5 KB, 51 views)
  Reply With Quote
Old 28th December 2012, 12:11 PM   #82
diyAudio Member
 
jan.didden's Avatar
 
Join Date: May 2002
Location: Great City of Turnhout, Belgium
Blog Entries: 7
Hi Jean-Francois,

It looks indeed either a low-level oscillation or some external influence.
Because it doesn't change with the changes you made, it most probably is external.

If you short the input of the amp, does it change?
If you disconnect the scope probe from the amp, and short the probe input to the probe ground lead, do you still see it?

jan
__________________
If you don't change your beliefs, your life will be like this forever. Is that good news? - W. S. Maugham
Check out Linear Audio!
  Reply With Quote
Old 28th December 2012, 01:10 PM   #83
diyAudio Member
 
Join Date: Mar 2011
Jan,

Thanks for your prompt suggestions.

1) Shorting the amplifier signal input, the AC is still there but with a greatly reduced amplitude
2) I'm not sure I got your second suggestion right.
After measuring the signal, I remove the probe and the signal is still there on the screen. If I shortcut the probe, the AC disappears on the oscilloscope.

Regards,
Jean-Francois.
  Reply With Quote
Old 28th December 2012, 06:56 PM   #84
diyAudio Member
 
jan.didden's Avatar
 
Join Date: May 2002
Location: Great City of Turnhout, Belgium
Blog Entries: 7
Quote:
Originally Posted by yue1970 View Post
After measuring the signal, I remove the probe and the signal is still there on the screen. If I shortcut the probe, the AC disappears on the oscilloscope.

Regards,
Jean-Francois.
So if the probe is hanging in the air disconnected from the amp, only scope ground connected to amp ground, the oscillation is still there on the screen, but if you disconnect the scope probe ground from the amp ground, it's gone?
In that situation, does moving the probe away and closer to the amp do anything?
Are both the scope and the amp on the same mains outlet? Does it change when moving them to different outlets?
Is the amp grounded through a 3-prong outlet?

jan
__________________
If you don't change your beliefs, your life will be like this forever. Is that good news? - W. S. Maugham
Check out Linear Audio!
  Reply With Quote
Old 28th December 2012, 09:13 PM   #85
diyAudio Member
 
Join Date: Mar 2011
Jan,

I tried to move the scope to another outlet without change.
The amp is grounded through a 3-prongs outlet.
The amp is also earthed internally using a star topology (I did not implement any ground loop breaker). The main earth is connected to the chassis, the chassis to the input signal RCA ground and the input signal RCA ground back to the earth star -I can draw a detailed diagram if you believe that the earthing scheme may be in cause).

I'm using a 10 ohm resistor at the speaker output for measurement purposes - I tried with and without a zobel network as well without any difference.

What's happening is a bit different from what I tried to explain - not easy to describe without being in front of the bench
Below some pictures of each measurement - in numeric mode on the oscilloscope. This should hopefully make the things clearer.

Step 1: Oscilloscope probe connected to the speaker sockets (both ground and probe)

Step 2: Oscilloscope probe hanging in the air, ground still connected

Step 3: Oscilloscope probe connected to the speaker socket - ground in the air
=> Please note that I have adjusted the range to 50 mV instead of 2 mV to enable the curve to stay on the screen

Step 4: Both probe and ground disconnected

Step 5: Oscilloscope probe connected to the speaker socket - ground connected to the chassis
=> I adjusted again the range to 50 mV

Step 6: Oscilloscope probe connected to the speaker sockets (both ground and probe) + signal input shorted
=> In this last case, frequency of measurement is quite erratic - in the range of MHz.
Attached Images
File Type: jpg Step 1.jpg (163.6 KB, 18 views)
File Type: jpg Step 2.jpg (143.9 KB, 18 views)
File Type: jpg Step 3.jpg (159.2 KB, 18 views)
File Type: jpg Step 4.jpg (141.9 KB, 17 views)
File Type: jpg Step 5.jpg (175.5 KB, 1 views)
File Type: jpg Step 6.jpg (157.1 KB, 1 views)
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Can I use a scope to measure powerline noise? Saurav Parts 23 11th July 2012 07:37 PM
Measure the output of a bridged class D ocool_15 Class D 5 20th April 2008 08:12 PM
Great deal on Digital scope. Is this enough scope? hifimaker Pass Labs 1 1st May 2007 10:59 PM
Want to measure V on the scope: should I buy a new one or build a low noise preamp? Bricolo Parts 43 1st November 2005 09:41 AM
Can I look for (or even measure) distorsion on an amp with a dual scope? Bricolo Parts 17 17th September 2003 03:06 PM


New To Site? Need Help?

All times are GMT. The time now is 06:31 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2