Welbourne Labs!!!!!!!!!!!!!!!!!!!!!!!!!! - Page 7 - diyAudio
Go Back   Home > Forums > General Interest > Everything Else

Everything Else Anything related to audio / video / electronics etc) BUT remember- we have many new forums where your thread may now fit! .... Parts, Equipment & Tools, Construction Tips, Software Tools......

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Closed Thread
 
Thread Tools Search this Thread
Old 24th August 2008, 04:53 PM   #61
jwatson is offline jwatson  Saudi Arabia
diyAudio Member
 
Join Date: Aug 2008
I'll just throw in my couple of pence worth...

I've also had a frustrating time with Welborne. I ordered a Terraplane in October 05 and received the kit three months later, missing several major components including silver wound transformers. At the time of order, I was assured of a 10 day delivery. Emails/calls alerting RW of the missing items went unanswered for around a week. The rest of the kit was then shipped over the next 5 months.

Same story as everyone else, very polite and responsive up until the moment he got my money. Thereafter, responses were virtually non-existent and somewhat curt. I called a number of times but was just switched to a machine, despite advance emails advising that I wished to discuss the shipping.

The balance of the kit was sent out via the cheapest means possible, despite the fact that I'd paid a high premium for the best delivery (stupidly believing the '10 days shipping story'). That's just theft in my opinion.

There are no logos on the amplifier but if there were I would have removed them; The amps sound good but every time I look at them I feel sick about my dealings with the company.

I will never do business with them again and would recommend others to looks elsewhere also. Sorry to start my time with this list on such a sour note but people need to be warned about this company.
 
Old 24th August 2008, 06:48 PM   #62
diyAudio Member
 
grimberg's Avatar
 
Join Date: Oct 2002
Location: California, USA
If the company is not responding and you have documentation to prove your claim, I suggest you file a complaint with the Better Business Bureau at www.bbb.org. You can also tell your story at www.ripoffreport.com. If enough people do that it may get the offending company’s attention.
 
Old 25th August 2008, 06:54 AM   #63
diyAudio Member
 
Join Date: Mar 2005
My summary:

After my unpleasant experiences with this company i ended with announcing him a deadline of 30 days ... after that i'd give all data and communication informations including all mails to my credit card company, which i also did at the end as i still did not receive anything ... three days later i've got all the missing parts with no commentary on the parcel. So i pulled back that procedure.

So in my case it's a "happy" ending, but nevertheless not amusing.

It must also be said that the products he sells are well made and the kit is packed very lavish. For example each sort of resistor, cap. myC, has it's own labeled plastic bag ... and the manual is written also very well detailed ... nearly to foolproof.

It's a pitty to see that somebody makes so much effort in his business/products and ends with this result.

To make it a constructive criticism:
Dear Ron Welborne, never say you have products in stock, when you don't have them 100% complete. And if you are overshot with some circuit boards or parts of your kits for a few weeks, then say it in advance. I think that people would easy wait for something when they'd know how long they have to wait for it.
Install a phone that you are accessible.

Smooth and good business needs mostly good communication !

artQuake
__________________
the truth is somewere
 
Old 30th September 2008, 09:31 PM   #64
ondesx is offline ondesx  France
diyAudio Member
 
Join Date: Apr 2008
Default to artquake

Hi,

Since we cannot pm you I try to contact you through this thread. It seems you constructed the Monster's Balanced preamp designed by Alexw88. How did you get the PCB ? Where do you find the PSU ? And what is your comment on this preamp ?

TIA for your feedback

My Best
 
Old 2nd October 2008, 05:18 PM   #65
diyAudio Member
 
Join Date: Mar 2005
Default to ondesx

Hi, get more Infos in This Thread

PM is acrivated ... interesting when i try to mail me i can not ... but it's activated ... Maybee admin can help ? ... whatever ...

I have some pcb boards left ... please answer on the thread above ...
i think this is the wrong one ... then we go on ...

regards
artQuake
__________________
the truth is somewere
 
Old 21st December 2012, 06:11 PM   #66
jdh is offline jdh  United States
diyAudio Member
 
Join Date: Dec 2001
Location: redlands,CA
Default They are STILL having problems

I too have had a problem... they (cunningly after reading the above posts) sent me an email stating that they were having problems with credit card payments and please pay by PayPal. I did so but with my credit card. It's now been 2 mos. and I have gotten NO response back from them after having sent 4 emails over the course of this time. Paypal could be of no help to me as they said when they brought up the payment that they could not put a dispute. WHAT? I asked them if they could look into it and they said "deal with your credit card company"... Gee thanks Paypal. I called the credit card company and they are initiating a dispute. This is NO way to run a company. I also have a small owner run business in the audio industry and I at least have returned ALL emails within (at the most) a weeks time. I sent them an email under another name and they responded to the question on their products, so I know they are getting email. If I don't hear anything within another month, I will start my own web site documenting all cases I find when posting this to boards, then we will see how much business they get. Oh yes, BTW you'll notice that there is NO contact phone number on their website anymore. I'm sure they got tired of going thru the myriad of angry phone calls about their order status.
__________________
Just another day in search of audio nirvana. Complete reno Sumo/GAS equipment, Jolida JD9 phono pre for fully modded (HufAudio.com) VPI MKIII.

Last edited by jdh; 21st December 2012 at 06:20 PM.
 
Old 15th January 2013, 12:38 PM   #67
samhill is offline samhill  United States
diyAudio Member
 
Join Date: Jun 2010
Default An Other With A Problem With Welborne Labs

Hello all, I'm curious if anyone here has had recent trouble with Welborne Labs, I saw some old posts on the topic but I'd like to know specifically about these last few months? I usually don't post bad press on people since life's complicated all around but I've tried everything and can only conclude outright fraud. I've dealt with them a few times over 20 years w/o issue, but the impression I get now is that they must be going out of business and taking orders and getting ready to run. I'm temporarily living in Italy and had my order sent here instead of my USA address, just two DC filament boards and parts while he was having a big Fall sale, a $60 order charged on oct 20 and still no delivery.

Usually from the US to Italy a light envelope like this gets to me in 1-2 weeks. Rarely anything gets held up in customs, never anything small. After a month I started sending email inquires to check if shipped or delayed and got no reply. Sent many more polite emails over the next few months and never anything back, not even an automated response! There is no phone on the website but I found it Googling. Just a machine or often no answer. I had friends stateside try calling too. I sent in a BBB complaint and got a report back from the OK BBB that they got no replies to their queries either. So I figure I just got outright scammed. I googled and saw it's happened to others here, he seems to especially blow off overseas customers. I'm trying now to deal with my card company but that doesn't look too good, not easy anyway.

If anyone here's managed to get in touch, resolve a similar problem, or can verify that the place is still in business please post or PM. Others best beware.
 
Old 15th January 2013, 01:02 PM   #68
Mooly is offline Mooly  United Kingdom
diyAudio Moderator
 
Mooly's Avatar
 
Join Date: Sep 2007


I've moved your thread here.
__________________
-------------------------------------------------------
Installing and using LTspice. From beginner to advanced.
 
Old 21st February 2013, 11:29 AM   #69
diyAudio Member
 
Join Date: Aug 2011
Thumbs down Welborne Labs does not deliver my PSU...

Hello!

I want to warn everyone not to order anything from Welborne Labs. They engaged in pure scams an do not deliver their goods. I'm still waiting for my PSU to the Sqeezebox Duet, ordered 2013.01.03

Regards,
Lasse
(Norway)
 
Old 21st February 2013, 01:18 PM   #70
Mooly is offline Mooly  United Kingdom
diyAudio Moderator
 
Mooly's Avatar
 
Join Date: Sep 2007


This is still a closed thread. Last post has been added for "information only".
__________________
-------------------------------------------------------
Installing and using LTspice. From beginner to advanced.
 

Closed Thread


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Welbourne Labs John C Parts 4 20th December 2007 01:58 AM


New To Site? Need Help?

All times are GMT. The time now is 11:01 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright ©1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2