TFT panel fails! - diyAudio
Go Back   Home > Forums > General Interest > Everything Else

Everything Else Anything related to audio / video / electronics etc) BUT remember- we have many new forums where your thread may now fit! .... Parts, Equipment & Tools, Construction Tips, Software Tools......

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 14th June 2007, 08:40 AM   #1
diyAudio Member
 
Join Date: Feb 2002
Default TFT panel fails!

I have a 15" TFT. Its a Philps 150s. It have been failing sometimes in the past. I think humidity has something to do, because it stop failiing when put it on a dry enviroment, or when put under the sun. The failing consits on dificult to swtich on, like if the lamp or inverter where wrong. Its a common problem? Maybe easy to repair or not?
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Sony X505ES Fails Hylle Digital Source 3 28th May 2009 07:57 PM
what usually fails on a sony cdx-c90? an2ny888 Car Audio 3 5th November 2008 04:45 PM
What happens when tube fails DarkOne Tubes / Valves 2 12th July 2002 07:17 AM


New To Site? Need Help?

All times are GMT. The time now is 12:19 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2