diyAudio

diyAudio (http://www.diyaudio.com/forums/)
-   Everything Else (http://www.diyaudio.com/forums/everything-else/)
-   -   butler 2150 tube amp prob (http://www.diyaudio.com/forums/everything-else/102256-butler-2150-tube-amp-prob.html)

centexhomeboy 21st May 2007 12:22 PM

butler 2150 tube amp prob
 
I have a butler tube amp that is putting out static noise and low general output both on only one channel. The amp works fine except for these problems. Could someone with experience working on these amps please let me know if this could be as easy as replacing the tube(s)? Or maybe what to check, I have good basic diy skills and equip and would like to get this amp working as I hear it's supposed to be fairly high quality and would like to get it in my car. Thanks

nelson de Leon 9th September 2008 03:11 PM

Have you tried to email BK?

TO-3 28th August 2009 06:30 PM

Quote:

Originally Posted by centexhomeboy (Post 1215160)
I have a butler tube amp that is putting out static noise and low general output both on only one channel. The amp works fine except for these problems. Could someone with experience working on these amps please let me know if this could be as easy as replacing the tube(s)? Or maybe what to check, I have good basic diy skills and equip and would like to get this amp working as I hear it's supposed to be fairly high quality and would like to get it in my car. Thanks

Is it a TD Blue 2150? or a PPI 2150?


All times are GMT. The time now is 04:56 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio


Content Relevant URLs by vBSEO 3.3.2