Trio CS-1554 Blew the PIO Intensity Capacitor, why? - diyAudio
Go Back   Home > Forums > Design & Build > Equipment & Tools

Equipment & Tools From test equipment to hand tools

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 16th December 2012, 11:00 AM   #1
diyAudio Member
 
freax's Avatar
 
Join Date: Sep 2007
Default Trio CS-1554 Blew the PIO Intensity Capacitor, why?

I was doing some measurements last night of my TDA1543 dac's I/V stage and I was using a Trio CS-1554 Dual Trace Oscilloscope when I heard a loud fizz and it was coming from the Trio.

I was using it for approximatley 15 minutes with the input voltage range set correctly.

Sure enough this afternoon I took off the covers to the Trio and noticed that the oil that had covered the inside of the case was coming from a 1500 WV PIO 0.5uF capacitor up at the front of the unit.

This unit is a fully transistorised one and works perfectly fine aside from being the age that it is and this PIO capacitor blowing.

The PIO cap in question is attached to the Intensity trimpot, The second one from the bottom.
Click the image to open in full size.

Click the image to open in full size.

What caused this? was it caused by old age or some other faulty component like the main filtering capacitor losing capacitance?, ie that one going to the trimpot from the pio cap?

I was hoping to get this cleared up as I have a sister Trio back at home and it will have an identical pair of capacitors in it that I can use for spares
__________________
Personal website: http://www.shadytreeprojects.com/ - Naturally Crazy & loving every minute of it!

Last edited by freax; 16th December 2012 at 11:23 AM.
  Reply With Quote
Old 10th July 2013, 09:52 AM   #2
diyAudio Member
 
tomtt's Avatar
 
Join Date: Aug 2002
Location: kansas city mo, and on occasion, around the world ...
Blog Entries: 15
rectifiers ... ?
  Reply With Quote
Old 10th July 2013, 10:08 AM   #3
Enzo is offline Enzo  United States
diyAudio Member
 
Join Date: Sep 2004
Location: Lansing, Michigan
Or simple random component failure.
  Reply With Quote
Old 25th July 2013, 04:54 PM   #4
seppoa is offline seppoa  Sweden
diyAudio Member
 
Join Date: Feb 2013
According to my experience, PIO caps are not very trustwhorthy, and fails by no appearant cause, maybe of old age sometimes. In my years as a TV repair technician in the ages of tube equipment I have changed thousands of PIO caps due to leakage or shorts. And they can emit lots of smoke, to scare the owners.
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Kenwood trio cs 1040 itamar Equipment & Tools 0 6th November 2011 05:00 PM
Looking for oscciloscope Trio cs-1560a remis370 Everything Else 1 31st October 2011 02:36 AM
TRIO 15Hz Oscilloscope CS-1560A engels Tubes / Valves 2 18th February 2008 10:39 PM
New PIO Capacitor! serengetiplains Parts 90 11th December 2007 07:12 PM


New To Site? Need Help?

All times are GMT. The time now is 06:06 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2