diyAudio

diyAudio (http://www.diyaudio.com/forums/)
-   Equipment & Tools (http://www.diyaudio.com/forums/equipment-tools/)
-   -   B&K 2534 DSO channel failing (http://www.diyaudio.com/forums/equipment-tools/217163-b-k-2534-dso-channel-failing.html)

TheGimp 1st August 2012 12:58 PM

B&K 2534 DSO channel failing
 
I've got a four year old B&K 2534 DSO with the second channel losing it's high frequency response (all the way down to audio frequencies) as it warms up. I noticed this recently when I was running a 1KHz test on an amp. The leading edge started rolling off.

I suspect a component is failing and sensitive to temperature, which makes isolation a bit easier. Warm it up, put a signal in and start at the input testing components with "cool-spray".

I emailed B&K requesting a schematic, but they have not responded.

Does anyone have a schematic for this DSO?

tks

Steven

TheGimp 9th August 2012 05:10 PM

CH2 is now off the screen.

B&K did not respond to my request for a schematic.

B&K wants $350 to repair it.

I'll probably get another scope. Maybe a Rigol DS1102E.

I think I'll pop the top on the B&K to see what it looks like inside.

TheGimp 14th August 2012 02:51 PM

I opted for a Tektronix 465M instead.

I may try to diagnose the B&K with it even if the parts do not have markings. At least I can isolate where the fault is. If a schematic ever becomes available I'll try to fix it.


All times are GMT. The time now is 12:07 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio


Content Relevant URLs by vBSEO 3.3.2