Speaker Workshop doesn't like my Behringer UCA202 - diyAudio
Go Back   Home > Forums > Design & Build > Equipment & Tools

Equipment & Tools From test equipment to hand tools

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 10th July 2012, 11:34 AM   #1
diyAudio Member
 
Join Date: Nov 2011
Location: UK
Default Speaker Workshop doesn't like my Behringer UCA202

I'm just getting started with my first speaker project but have hit a problem with my USB sound card, a Behringer UCA202. Going through the calibration mode of Speaker Workshop I see the attached plot. I understand that this indicates the UCA202 is a cheapskate card that duplexes the L/R channels giving bad phase distortion. Is there anything I can do about this or should I be looking at getting a new sound card?
Attached Images
File Type: png Calibrate1.png (7.7 KB, 135 views)
  Reply With Quote
Old 15th July 2012, 10:30 AM   #2
dangus is offline dangus  Canada
diyAudio Member
 
Join Date: May 2004
Location: Vancouver Island
It's supposed to be based on the same TI/Burr-Brown chip that's found in some much more expensive hardware. Maybe an ASIO driver will make a difference?
  Reply With Quote
Old 15th July 2012, 09:56 PM   #3
diyAudio Member
 
Join Date: Feb 2010
Also check the sample rate>48000 , and play with the latency values if you can.
  Reply With Quote
Old 6th August 2012, 03:26 PM   #4
ctrlx is offline ctrlx  United Kingdom
diyAudio Member
 
Join Date: Jul 2012
that curve is ok...
you put in a value for "int ch delay" to comp and get the phase flat.
  Reply With Quote
Old 21st May 2013, 12:04 PM   #5
diyAudio Member
 
Join Date: Nov 2011
Location: UK
I had to abandon working on this due to other commitments but have just found some time to play with it again.

I had tried before to alter the channel delay, to no good effect but this time around I figured out that I should try a negative value. Bingo! A -21.15 delay was enough to get the phase response almost flat - just -2 degrees out at 20KHz.
  Reply With Quote
Old 21st May 2013, 05:03 PM   #6
diyAudio Member
 
Join Date: Nov 2011
Location: UK
A bit more tweaking and it looks to be almost completely flat using a channel delay of -20.91 uSec.
Attached Images
File Type: png Measurement.Calib.png (8.9 KB, 38 views)
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Re-Jigging the jig: Speaker testing device for Arta, Speaker Workshop & HOLMImpulse MJL21193 Multi-Way 264 8th October 2012 12:10 AM
BEHRINGER UCA202 RCA output coupling cap mod ?? AC439 Digital Line Level 4 15th June 2012 07:53 PM
Behringer FCA202 and UCA202 soundcards noodle_snacks Digital Source 2 6th August 2006 09:17 PM
Speaker Workshop, help please Grahamt Multi-Way 5 10th March 2005 11:48 AM
Speaker Workshop do all this? rick57 Multi-Way 8 20th November 2004 02:11 PM


New To Site? Need Help?

All times are GMT. The time now is 09:55 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2