Troubleshoot M92A Multimeter - diyAudio
Go Back   Home > Forums > Design & Build > Equipment & Tools

Equipment & Tools From test equipment to hand tools

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 18th March 2011, 08:37 AM   #1
g4ran is offline g4ran  United Kingdom
diyAudio Member
 
Join Date: Mar 2011
Default Troubleshoot M92A Multimeter

Hi all i'm a new to the site and i was wondering if anyone can give me some advice, i have M92A multimeter and as soon as i turn it to continuity test it starts buzzing without being connected to anything the rest of the meter appears to be ok, i have looked at the pcb and all the resistors components look are surface mounted buy 2 look like they have had the solder re-run by hand (R20 + R21) i was wondering if anyone knows if these control the continuity test part of the meter thanks.
  Reply With Quote
Old 19th March 2011, 06:46 AM   #2
diyAudio Member
 
Join Date: Apr 2010
Location: Bath, UK
Think if it is the same 'M92A' as in this link:
M92A Multimeter - China meter, measurement in Meter for Electricity

you may have to contact the Manufacturer in China for the info you are looking for
Mik
  Reply With Quote
Old 19th March 2011, 10:44 AM   #3
diyAudio Moderator
 
pinkmouse's Avatar
 
Join Date: Apr 2002
Location: Chatham, England
It's not just a low battery warning is it?
__________________
Rick: Oh Cliff / Sometimes it must be difficult not to feel as if / You really are a cliff / when fascists keep trying to push you over it! / Are they the lemmings / Or are you, Cliff? / Or are you Cliff?
  Reply With Quote
Old 19th March 2011, 02:07 PM   #4
g4ran is offline g4ran  United Kingdom
diyAudio Member
 
Join Date: Mar 2011
Default Troubleshoot M92A Multimeter

Hi pinkmouse i have tried changing the battery but it made it made no difference

audiomik the meter is the same as the one in your link so i'll give them a try,

Thank you both very much for your help.
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Crescendo troubleshoot WimVL Elektor 1 29th July 2009 05:23 PM
System Troubleshoot: Need Help ronfi Analogue Source 2 17th October 2008 11:07 PM
Troubleshoot M92A Multimeter haseeb Parts 12 9th June 2008 02:39 AM
Help me troubleshoot this design, please teemuk Solid State 19 7th August 2006 11:07 PM
Help - Troubleshoot arkay Tubes / Valves 16 5th January 2002 06:53 AM


New To Site? Need Help?

All times are GMT. The time now is 08:40 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2