Weller WLC100 Problem - diyAudio
Go Back   Home > Forums > Design & Build > Equipment & Tools

Equipment & Tools From test equipment to hand tools

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 25th February 2010, 10:44 AM   #1
Doug R is offline Doug R  United States
diyAudio Member
 
Join Date: Oct 2007
Location: Indy
Default Weller WLC100 Problem

Hi All,
I have had a Weller WLC100 Soldering Station for a year or so. At first, it worked great, but lately the tips won't wet completely (even several brand new tips) and the iron won't heat the joint well unless I melt solder on the tip immediately before heating the joint. I have to do this for each joint, and get blobs of solder on the joints as a result.

I have tried different solder, new tips, tightening the set screw etc. Do I need a new element or what?

Thanks,
Doug
  Reply With Quote
Old 18th March 2010, 09:19 AM   #2
diyAudio Member
 
Join Date: Jul 2003
Location: Dona paula, Goa
U need a tip cleaning sponge. Keep it wet with water.
  Reply With Quote
Old 18th March 2010, 10:53 PM   #3
Matt BH is offline Matt BH  United Kingdom
diyAudio Member
 
Join Date: Jul 2009
Location: Cheltenham
I dont know too much about the WLC100 but I use a TCP and an EC2100. if you take the element and the guts out of the handle there should be a thermocouple or thermostat up the middle of the element contacting the tip. It is probably not contacting the tip properly and or a bit dirty.

Cheers Matt.
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Needed: Schematic for Weller EC1002 babblefish Equipment & Tools 2 9th September 2009 07:48 AM
hakko vs. weller metebalci Parts 36 27th July 2009 06:27 AM
Weller soldering iron problem rtarbell Parts 2 23rd June 2007 04:48 AM
Weller/Portasol P2C parts? obscurion Parts 2 4th February 2005 02:14 AM


New To Site? Need Help?

All times are GMT. The time now is 12:21 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2