Go Back   Home > Forums > > > >
Home Forums Rules Articles diyAudio Store Blogs Gallery Wiki Register Donations FAQ Calendar Search Today's Posts Mark Forums Read

InFocus LP-650 Power Supply Issue
InFocus LP-650 Power Supply Issue
Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 11th November 2011, 08:01 AM   #1
chris2ferz is offline chris2ferz
diyAudio Member
 
Join Date: Nov 2011
Default InFocus LP-650 Power Supply Issue

I have an InFocus LP-650 projector that has no power light. Replaced c13 due to high esr and low capacitence. Also replaced c16 which was even worse. Both fuses F1 & F2 are ok. Board number is 510-1615-01 Rev.1

Any ideas of what to check next?
  Reply With Quote

Reply


InFocus LP-650 Power Supply IssueHide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Need help with Lamda LP-531FM power supply abmoggy Parts 0 4th May 2005 05:29 AM


New To Site? Need Help?

All times are GMT. The time now is 12:19 AM.


Search Engine Optimisation provided by DragonByte SEO (Pro) - vBulletin Mods & Addons Copyright © 2017 DragonByte Technologies Ltd.
Resources saved on this page: MySQL 15.79%
vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2017 DragonByte Technologies Ltd.
Copyright ©1999-2017 diyAudio
Wiki