Go Back   Home > Forums > > > >
Home Forums Rules Articles diyAudio Store Blogs Gallery Wiki Register Donations FAQ Calendar Search Today's Posts Mark Forums Read

Infocus LP530 Blinking green light, no power
Infocus LP530 Blinking green light, no power
Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 8th June 2011, 10:29 PM   #1
fox_rivers is offline fox_rivers  United States
diyAudio Member
 
Join Date: Feb 2009
Send a message via Yahoo to fox_rivers
Default Infocus LP530 Blinking green light, no power

I picked up an Infocus LP530 DLP projector in need of repair for $10. The green light is solid when I plug it in but when I press the power button the green light blinks with no fans or lamp activity, nothing but the blinking green light.

I have plenty of soldering skills and the ability to use a multimeter. I pulled the power supply out and found no signs of burnt components or swollen/leaky capacitors. The power supply model is a MagneTek 3A49-03-100.

Are there any particular components on the power supply I should check?

I have heard of people blowing their power supplies using the wrong type of bulb but nothing is burnt or popped.

Any help would be appreciated.
  Reply With Quote
Old 8th July 2011, 12:54 AM   #2
klabrie is offline klabrie
diyAudio Member
 
Join Date: Jul 2011
Did you ever find a solution to your issue?
i have the EXACT same issue and same model... Any info would be GREATLY appreciated.

Thank you!
  Reply With Quote
Old 20th August 2011, 07:08 PM   #3
fox_rivers is offline fox_rivers  United States
diyAudio Member
 
Join Date: Feb 2009
Send a message via Yahoo to fox_rivers
Quote:
Originally Posted by klabrie View Post
Did you ever find a solution to your issue?
i have the EXACT same issue and same model... Any info would be GREATLY appreciated.

Thank you!
I haven't I set aside the projector aside for awhile and decided to work on it some more. I checked all the capacitors in the power supply and found one small cap with its microfarads a bit off. There is a cluster of large caps on one side of the board all with the value of 680 uf. I tested them all and got anywhere from 650uf to 780uf. I'm not sure if that's within tolerance. Any other components to watch out for would be a great help.
  Reply With Quote
Old 4th August 2012, 03:25 PM   #4
wbradw is offline wbradw
diyAudio Member
 
Join Date: Aug 2012
Default LP 530 - Blinking Green Light

Did you ever get a solution to this problem? I have an Infocus LP530 and after plugging it in and pressing the power button, all I get is a blinking green light. Anyone know of a solution to this problem?

Thanks
  Reply With Quote

Reply


Infocus LP530 Blinking green light, no powerHide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Infocus LP530 Phelly Everything Else 1 31st May 2010 05:37 AM
need help with infocus lp530 schauhan17 Parts 0 17th November 2008 02:01 PM


New To Site? Need Help?

All times are GMT. The time now is 12:38 PM.


Search Engine Optimisation provided by DragonByte SEO (Pro) - vBulletin Mods & Addons Copyright © 2017 DragonByte Technologies Ltd.
Resources saved on this page: MySQL 15.79%
vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2017 DragonByte Technologies Ltd.
Copyright ©1999-2017 diyAudio
Wiki