philips cd930 service manual - diyAudio
Go Back   Home > Forums > Source & Line > Digital Source

Digital Source Digital Players and Recorders: CD , SACD , Tape, Memory Card, etc.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 25th March 2007, 11:14 AM   #1
diyAudio Member
 
Join Date: Apr 2006
Location: vilnius
Default philips cd930 service manual

hello,I have problem with philips cd930,dont work servo,in display no info but it light,buttons dont work.I think that servo have no voltage .laser read disk.
I need service manual or need help.thanks.
  Reply With Quote
Old 26th March 2007, 07:51 AM   #2
diyAudio Member
 
Join Date: Apr 2006
Location: vilnius
with remote control play ok
  Reply With Quote
Old 27th March 2007, 04:31 PM   #3
diyAudio Member
 
Join Date: Apr 2006
Location: vilnius
problem is in display board,I have other philips cd930 and conect, display board for it no result,replace some trasistors no result,
buttons dont work, display show "...............................",with remote controler player work ok.display no.
  Reply With Quote
Old 28th March 2007, 09:14 AM   #4
diyAudio Member
 
Join Date: Oct 2004
Hi,

I've worked on a CD940 a bit, but only on the main board. I don;t have any schematics for the display (mainly because I think this is the main bit they change to differentiate between models).

can you trace the voltages going into the display board and see if there are any anomalies?

When you used the display from a different CDP, did you use its ribbon cable, or the ribbon cable from the faulty player?

Not being familiar with the board, that's what I'd do first.

Cheers,
Phil
  Reply With Quote
Old 28th March 2007, 07:05 PM   #5
diyAudio Member
 
Join Date: Apr 2006
Location: vilnius
I conect other display board in this philips cd and it is ok,problem in display board,I replace all transistors but no result.I find different voltages (for two boards) on some resistors,but I dont know what to do,bad display board procesor?but remote control work.I dont know this procesor is for buttons and remote or no,I can replace him,it is toshiba ,I have it. help me.thanks.
  Reply With Quote
Old 28th March 2007, 08:49 PM   #6
diyAudio Member
 
QSerraTico_Tico's Avatar
 
Join Date: Oct 2004
Quote:
Originally posted by kaulagalvis
I conect other display board in this philips cd and it is ok,problem in display board,I replace all transistors but no result.I find different voltages (for two boards) on some resistors,but I dont know what to do,bad display board procesor?but remote control work.I dont know this procesor is for buttons and remote or no,I can replace him,it is toshiba ,I have it. help me.thanks.
Is it a vacuum tube display?
  Reply With Quote
Old 30th March 2007, 11:11 AM   #7
diyAudio Member
 
Join Date: Oct 2004
Yes, it is a VFD, or vacuum tube display.

It is quite plausible that the display module is broken, but the rest of the circuitry is still fine (including IR).
I assume the keys on the front panel also work?

Cheers,
Phil
  Reply With Quote
Old 30th March 2007, 12:19 PM   #8
diyAudio Member
 
Join Date: Apr 2006
Location: vilnius
I replace all keys,I think that procesor is bad or it havent signal or voltage,I think to change procesor,but I waiting for service manual,perhaps proc is good.I think that problem in proc,because buttons dont work,procesor have voltage because show".............".
  Reply With Quote
Old 30th March 2007, 12:51 PM   #9
diyAudio Member
 
Join Date: Oct 2004
Processors can of course fail, but I'd be surprised. Unless there is a firmware issue, a processor will either work or no at all. Considering the IR is working (unless that isn't serviced by the processor) I think the processor is okay.
  Reply With Quote
Old 30th March 2007, 01:27 PM   #10
diyAudio Member
 
Join Date: Apr 2006
Location: vilnius
thanks.this problem began when I "play" with transformator,when cd was power on ,was bad contact in transformators socket,it is for display power(display no work) supply,when I conenct contact began this problem.display has power supply "......................",but something happening in display board.
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Philips CD930/CD931/CD940 service manual Bricolo Digital Source 33 15th February 2009 09:11 AM
philips cd 880 philips cd880 service manual 0519 Digital Source 4 28th August 2008 11:43 AM
Philips CD930 service manual volturnofelix Digital Source 2 27th November 2007 10:11 AM
Philips FA-911 Service manual karelg Solid State 0 13th August 2007 06:29 PM
Looking for a service manual for Philips DFA-888 JohanH Swap Meet 1 29th February 2004 06:08 PM


New To Site? Need Help?

All times are GMT. The time now is 02:21 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2