Problem in ATAPI Read Table of Content Command Post - diyAudio
Go Back   Home > Forums > Source & Line > Digital Source

Digital Source Digital Players and Recorders: CD , SACD , Tape, Memory Card, etc.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 30th September 2006, 07:24 AM   #1
buts101 is offline buts101  Nepal
diyAudio Member
 
Join Date: Sep 2006
Default Problem in ATAPI Read Table of Content Command Post

Problem in Read Table of Content Command Post
Hello guys,
I need to read the table of content of the audio cd. I'm controlling the cdrom with paulmon 8051 kit. I've successful done the basic things like hardware reset,atapi signature,drive diagnostics,master setting,drive idenfity,test unit ready.
I think the setting of atapi packet command data is ok,bcoz the eject and close tray,inquiry command,request sense ,test unit command(which all use atapi packet command) works without any problem. but when I issue any READ command such as READ table of content(43h),read sector(28h), it return no output data, it sets the error bit. When i saw the error register for sense key...i got 'Bh' as sense key which means just "Command Aborted" which the document says may be due to an overrun.
But when i use REQUEST SENSE packet command,its sense key gives '5h' which means due to illegal parameter in packet data.

Please help me here...why my code is not working for READ commands...i set allocation length of lsb and msb to FFFFh.

Is there some special initialisation that much be done before issuing the READ command.
Is software rst, and are all the mandatory command that document sf8020 says are mandatory?? As i gone through the source code of audio cd from this website...some mandatory command weren't included.

Thank you
Waiting for your helpful reply
Buts101
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem on the CDM12 when read disc! hatasa Digital Source 3 22nd October 2006 04:46 PM
Grounding / hum problem with Pioneer table draven66 Analogue Source 1 11th November 2005 01:35 PM
Philips CDC935, read problem when changing disc. air Digital Source 1 20th May 2004 11:37 AM
Sony scd-xb770 read problem. air Digital Source 6 21st April 2004 02:41 PM


New To Site? Need Help?

All times are GMT. The time now is 02:44 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2