Question : marantz cd6000 mod with NOS TDA1541 - diyAudio
Go Back   Home > Forums > Source & Line > Digital Source

Digital Source Digital Players and Recorders: CD , SACD , Tape, Memory Card, etc.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 7th December 2005, 07:00 PM   #1
kst is offline kst  Singapore
diyAudio Member
 
Join Date: Jan 2005
Location: Singapore
Default Question : marantz cd6000 mod with NOS TDA1541

hi there,
I am thinking of modifying my cd6000 OSE by replacing the 2 on board DAC sm5872bs with TDA1541A don't know if it is feasible.
From the schematics, the I2S data generated from SAA73720( which does not do any oversamling.) Then passed to this "strange" IC TC160G11AU which split the I2S data in to DOL/DOR and feed into 2 SM5872BS (L/R).
I am thinking of just replacing the SM5872BS with TDA1541A and still using the on-board HDAM stage to do filtering.
But there are some questions on the strange IC which did the data spliting which I hope some one can help.
I cannot find any spec of the IC so do not know if the IC did any signal processing before sending the split I2S data to the DAC. Also cannot confirm if the split data still be able to decode by other DAC.
Does anyone have any clue on the function of the IC apart from spliting the I2S data ?
Has anyone tried this before ?
  Reply With Quote
Old 7th December 2005, 10:04 PM   #2
guido is offline guido  Netherlands
diyAudio Member
 
guido's Avatar
 
Join Date: Mar 2002
Location: diepe zuiden
Accoding to the manual it only does l/r. But there's one signal going direct from decoder to the dac's, around the l/r chip (SCL).

The manual might help you (hint)
__________________
GuidoB
  Reply With Quote
Old 17th December 2005, 03:38 PM   #3
kst is offline kst  Singapore
diyAudio Member
 
Join Date: Jan 2005
Location: Singapore
thanks Guido. Will take a closer look at that.
  Reply With Quote
Old 25th December 2005, 06:48 PM   #4
kst is offline kst  Singapore
diyAudio Member
 
Join Date: Jan 2005
Location: Singapore
hi,

managed to get 1 channel working !! However need fine tunning on the level. The original differential HDAM in CD6000 not suitable for TDA1541A.
so now 1 channel of the set is driven by a TDA1541A configured in differential mode and using the on-board HDAM stage with some cap's and resistor value changed.

Question :

1) in the spec of TDA1541A, the filter resistor/cap value are 1.8K and 2.2nF cap. in most philips set it is 1.5K with 2.4nF cap. In this case since i am driving it in differential mode, can I just half the resistor value (to get the correct output level)? or the 1.~K ohm value is a magical value ?

2) calculating the suggested value in the spec of TDA1541A, the -3dB cutoff freq is ~40K, any additional filter stage required ?
  Reply With Quote
Old 14th January 2006, 02:30 AM   #5
kst is offline kst  Singapore
diyAudio Member
 
Join Date: Jan 2005
Location: Singapore
the set is up and running !!!

output from DAC TDA1541A only feed to the inverting path of the original differential HDAM filter.
the feedback resistance of first HDAM stage is changed from 12K to 820 ohm and feedback cap change from 120P to 470P.

Level now at 1KHz odB ~ 2.3Vrms.
However the low and high seem to drop abit ~1-1.5dB (at low 20Hz, and high >~ 10KHz).

try to replace first HDAM stage with NE5532 and LM6172..... results not so impressive.... in fact sound abit odd !! (dun noe y????)

with original HDAM stage the sound is more natural (Compared to CD850 and the new philips DVP9000)

Tent clock is also added !!
Although there are still a few things not tuned, the set is my "reference" source for CD now !!
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Marantz CD6000 Problem billman Digital Source 28 18th December 2008 11:51 PM
marantz cd6000 not playing mor2bz Digital Source 4 11th December 2007 02:58 AM
Marantz CD6000 Problem poynton Digital Source 2 29th October 2006 02:55 PM
Marantz CD6000 - a little help needed Baka Digital Source 0 3rd May 2006 08:07 AM


New To Site? Need Help?

All times are GMT. The time now is 06:36 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2