Marantz CD63 & CD67 mods list - Page 1870 - diyAudio
Go Back   Home > Forums > Source & Line > Digital Source

Digital Source Digital Players and Recorders: CD , SACD , Tape, Memory Card, etc.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 6th November 2012, 04:56 PM   #18691
diyAudio Member
 
Join Date: Mar 2009
Hi all been a while since i have been on here. Im after some help with my marrantz 67se its had some mods done its had the hdam circuit by passed it as a n external power supply but not sure what it runs i repaced the opamps with the ha screened ones, But it sounds bright and harsh with not much bottom end clout. And just wondered if there was any one in sheffield who could have a look at it and make sure its been done right
  Reply With Quote
Old 6th November 2012, 08:02 PM   #18692
diyAudio Member
 
Join Date: Oct 2012
Quote:
Originally Posted by Ben Hanke View Post
Couple of questions for the guys with multiple transformers:

I've asked this before, but do you hear any mains hum in stop mode with the volume maxed? I used to hear just the residual DAC noise, but now there's mains hum mixed in with that. I wonder if I have a 'dirty chassis' (a term I picked up investigating ground problems on audio equipment).

230v guys: If you buy a transformer with 2x115v primaries, how do you parallel the primaries? Do you tend to cut the wires shorter first?

Thanks,

Ben
Hi Ben. I have 3 Txs in my CD63 and I don't have 50Hz hum. When I crank the amp. to full power I can only hear a very slight hizzing sound from the speaker tweeter and there is no hum at all.

for the primary you should connect like this to get 230V:
_________
{
{ 115V
{__________
__________) joint these
{
{ 115V
{__________

You may cut short the middle cables before you join them together and then insulated the connections if you are not going to connect to 115V supply in future.
  Reply With Quote
Old 6th November 2012, 08:05 PM   #18693
diyAudio Member
 
Join Date: Oct 2012
Quote:
Originally Posted by bull041161 View Post
Hi all been a while since i have been on here. Im after some help with my marrantz 67se its had some mods done its had the hdam circuit by passed it as a n external power supply but not sure what it runs i repaced the opamps with the ha screened ones, But it sounds bright and harsh with not much bottom end clout. And just wondered if there was any one in sheffield who could have a look at it and make sure its been done right
Have you changed the smoothing capacitors to 10,000 - 22,000uF ?
  Reply With Quote
Old 6th November 2012, 08:15 PM   #18694
diyAudio Member
 
Join Date: Mar 2009
Quote:
Originally Posted by higlander View Post
Have you changed the smoothing capacitors to 10,000 - 22,000uF ?
Not sure i have done nothing only changed the opamps as electronics is not one of my strong points lol. I could post a pic of the board some regulaters have been changed and some big caps put on the voltage input but the work looks shabby to me and untidy. Just wondering if the person who did it knew what he was doing
  Reply With Quote
Old 8th November 2012, 12:13 PM   #18695
UV101 is offline UV101  England
diyAudio Member
 
UV101's Avatar
 
Join Date: Dec 2008
Location: Oxford
did you take any pictures? Should be easier to see whats been changed so far....
__________________
When Bitstream came out, I thought, “my God, what are we going to do...?” Ken Ishiwata http://www.hifisounds.co.uk
JA-88D Class A, Audio Aero Capitole MKII, Focal and Kimber "Leave Nothing as Standard"
  Reply With Quote
Old 8th November 2012, 08:54 PM   #18696
diyAudio Member
 
Ben Hanke's Avatar
 
Join Date: Dec 2007
Location: Vancouver, BC
Send a message via MSN to Ben Hanke Send a message via Skype™ to Ben Hanke
Thanks for your replies, folks. It seems I have my transformers wired correctly, and all my mains cables are northwest of the original transformer position so unlikely to interfere. I'll double check that the smoothing caps on the analogue rails are soldered properly, then it might be time to think about getting a scope.
__________________
Modified Marantz CD63KI -> Modified PM66KI -> B&W 805S
  Reply With Quote
Old 8th November 2012, 09:57 PM   #18697
mcd99uk is offline mcd99uk  United Kingdom
diyAudio Member
 
Join Date: Mar 2008
Location: UK
Quote:
Originally Posted by Ben Hanke View Post
then it might be time to think about getting a scope.
I'd say so. A scope, even an old one (mine is an old fluke portable job), is near essential. My CD67 would still be sitting there clicking with the disc spinning in the wrong direction without one.
  Reply With Quote
Old 9th November 2012, 08:53 AM   #18698
diyAudio Member
 
Fidelity Audio's Avatar
 
Join Date: Dec 2005
Location: Doncaster England
Quote:
Originally Posted by Ben Hanke View Post
Couple of questions for the guys with multiple transformers:

I've asked this before, but do you hear any mains hum in stop mode with the volume maxed? I used to hear just the residual DAC noise, but now there's mains hum mixed in with that. I wonder if I have a 'dirty chassis' (a term I picked up investigating ground problems on audio equipment).

230v guys: If you buy a transformer with 2x115v primaries, how do you parallel the primaries? Do you tend to cut the wires shorter first?

Thanks,

Ben
Hi Ben

I got some mains hum on mine many years ago and it was because of the location of the analogue stage psu to the transformer. I could not get rid of it. Once I built an external psu for the output stage the hum went away (obviously). Run +/- voltage into the player and direct to your output stage, if you build a good psu you will also get audio improvements.

Also doing this frees up a area for a tx to be used for other circuits

Brent
  Reply With Quote
Old 9th November 2012, 02:19 PM   #18699
diyAudio Member
 
Join Date: Mar 2009
Hi all im trying to post a pic of the mods on my player but not sure how to do it can any one helpcd player 008.JPG

cd player 003.JPG
  Reply With Quote
Old 9th November 2012, 02:23 PM   #18700
diyAudio Member
 
Join Date: Mar 2009
Ok done it this is whats been done i have only upgraded the opamps rest was done when i bought the player. Detail is not bad but trebble is harsh and bass is not as deep as i would like the midrange is not so good eather. I have had a moded 67se before and i know what thay can sound like but this one does not do it
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



New To Site? Need Help?

All times are GMT. The time now is 03:50 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright ©1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2