Go Back   Home > Forums > >
Home Forums Rules Articles diyAudio Store Blogs Gallery Wiki Register Donations FAQ Calendar Search Today's Posts Mark Forums Read

Digital Source Digital Players and Recorders: CD , SACD , Tape, Memory Card, etc.

Marantz CD63 & CD67 mods list
Marantz CD63 & CD67 mods list
Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 15th February 2012, 06:50 AM   #17941
Ben Hanke is offline Ben Hanke  Canada
diyAudio Member
 
Ben Hanke's Avatar
 
Join Date: Dec 2007
Location: Vancouver, BC
Send a message via MSN to Ben Hanke Marantz CD63 & CD67 mods list
Mine's skipping about once or twice per disc at the moment. I think it could be my choice of capacitor on the servo control digital supply. I have 6.3v 470uF NX there. I'm going to try swapping back to stock value (47uF, I think).
__________________
Modified Marantz CD63KI -> Modified PM66KI -> B&W 805S
  Reply With Quote
Old 15th February 2012, 05:37 PM   #17942
Puffin is offline Puffin  United Kingdom
diyAudio Member
 
Join Date: Feb 2006
Location: U.K
Got it sorted. Took the board out (again!!!!) and checked continuity on the L channel. Was getting signal and grd!? Turns out that when I removed the bridges I put in after removing the muting transistors, there was a minute solder bridge! Cleared that and all is well. A very sweet sounding player.

Next job is to upgrade some voltage regs.
  Reply With Quote
Old 15th February 2012, 06:29 PM   #17943
hotiron is offline hotiron  Scotland
diyAudio Member
 
hotiron's Avatar
 
Join Date: Feb 2007
Location: Aberdeen Scotland
Bridges!! What bridges? Why what where? If you bridged the mute transistors that would explain everything!
__________________
If you give up easily Dont start!!
  Reply With Quote
Old 15th February 2012, 07:57 PM   #17944
Puffin is offline Puffin  United Kingdom
diyAudio Member
 
Join Date: Feb 2006
Location: U.K
No no silly, they had been removed (presumably rather sloppily)
  Reply With Quote
Old 15th February 2012, 08:44 PM   #17945
6h5c is offline 6h5c  Netherlands
diyAudio Member
 
6h5c's Avatar
 
Join Date: Apr 2004
Location: Heerhugowaard
Quote:
Originally Posted by Puffin View Post
Got it sorted. Took the board out (again!!!!) and checked continuity on the L channel. Was getting signal and grd!? Turns out that when I removed the bridges I put in after removing the muting transistors, there was a minute solder bridge! Cleared that and all is well. A very sweet sounding player.

Next job is to upgrade some voltage regs.
Good to hear it's playing without problems now

Ray
__________________
Gonna buy my little girl a pink soldering-iron
The new DOS-CFP board is out!
  Reply With Quote
Old 16th February 2012, 12:30 AM   #17946
hotiron is offline hotiron  Scotland
diyAudio Member
 
hotiron's Avatar
 
Join Date: Feb 2007
Location: Aberdeen Scotland
Default Like Button

Can we have a like button on the forum!?
__________________
If you give up easily Dont start!!
  Reply With Quote
Old 16th February 2012, 12:32 AM   #17947
hotiron is offline hotiron  Scotland
diyAudio Member
 
hotiron's Avatar
 
Join Date: Feb 2007
Location: Aberdeen Scotland
Quote:
Originally Posted by Puffin View Post
No no silly, they had been removed (presumably rather sloppily)
Bridges or mutes Lol
__________________
If you give up easily Dont start!!
  Reply With Quote
Old 16th February 2012, 06:00 AM   #17948
Puffin is offline Puffin  United Kingdom
diyAudio Member
 
Join Date: Feb 2006
Location: U.K
I forgot to say that I picked the 63 up at an audiojumble last Sunday for 20. No remote, and the case lid was scratched to buggery (what do people do with their stuff!?)
I was told it was in fact working. I never even listened to it as standard and just pulled the board out and got to work.

I have a universal remote whih shows Marantz codes as 7008, 7018 and 7021. None of them work with it. I an only assume that the sensor is shagged.

Rob.
  Reply With Quote
Old 16th February 2012, 06:36 AM   #17949
6h5c is offline 6h5c  Netherlands
diyAudio Member
 
6h5c's Avatar
 
Join Date: Apr 2004
Location: Heerhugowaard
Have you tried flipping the remote switch at the back?

Ray
__________________
Gonna buy my little girl a pink soldering-iron
The new DOS-CFP board is out!
  Reply With Quote
Old 16th February 2012, 07:22 AM   #17950
Fidelity Audio is offline Fidelity Audio  England
diyAudio Member
 
Fidelity Audio's Avatar
 
Join Date: Dec 2005
Location: Doncaster England
LOL The old favorite

Brent
  Reply With Quote

Reply


Marantz CD63 & CD67 mods listHide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


New To Site? Need Help?

All times are GMT. The time now is 04:57 PM.


Search Engine Optimisation provided by DragonByte SEO (Pro) - vBulletin Mods & Addons Copyright © 2018 DragonByte Technologies Ltd.
Resources saved on this page: MySQL 15.00%
vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2018 DragonByte Technologies Ltd.
Copyright ©1999-2018 diyAudio
Wiki