tnt convertus dac - diyAudio
Go Back   Home > Forums > Source & Line > Digital Source

Digital Source Digital Players and Recorders: CD , SACD , Tape, Memory Card, etc.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 20th April 2004, 04:52 AM   #1
garbage is offline garbage  Singapore
diyAudio Member
 
garbage's Avatar
 
Join Date: Apr 2004
Location: Singapore
Default tnt convertus dac

hi all

i am currently building the tnt convertus dac.
it can be found at tnt website

i finished wiring up the 3 psu and tested them.

then i hooked up the receiver and dac circuit. the dac power supply's FET (IRF830) went very hot. i immediately switched it off.

do TDA1543 implementations of the DAC portion typically have pins 5, 6, 7 and 8 all in continuity with each other? this is what i get when i tested with a multi-meter.

any help would be great.

thanks.
  Reply With Quote
Old 21st April 2004, 02:21 AM   #2
garbage is offline garbage  Singapore
diyAudio Member
 
garbage's Avatar
 
Join Date: Apr 2004
Location: Singapore
just an update.

i am still troubleshooting my dac circuit, but it seems like there are some connection caused by the solder joint between tracks of the board.

currently pins 5,6,7 and 8 do not have continuity between each other.
on some pins the multimeter will short and then show an open circuit. (could be due to caps connected to that pin)

i still have to find out where the continuity on pin 4 to 6 is. pin 4 is analog ground of the dac and pin 6 is the audio left output.
  Reply With Quote
Old 21st April 2004, 10:30 PM   #3
diyAudio Member
 
Join Date: Jan 2002
Location: Cleveland ohio
you could go to Doede Duama's web site and order a printed circuit board for 20.00 U.S. Doede makes available all of the required parts....I powered mine from a 12 volt gel cell (for the DAC Tower that Draws almost half an amp) and 3 sets of Ni Cad batteries (for the reciever analog and digital supply and the clock) for a total of 4 supplies.

Sounds unbelievably good...and follows the TNT webb site ideas pretty closely.

just look up dddac 1543
  Reply With Quote
Old 22nd April 2004, 02:01 AM   #4
garbage is offline garbage  Singapore
diyAudio Member
 
garbage's Avatar
 
Join Date: Apr 2004
Location: Singapore
hi audionut

thanks for the advice.
i will order one from him if i fail to implement my p2p dac circuit.

right now everything seems ok, but when powered on without the dac chips so that i could measure voltage, i get abt the same voltage reading on pin 6 (audio left out) as on pin 5 (V+). while on pin 8 (audio right out), i get about 10 times less that value.

i've checked my wirings on pins 6 and 8 and could not spot any difference. will re-check when i am not so tired.
  Reply With Quote
Old 23rd April 2004, 10:28 PM   #5
Giorgio is offline Giorgio  Italy
diyAudio Member
 
Join Date: Dec 2003
Location: Milan
Hi Garbage,
the two exits should bedefinitely at the same level, if I remember correctly 0V, without the DAC chips...

There must be something still wrong somewhere, if you get such a difference...


Good Luck, and please let meknow your impressions.

Kind regards

giorgio@tnt-audio.com
  Reply With Quote
Old 24th April 2004, 06:28 PM   #6
garbage is offline garbage  Singapore
diyAudio Member
 
garbage's Avatar
 
Join Date: Apr 2004
Location: Singapore
hi giorgio

thanks for your reply.

i did manage to get the dac working at last, but only on one channel.

in the course of troubleshooting, i removed 2 of the 4 dacs from the parallel configuration to make it easier to spot the problem.

i managed to have it running with 2 dac instead. the sound is not good. there seem to be echos what a track is played. when one of the dac is removed, everything sounds fine.

it seems that paralleling the dac with wires soldered point to point is not ideal (there are many different lengths). maybe this caused the signal to reach the outputs (pin 6/8) at a slight delay, thereby causing the echo.

also, the noise level is not low. i just came back from a diy gathering. there were several non oversampling dacs in a shootout. there were 2 dacs that uses nimh batteries, one with a tube buffer, and the fourth, i'm not too sure of the configuration. all had their good points. i am also impressed by the compactness and neat soldering of the components.

i am in the midst of soldering a new board with just one dac for testing. this board uses most of the parts mentioned in the dac schematic on tnt, except the low pass filter using 680pf caps and the 680ohm resistor. i also removed the 1uH choke that is in series at right and left output. i have also taken care in making the board neat. hope this will bring down the noise level somewhat.

will keep you informed of the progress.
  Reply With Quote
Old 25th April 2004, 07:01 AM   #7
garbage is offline garbage  Singapore
diyAudio Member
 
garbage's Avatar
 
Join Date: Apr 2004
Location: Singapore
updates to the dac section.
there is a regular hi-frequency buzz on the speakers when using the dac.
also, the output stage is not able to drive my passive preamp even when the voltage is raised to 8V for the dac. there was no difference from 5V to 8V, volume did not increase.

any ideas on what might be wrong?

my current L and R pins are as follows:
pin ---3.3R--- 0.47uF solen --- RCA out
| |
+10uF brandless poly+

original config as suggested by tnt-convertus dac:
pin -+-----+--1mH inductor---3.3R--+---+--0.47uF+--- RCA out
| | | | |
| | | +-10uF--+
680pF 680R 1nF
| | |
G G G

lines did not come out correct....
hope you guys can decipher it.
  Reply With Quote
Old 25th April 2004, 09:32 AM   #8
diyAudio Member
 
Andypairo's Avatar
 
Join Date: Sep 2002
Location: near Milano , Italy
Quote:
Originally posted by Giorgio

giorgio@tnt-audio.com
Ciao Giorgio,
nice to have you on this board!
Cheers

Andrea
  Reply With Quote
Old 25th April 2004, 01:28 PM   #9
diyAudio Member
 
Bernhard's Avatar
 
Join Date: Apr 2002
Location: Munich
HI,

I have cut out the DAC section ( TDA1541 + decoupling caps ) from a Philips CDP board and connected it with simple wires parallel to the DAC section of a Philips CD650.

Really no problem, with the right choice of selected chips, performance gets better.


Bernhard
  Reply With Quote
Old 25th April 2004, 01:52 PM   #10
Banned
 
Join Date: Apr 2002
Location: Germany, Clausthal
From my experinece you will need a real preamp, and cant drive a volume pot direct with the TDA1543. I would not use to much voltage, try 5V. Im not sure many devices is parallel necessarily are better than only one. I got noise like you describe in connection with wrong values of resistor from Iout to GND and Vref to GND. Good results( with one chip) i got with something like 100 or 200R at Vref and 1100R for Iout. But i also was told this values are terribly wrong....
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
PCB need for TNT-convertus DAC gravir Digital Source 9 8th December 2004 12:44 AM


New To Site? Need Help?

All times are GMT. The time now is 08:21 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2