CD Player doesn't detect disc sometimes - diyAudio
Go Back   Home > Forums > Source & Line > Digital Source

Digital Source Digital Players and Recorders: CD , SACD , Tape, Memory Card, etc.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 2nd January 2004, 01:32 PM   #1
Gartak is offline Gartak  Brazil
diyAudio Member
 
Join Date: Jan 2004
Location: Brazil
Send a message via AIM to Gartak Send a message via MSN to Gartak Send a message via Yahoo to Gartak
Default CD Player doesn't detect disc sometimes

I have a 6 month old Coby MP3 Discman (http://www.cobyusa.com/product/item2.php?curitm=MPCD550). All of a sudden, it stopped detecting discs. If I insist, removing and putting the same CD again several times, it will eventually detect and play it perfectly.

I disassembled it, cleaned lens, checked if the head assembly was stuck, all was ok. Lens go up and down trying to detect the disc, but when it fails to detect the disc, it displays "no disc" just after the lens stop moving and before the CD spins. Everytime the CD gets to the point of spinning, it works well, playing the CD. I noticed that when it was reassembled, it started to detect the CDs correctly more times than before.

Since warranty is over and it's not so cheap (US$49.88 at Amazon), I would like to fix this device myself. So I ask: how can I pinpoint the cause of the problem and fix it? Bad solders? Bad ribbon cables? I'm experienced with soldering, even SMDs, if that is necessary.

Thank you all in advance for any ideas.
  Reply With Quote
Old 2nd January 2004, 02:06 PM   #2
cm is offline cm  Singapore
diyAudio Member
 
Join Date: Sep 2003
Location: Singapore
I had the same problem with my CD player. Changing the solved the problem. Tweeking the pot on the flex of the lazer ( very slightly ) got me a few more days of use before the lazer died.

It could also be that the flex circuit connecting lazer to the board is not connected properly. Make sure it is plug in all the way before you push the connector catch in. It could be that you have a badly assembled flex. If it still does not work....
  Reply With Quote
Old 2nd January 2004, 10:41 PM   #3
Gartak is offline Gartak  Brazil
diyAudio Member
 
Join Date: Jan 2004
Location: Brazil
Send a message via AIM to Gartak Send a message via MSN to Gartak Send a message via Yahoo to Gartak
Thanks a lot for your reply!

Just one thing, I think you missed a word, you didn't say what exactly you replaced to fix your player. What was it?

Anyway I'll try to check the ribbon cable and I won't touch the trim, at least for now.

Thanks again!
  Reply With Quote
Old 3rd January 2004, 02:06 AM   #4
cm is offline cm  Singapore
diyAudio Member
 
Join Date: Sep 2003
Location: Singapore
Sorry, my mind is fast by the fingers are weak.

I replaced the lazer module. It cost me about 10 USD ( Philips VAM1202 ). It is likley your lazer module is a Sony and should cost about 8 USD. However, since your player is so new, it is not likely to be the lazer unit.

Where are you in Brazil? I have been to Sao Paulo three times in the last six months and I love it. The people are so friendly and the city is so pretty. I will be back in Sao Paulo again in three weeks. Have to pick up some Portugese....
  Reply With Quote
Old 3rd January 2004, 11:58 AM   #5
Gartak is offline Gartak  Brazil
diyAudio Member
 
Join Date: Jan 2004
Location: Brazil
Send a message via AIM to Gartak Send a message via MSN to Gartak Send a message via Yahoo to Gartak
Thanks for the explanation!

Last night I opened the thing again, diconnected and reconnected all ribbon cables I could, removed the main circuit board and pushed all components I could. Now the player seems to be working well again! At least 20 succesful CD detections, no more failures so far.

But I noticed some ugly solder joints in the board, I'm sure I'll have problems with this in the future, but I'll leave it as is for now.

Thanks for the help! About São Paulo, it's my city! I was born here. I like it very much, even if sometimes I think it's too crowded and violent. If you need help with anything in here, just tell me! My email is emarco@uol.com.br.

Thanks again!
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Disc Tray problem on DVD player. ashok Everything Else 2 18th September 2007 05:48 AM
Converting CAL CL10 5 disc player to a single disc player stoolpigeon Digital Source 0 27th May 2007 01:25 PM
Thorens Disc Player exurbia Analogue Source 2 30th May 2005 09:39 PM
CD player not recognizing disc jarthel Digital Source 6 27th March 2005 12:57 AM
CD player does not detect CD - pickup problem? cm Digital Source 12 8th December 2003 08:09 AM


New To Site? Need Help?

All times are GMT. The time now is 08:16 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright ©1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2