Thule spirit cd 100 - diyAudio
Go Back   Home > Forums > Source & Line > Digital Source
Home Forums Rules Articles diyAudio Store Gallery Wiki Blogs Register Donations FAQ Calendar Search Today's Posts Mark Forums Read

Digital Source Digital Players and Recorders: CD , SACD , Tape, Memory Card, etc.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 12th February 2014, 04:44 AM   #1
quan is offline quan  Australia
diyAudio Member
 
Join Date: Feb 2007
Location: sydney
Default Thule spirit cd 100

Hi guys. I was given a Thule spirit 100 cd player with some issues. It loaded and read the disc ok but there is a few different noises ie hum in the back ground, also static sound which intermittently dropping off. I did cleaned the laser but made no difference. I would like to fix the problem and perhaps upgrade the clock later. Please advise where i should be looking or do measurements to trouble shoot. I can only see some brown discoloration btw the blue block caps( marked 1uF). TIA.
Quan
Attached Images
File Type: jpg IMG_6724-1.jpg (91.2 KB, 96 views)
File Type: jpg IMG_6727-1.jpg (110.0 KB, 90 views)
File Type: jpg IMG_6725-1.jpg (92.1 KB, 92 views)
  Reply With Quote
Old 12th February 2014, 04:48 AM   #2
quan is offline quan  Australia
diyAudio Member
 
Join Date: Feb 2007
Location: sydney
Another picture- overall view. The laser i can see is Sony 213B mechanism.
Attached Images
File Type: jpg IMG_6726-1.jpg (118.8 KB, 90 views)
  Reply With Quote
Old 14th February 2014, 08:26 PM   #3
quan is offline quan  Australia
diyAudio Member
 
Join Date: Feb 2007
Location: sydney
No suggestions guys?. The main analog board is all smd stuff and no schematics so i am not sure where to start. Distorted sound could be from the D/A chip? or surrounding filter caps?.
Quan
  Reply With Quote
Old 15th February 2014, 04:58 AM   #4
diyAudio Member
 
Join Date: Oct 2006
Not meaning any insult, but this player is barely better than junk. It's built as cheaply as possible, with just enough "extra" to make a feeble attempt at marketing it as a high end piece, i.e., the TCXO clock, 24/96 dac chip(albeit the cheapest early in format PCM1716), and, well, nothing else. I would consider it barely worth repairing, let alone upgrading. The symptoms could be caused by the cheap few thru-hole lytic caps on the supply board, by any or all of the SMD lytic caps on the audio board, by a defective PCM1716 dac chip, or by bad output opamp(can't make out the #, but that 14pin smd chip near the jacks is placed like a quad opamp for output stages), or by a combo of faults of above. Unless it turns out that replacing the power supply board lytic caps cures it, it would not be easy to track down the problem(s). I would personally give up after replacing the supply caps if they didn't fix it, and use the quite nice power transformer & TCXO clock for more worthy projects, and save the cheap but reliable Sony laser/mech for the next player needing it.
If I were Thule & retailing this player for more than $150usd, I'd be embarassed as hell for anyone to take the lid off it.

Last edited by stephensank; 15th February 2014 at 05:00 AM.
  Reply With Quote
Old 15th February 2014, 10:34 AM   #5
quan is offline quan  Australia
diyAudio Member
 
Join Date: Feb 2007
Location: sydney
Thank you Stephen. My gut feeling is the same when i first opened up the lid. I am not confident with working on smd parts esp without the schematic. I certainly would not want to buy the schematic for 30euros if it is not going to make head waves. I tried to run the player with external DAC and the distortion is much better but still some noise(crackling) but only on the right channel. I would go ahead and change the PSU caps to see if it makes any difference.
Quan
  Reply With Quote
Old 5th April 2015, 02:08 AM   #6
diyAudio Member
 
Join Date: May 2010
Send a message via Skype™ to shizaudio
Hi quan, would you please share the both sides photos of the PSU board?
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Thule spirit IA100 gekolikegrow Solid State 1 22nd December 2014 10:37 AM
Philips CD-100/CD100 (First Generation CD Player) - Main Switch needed tiefbassuebertr Digital Source 0 16th December 2013 07:32 PM
Tray don't stop by Primare CD20 and Thule CD-100 (both MK-1) after Switch-On tiefbassuebertr Digital Source 0 4th December 2012 06:43 PM
Anyone modded Thule Spirit 150B? anubisgrau Digital Source 3 14th July 2010 03:43 PM
cd-100 and more audiophile_81 Digital Source 8 20th July 2007 04:49 PM


New To Site? Need Help?

All times are GMT. The time now is 05:25 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
Copyright 1999-2016 diyAudio

Content Relevant URLs by vBSEO 3.3.2
Wiki