Need help! My CD player not working - diyAudio
Go Back   Home > Forums > Source & Line > Digital Source

Digital Source Digital Players and Recorders: CD , SACD , Tape, Memory Card, etc.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 18th December 2003, 10:55 AM   #1
dh001 is offline dh001  Singapore
diyAudio Member
 
Join Date: Dec 2003
Location: Singapore
Default Need help! My CD player not working

Using Marantz Cd63KI, have done some mods on it, power supply caps, coupling caps, op amp.
One day when I was trying to fix a bypass cap to the opamp power supply caps and fix back the pcb board......the disc can't spin after this!!!

The optical pickup was newly replaced and it's working ( I can see the red color laser beam, and the pickup is moving up/down )


I have enter into service mode and it shows Error code 10 ( Radial Err ), I have check all the ribbon wire connector all OK. The Decoder IC SAA7345 and Servo IC TDA1301T was replaced, all the componet near SAA7345 was replaced, the RF circuit was check but i just can't get the problem solve !!!!

Really need help here ..... coz i dun wanna scrap these player.

thanks a lot
  Reply With Quote
Old 3rd January 2004, 05:07 AM   #2
diyAudio Member
 
Join Date: Dec 2003
Location: Sydney
Have you got the circuit diagram?

Check 3 low noise dual OPs in transport section. They are VERY easy to destroy. Also, definitely check the ribbon cable and if it makes a good contact with clip in connectors. You have checked it, I know, but re-check it!

Each of those 3 OPs does TWO functions, use the circuit diagram and find one, which controls radial movement of the lens/laser.
Measure the voltages at the output pins and compare with the circuit diagram. If okay, measure conductivity between output pins and RF circuit board located underneath of the transport mechanism. For this, you may have to remove main PCB and transport mechanism and connect them together and turn them upside down on you working bench/desk/table. This will allow you to check conductivity of all ribbon cable pins-the most common poin of the problem you described. If okay, measure voltages at 4 input pins of the OP in question. Two pins should 'sit' on the reference voltage (very close to +5V), and two should receive proper voltage from the 1301. I am referring to all the input pins for BOTH OPs inside of the one IC. As I mentioned, you'll need a circuit diagram.

I can scan the transport control section of the circuit diagram and e-mail it to you. I suggest you to get the whole circuit diagram and stop replacing components hoping that you’ll fix the problem. Use the diagram!

Good luck
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
CD player not working fine, help needed Assyst1606 Digital Source 28 24th August 2008 05:38 PM
Non working Denon DVM-4800 dvd player ostie01 Digital Source 0 16th March 2007 04:52 AM
Wanted: Leftover DAC from an upgraded CD player, or CD player with broken transport. Spasticteapot Swap Meet 0 7th October 2006 09:12 PM
AIWA cd player working intermittently. Marcio Cunha Digital Source 1 11th August 2006 05:46 AM
WTB Krell KSA Mk2- working or non working Jozua Swap Meet 0 20th March 2006 12:14 PM


New To Site? Need Help?

All times are GMT. The time now is 11:49 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright ©1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2