Marantz CD63ki problem - diyAudio
Go Back   Home > Forums > Source & Line > Digital Source

Digital Source Digital Players and Recorders: CD , SACD , Tape, Memory Card, etc.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 11th April 2013, 08:04 PM   #1
diyAudio Member
 
Join Date: Apr 2013
Default Marantz CD63ki problem

Hi everyone. I've been reading these forums for a while but have finally joined to post a problem I now have.
My 63Ki recently stopped reading discs or playing them. You could see the laser trying to focus and failing and the disc wouldn't spin. After reading much here and doing a diagnostic test that came up with an error 2 fault I decided it was the common and much publicised laser failure.
I am reasonably competent with a soldering iron so I bought a new genuine replacement part and installed it following the instructions on this forum somewhere. I now have exactly the same fault occurring as before! I went back to the supplier who told me 'There is no possibility of an original Philips part being faulty out of the box' and patronised me by saying it is 'easy to make a mistake with the installation'. He went on to say it can be caused by an open circuit or drive failure and if I have the model number it is possible to find out the parameter being measured to give the error code and better diagnose the fault I am having.
Does this sound plausible or am I being led up the proverbial garden path or has someone had this fault before and know what the fix is?
Thanks in advance and great forum!!

Andy.
  Reply With Quote
Old 12th April 2013, 08:32 AM   #2
UV101 is offline UV101  England
diyAudio Member
 
UV101's Avatar
 
Join Date: Dec 2008
Location: Oxford
There is a thread on this forum relating specifically to CD63's and its 19,000 plus posts long.
__________________
When Bitstream came out, I thought, my God, what are we going to do...? Ken Ishiwata http://www.hifisounds.co.uk
JA-88D Class A, Audio Aero Capitole MKII, Focal and Kimber "Leave Nothing as Standard"
  Reply With Quote
Old 12th April 2013, 02:19 PM   #3
diyAudio Member
 
Join Date: Apr 2013
I did see that and have flicked through it but the majority of it seems to be about mods rather than faults and fault finding. 1000+ pages is some reading!!

Andy.
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Marantz CD63KI Biskit Digital Source 3 6th May 2013 07:21 AM
Marantz CD63KI Not Recognising CDs dlflclhl Digital Source 21 14th April 2013 10:33 AM
Help needed with Marantz cd63ki not recognising discs mercedesjenz Digital Source 1 18th October 2008 02:12 PM
Marantz CD63KI - XO clock in, sound bad... Zombie Digital Source 30 2nd April 2008 08:02 PM
Part number for Marantz CD63KI Laser needed urgently Mesh Digital Source 2 13th December 2004 05:33 AM


New To Site? Need Help?

All times are GMT. The time now is 09:00 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2