Wadia 21 Dead laser or servo problems? - Page 4 - diyAudio
Go Back   Home > Forums > Source & Line > Digital Source

Digital Source Digital Players and Recorders: CD , SACD , Tape, Memory Card, etc.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 7th February 2013, 10:38 AM   #31
diyAudio Member
 
Zero Cool's Avatar
 
Join Date: Sep 2004
Location: MN
Quote:
Originally Posted by Mooly View Post
The "virtual ground" thing is a bit weird on these. M52104 ? this is a 52103.

Couldn't find anything on that either...
But even that schematic you posted correctly shows Pin 1 as VC and Pin 6 as ground! and I do see in your schematic that the Pin 1 line goes to a VC test point. where as the VRDS-T1 (and hence Wadia 21) is not shown or as verified, connected that way! I really think this is a Teac factory mistake!
__________________
It's not about what you can BUY...It's about what you can BUILD!
  Reply With Quote
Old 7th February 2013, 12:40 PM   #32
Mooly is offline Mooly  United Kingdom
diyAudio Moderator
 
Mooly's Avatar
 
Join Date: Sep 2007
I doubt there's a factory error tbh.

In your diagram it doesn't actually say that pin 1 on P701 goes to Pin 1 on the KSS. It implies as much but doesn't quite go as far as showing that.
__________________
-------------------------------------------------------
Installing and using LTspice. From beginner to advanced.
  Reply With Quote
Old 7th February 2013, 12:48 PM   #33
diyAudio Member
 
Zero Cool's Avatar
 
Join Date: Sep 2004
Location: MN
I pinned it out, I took the dead laser apart and with a multimeter checked that Pin 1 really is connected as show and that Pins 5&6 are also as shown and the PCB's are labeled as to which is Pin 1 etc. So YES It is connected as shown!

But what I did find on a sony schematic for a cd player that also used the KSS-240A is that VCC is shown as +5, Gnd is gnd but VC is shown as +2.6v or almost have of VCC so maybe VC is not -5 but a half supply reference?? and if the T! is running off +/-10V Gnd would be half reference! But still every schematic i can find shows these lasers and pretty much all the KSS series to be running from +5v. without a datasheet it's hard to know but it's interesting.
__________________
It's not about what you can BUY...It's about what you can BUILD!
  Reply With Quote
Old 7th February 2013, 01:03 PM   #34
Mooly is offline Mooly  United Kingdom
diyAudio Moderator
 
Mooly's Avatar
 
Join Date: Sep 2007
Have you actually measured the voltages for real to see what they are.
__________________
-------------------------------------------------------
Installing and using LTspice. From beginner to advanced.
  Reply With Quote
Old 7th February 2013, 01:35 PM   #35
diyAudio Member
 
Zero Cool's Avatar
 
Join Date: Sep 2004
Location: MN
Quote:
Originally Posted by Mooly View Post
Have you actually measured the voltages for real to see what they are.
Yup! All voltages are as labeled!
__________________
It's not about what you can BUY...It's about what you can BUILD!
  Reply With Quote
Old 7th February 2013, 04:57 PM   #36
Mooly is offline Mooly  United Kingdom
diyAudio Moderator
 
Mooly's Avatar
 
Join Date: Sep 2007
Quote:
Originally Posted by Zero Cool View Post
Yup! All voltages are as labeled!
You mean with 10 volts across the pickup. Very strange I agree but I think you have to take it as correct.
__________________
-------------------------------------------------------
Installing and using LTspice. From beginner to advanced.
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Dead Dead Laser Pickups - why not replacing the Diode only? Salar Digital Source 20 24th July 2013 09:34 PM
Wadia Drive 8 Laser unit Wim J Digital Source 12 10th June 2013 07:48 PM
Wadia 6 with tracking/focussing/problems RobertS61 Digital Source 2 19th February 2011 06:55 PM
Wadia 21 schematic wanted Alfetta87 Digital Line Level 11 11th March 2009 02:20 PM
Wadia 21 chipset Alfetta87 Digital Source 3 22nd November 2006 02:27 PM


New To Site? Need Help?

All times are GMT. The time now is 01:54 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2