diyAudio

diyAudio (http://www.diyaudio.com/forums/)
-   Digital Source (http://www.diyaudio.com/forums/digital-source/)
-   -   Rotel RCD 855 diagnostics...need help (http://www.diyaudio.com/forums/digital-source/226861-rotel-rcd-855-diagnostics-need-help.html)

chromenuts 2nd January 2013 04:34 AM

Rotel RCD 855 diagnostics...need help
 
Rotel RCD 855 stopped working...flashes an error light, stops playing disc. Currently not spinning up discs and reading TOC.

So I find a thread on here about someone trying to do diagnostics on another 855 with an error.

I was able to absorb enough information that I have successfully used his reference to diagnostic procedures outlined in Philips CD582 manual to figure out how to put my Rotel into service mode and follow to the best of my ability the flow charts they outline for diagnosing problems.

It turns on. The display works. No clicks or pops. I can open and close the tray to load a disc.

Table Of Contents is the first catch...sometimes it was spinning and reading, other times it wasn't. Currently it isn't. and it hasn't since I tried starting the player back up after lunch the other day I believe.

At first I am just trying to toggle through the different service positions to see what happens. I remove the Lid again so I can observe what happens better.

Following the B leg in the service flow chart I confirm the service software is running on the display.

Using the search buttons I am able to move the laser head back and forth along its entire travel...OK radial motor should be good.

I don't have the remote to the player any more, so I can't perform the infra-red test of the photodiodes. To be honest even if I did I don't think I understand the procedure based on the cryptic chart outlining it.

I skip over the photodiodes test and I am able to confirm that the laser appears to be glowing red when I turn off the lights in the room...although faintly. When I toggle with the Track button into the Service 1 position the laser cycles through its focus movement.

I refer back to to the A path on the chart and put together the relevance of the C path tests and there functions. I perform them with and without a disc present in the machine. The results are as follows:

Position 0 gets me display of software code

Position 1 gets me laser activation and focus movement

Position 2 gets me nothing

Position 3 gets me movement of the laser pickup to its outer most point with no disc. With a disc loaded I get noise that sounds like the pickup banging against the end of its travel path and sometimes the error light comes on and I get 03 on the track screen.

I am assuming that it is giving me an error code 3 even though I can't follow the flowchart through to the E position through either the C or E diagnostic path.

The error code 3 description states No lead-in track found and to check CD disc, radial arm position, REdig (Radial Error digital) and Radial error processor.

I suppose not getting any disc movement after toggling to Position 2 is enough to tell me that either the disc motor is dead/dying or part of the circuit that controls it is screwed up?

The No lead-in track could be due to the fact that the motor wasn't spinning the disc...and I tried several high quality discs so a disc problem is not likely. As far as the radial error issues I am not sure what to make of them...as I said the radial motor seems to be moving the pickup properly.

I traced some references in the Philips flowchart (6510, 6511, 6512) to what looks like some transistors in the motor control circuit...and found what looks like a similar circuit in a much less detailed and poorly reproduced copy of a service manual for the Rotel 855.

I'm not sure how to proceed from here. Can I assume the motor is dead? Am I out of luck unless I can find a replacement CDM unit? Or is there other testing that can be done to the motor, its control circuit or something else I may have missed? Any feedback from the experienced here is greatly appreciated.

I should mention that I have only a basic multimeter and electronics skills and understanding. I want to put the work in to try and fix this though. Thanks.

Kevin

chromenuts 8th January 2013 01:46 AM

Well this sucks. I can't believe no one has any advice to offer on this issue.

I've been searching locally for any vintage players that might contain a CDM4 transport to swap in, but I feel like that is just a partially blind stab at the problem. I'm skeptical about trying one of the pulled CDM4 units from China on flea bay...they don't reference what version CDM4 they are selling, they aren't exactly dirt cheap and I'm not sure if more than one version of the CDM4 is compatible with the player. From what I have read the 855 is supposed to contain the CDM4/19. I decided not to tear it completely apart just yet, so I can't confirm markings as of right now.

I was hoping I could get some guidance on how to do some further testing that would help me eliminate issues with the motor circuit or motor control circuit that they reference in the Philips service manual. I may be completely off in assuming those circuits should be basically the same in the Rotel...tell me I'm wrong or anything for that matter. Some one has been down this path.

tauro0221 8th January 2013 02:45 AM

Hi,
I can give you one advice it is to check the IC's around the cables that connect to the motor. Normally all servo motor use a H motor driver to move the motor. You have to look all the IC's around and check for the specs of each one to see if one it is an H driver IC. Other than that follow the connections from the motor and see where the end. Hope this will help you.

Praudio 8th January 2013 04:10 AM

If CDM4/19 is really the culprit ; get some brand new transport for sale.

josha 8th January 2013 06:11 AM

Hi,

Have you seen this post? That refers to a blown T103 causing similar symptoms. I did find a service manual here but the qualities not great I'm afraid.

The transistor mentioned is in the bottom middle of the circuit board to the right of U105 - you can just make it out in the service manual!

For the sake of a single PNP BC328 it's probably worth a shot?

Cheers

Mooly 8th January 2013 06:41 AM

This is difficult without a scope.

The disc motor doesn't spin until focus is found on a disc.

CDM4... isn't this the one with the 33uf caps problem on the servo PCB ? You must replace them with the same value of 33uf and not 47uf.

Sandor 8th January 2013 07:24 PM

A frequent problem in old CDM-4 transports is a worn out pivot plate in the clamp mechanism (piece #52 in the disassembly diagram at page 16 of the service manual).
This little plastic piece must be perfectly flat to allow the movement of a little steel ball (piece #1) in any direction. Use causes an engraving on the surface, where the ball gets locked in. This causes trace skipping and read errors.
That piece has part number 300 40004, but it's likely hard to find. Fortunately you can solve the problem by applying a sticky tape on the worn surface, or sand down the surface to eliminate the pit.
Please pay attention when disassembling the CDM-4, as the small ball easily gets lost...

poynton 9th January 2013 11:41 AM

Quote:

Originally Posted by Mooly (Post 3316002)
This is difficult without a scope.

The disc motor doesn't spin until focus is found on a disc.

CDM4... isn't this the one with the 33uf caps problem on the servo PCB ? You must replace them with the same value of 33uf and not 47uf.

My first thought also ...!!

This cd player uses a Philips board as well so the caps in question are under the cd mechanism.

As Mooly says, use the same value and also the same type not exotic types eg. Oscon, Cerafine etc.

Andy

chromenuts 10th January 2013 03:23 AM

Thanks guys...I knew I would get something to run with on here.

No Josha..I hadn't seen the post on the 955...and I thought I had been pretty thorough...thanks!

That is the same Rotel manual I was able to find online...at least its something.

The issue with T103 in the Rotel schematic seems to correspond with the diagnostics flow in the Philips manual. They indicate examining 6510,11,12 when you don't get spin up of the disc.

As I mentioned I noticed the circuit layout seems to correspond between the Philips manual detail of the motor control circuit illustrated and the circuit in the Rotel manual that includes T103.

I will attempt helping the disc during the search for the TOC for giggles...although I think I may have already tried that. Then take a look at T103 and the caps on the servo PCB if I can figure that out. Thanks.

Kevin

WAR415 10th January 2013 12:51 PM

Rotel RCD-855
 
If all else fails then I have a few original working CDM 4/19's on hand. I sold a couple of them on u-pay without the bull crap "item not as described" which happens frequently.


All times are GMT. The time now is 12:44 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio


Content Relevant URLs by vBSEO 3.3.2