diyAudio

diyAudio (http://www.diyaudio.com/forums/)
-   Digital Source (http://www.diyaudio.com/forums/digital-source/)
-   -   Sony MHC-RG444s (http://www.diyaudio.com/forums/digital-source/219841-sony-mhc-rg444s.html)

radulupu 16th September 2012 06:41 PM

Sony MHC-RG444s
 
Hello everyone.
I won't create two threads , one to expose my problem , and another one to introduce myself, but i'll use this one to do both.
My name is Radu, i'm 22 and i live in Italy.
What brings me here is mostly disperation , because i'm kind of sick of searching , trying to understand a bit about cds , laser lens , pick-ups and stuff like that.

Therefore , i have a problem with a stereo (name in the thread title) regarding the readability of cds.

I just got this stereo (used) and even though it works fine otherwise , it's got this annoying problem with the cd player.
It mostly won't read any cd, it'll say "No disc" and then skip to the next cd , which will display the same message.
At the very 1st moments i found about this issue , the stereo was acting kind of this :
You place a cd, and when it's supposed to start reading the disc , all you hear is some sort of a clicking noise and after 3 or 4 clicks , it would skip to the next disc.
After a dissassemble of the stereo , it turned out that the lens had a sort of a dust cap protection cover that was keeping the lens fully covered when in idle.
That thing seemed to be jammed at times , as it wouldn't let the laser physically see the disc ,and so the laser would have actually hit it each time it tried to focus on the disc.
I managed to remove that cap , so the lens remained uncovered all of the time.
Now , the lens manages to go up and down (focus movement) all of the time , but mostly , after 2 or 3 retries , it just skips to the next disc.
It acts also differently at times , like , it wouldn't skip the disc , but the cd inside would spin kind of fast , first forwards , then backwards , then again forwards and ultimately it wouldn't read anything but skip or simply display that "READING" message for an eternity.
I already cleaned the lens multiple times with a lens cleaning cd, and i also did it manually later with a Qtip (and using the liquid that was provided with the cleaning disc). No improvements what so ever.
The stereo however plays a disc once in a while , and when it does it , it does it the right way : no track skipping , no static sound , everything just normal.
I'm now thinking about replacing the lens , but i'm not sure if it's the lens that has to be replaced or something else.
Besides , in the service manual , and on the cd mechanism itself , all i can find as a code is KSM-215DCP , but that's the mechanism code.
I can't find the laser code.
Based on the looks , it looks like KSS-213D , but can't be sure about that. Any help?

What should i do? Try to get that KSS-213D replacement and see if it works? Or it would be just wasted money , the problem being somewhere else?

I'm sorry for the long post , and i'm also sorry for opening a new thread , but i couldn't find any solution to my problem in any of the other threads.
Hope to hear from you soon!

Thanks in advance!

Mooly 17th September 2012 06:46 AM

The symptoms are classic playability problems typical across many makes and models.

There is a good chance a new pickup may fix this but the proper way is to use an oscilloscope and look at what is happening. You need to confirm the RF from the pickup is at the correct amplitude when it does play.

You also need to look in the service manual to see what adjustments are provided for but don't just twiddle without knowing what you are doing.

Also spindle motors can be problematic on many models. Another basic requirement is that the sled assembly is free and not sticking at all. All mechanical details must be confirmed as correct.

radulupu 17th September 2012 11:17 AM

I can't find any info regarding the adjustments that has to be done to the laser.
Besides , without an oscilloscope , i guess i couldn't do much anyway.
In the meantime i have ordered a KSS-213D (pickup with the dust cap) and should arrive this week. 20 euros isn't much , but it's way cheaper than what Sony would've asked to just CHECK the stereo, or any other dude that works with oscilloscopes and stuff like that.
About the mechanism , to my very ignorant eye, it looks like dust free, nothing weird , but just some sort of a ..grease i believe , of white color , that sits on the dents of the motor wheels and the other wheels that the mechanism has. It's not really uniform , but i avoided to touch it or wipe it not knowing what it is exactly.
Using some sort of a a contacts lubricating oil could work with this mechanism? Would that lubricate it enough?
Thanks!

Mooly 17th September 2012 11:48 AM

I wouldn't go lubricating anything just yet, certainly not without the proper (or suitable) greases. If it all looks clean then thats a good start. As always there are tests you can do. A good one is to monitor the DC voltage across the sled motor while it is playing. The voltage should remain at a low level... although it will jump around a bit... but should remain low. If it suddenly starts to rise then that is an indication that the sled has stuck and as the voltages increase the motor will suddenly overcome the friction and the sled jerks forward.

Spindle motors can wear, the bearing can become sloppy and the commutator in the motor can become dirty causing erratic operation.

As you have ordered a new pickup I think best to try that first as there is a fair chance of success.

radulupu 17th September 2012 03:01 PM

Ok then, once the new pickup arrives , i'll get it mounted and see how it goes. I'll keep you updated.
Thank you so much for the infos you provided! I'm suddently out of the dark thanks to you!

Mooly 17th September 2012 04:26 PM

Make sure you remove (if the KSS213 has this) the antistatic shorting link. If it does have one it will be a solder blob shorting two points out and will be on the PCB attached to the pickup. Remove after fitting the new pickup and connecting the ribbon. If you use a mains iron make SURE that the Sony is totally unplugged and off before touching the iron on the pickup.

radulupu 17th September 2012 05:01 PM

It does have the antistatic blob. At least it should according to Sony.
The thing is that some sellers on ebay sell the pickups as new , when they're actually refurbished. Some of them have the blob , some not.
Anyway, Sony seems to recommend a high temp (350)soldering iron to remove that blob, which i'm not sure i have. I'll be using a normal 50W soldering iron. Hope the copper won't peel off due to the iron not being appropriate.

Mooly 18th September 2012 06:39 AM

The blob will come off in an instant and the copper print will be fine.

radulupu 24th September 2012 07:20 PM

Hello to you all!
The new pickup arrived and i installed it. The stereo now reads the discs incredibly fast (a little longer for the cd-rw tho) and the skipping is gone. It's as good as new.
I removed the blob having the pickup in my hand because , well , i couldn't install it first of all , and then remove the blob (i should've removed another circuit board to reach that area with the iron). Anyway, i never touched anything else but the plastic so keep that in mind if you install a new pickup in the same manner like i did.
Once the blob was gone , i got the pickup on the rails in the cd mechanism, then i made it scroll all over the rail, and left it in the idle position (with the dust cap covering the lens).
Finally , i got every cable connected, got the cd tray back into its position, and i fired up the system.
A bit noisy when the pickup moves on the rails(i should lubricate that mechanism,but i gotta find a suitable grease) , however no clicking noise, nothing out of ordinary. Within seconds i could see the cd data being displayed on the screen.
It also jumps from a track to another way faster than before.
I'm just happy, and all i had to take out of my pockets were 20 euros.
Thanks Mooly for your very clear responses, and for your availability.
I recommend to make this thread Sticky , as i know i've been searching for so long on how to fix my stereo. Perhaps someone else might find himself/herself in the same situation, so it could simply read these posts , and go ahead and fix the stereo.
Thanks a lot again!

Mooly 25th September 2012 06:48 AM

Thanks for the update and great to hear you have fixed it :)


All times are GMT. The time now is 12:52 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio


Content Relevant URLs by vBSEO 3.3.2