problem of quad 67cd motor (cdm9,rf-300c-11400) - diyAudio
Go Back   Home > Forums > Source & Line > Digital Source

Digital Source Digital Players and Recorders: CD , SACD , Tape, Memory Card, etc.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 4th August 2012, 03:19 PM   #1
ClassA is offline ClassA  Taiwan
diyAudio Member
 
Join Date: Nov 2005
Location: Taiwan
Default problem of quad 67cd motor (cdm9,rf-300c-11400)

Every time I turn on my 67cd power, the disc in 67cd turns very fast counterclockwise and there is no readout shown on the screen. After several turn on&off power, it becomes normal. Does anyone know the root cause? control IC or spindle motor problem? Thanks!
  Reply With Quote
Old 22nd August 2012, 03:34 PM   #2
ClassA is offline ClassA  Taiwan
diyAudio Member
 
Join Date: Nov 2005
Location: Taiwan
Could anyone give me a suggestion?
  Reply With Quote
Old 22nd August 2012, 03:45 PM   #3
ide2003 is offline ide2003  Indonesia
diyAudio Member
 
Join Date: Oct 2008
Location: Jakarta
hi there, I happen to have same problem with my Sony CDP950 (story here) and CDP -M75, both cases found that the spindle motor driver chip (CDP950) and driver transistor (CDP-M75) was burnt out. Look for your CD67 schematic, upload here so we can see, most likely it's the spindle driver. On mine, I added hefty heatsink on those drivers after repairing


edit, you're lucky, download the SM here http://elektrotanya.com/quad_67-cd-p.../download.html

Last edited by ide2003; 22nd August 2012 at 03:55 PM.
  Reply With Quote
Old 23rd August 2012, 04:28 PM   #4
ClassA is offline ClassA  Taiwan
diyAudio Member
 
Join Date: Nov 2005
Location: Taiwan
Hi ide2003,
Thank you. I will try it.

Cheers
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
CDM9/65 motor screamager Digital Source 20 15th March 2013 06:54 PM
quad 67cd noise from CD transport ClassA Digital Source 1 30th June 2012 07:56 PM
CDM9 Tray Motor Overrun jonclancy Digital Source 30 14th November 2008 05:48 AM
Krell FPB 300c amp problem crystalchi888 Solid State 0 13th February 2008 07:16 AM
Design "flaw" in Quad 67CD PSU? Zombie Digital Source 3 30th December 2004 11:38 AM


New To Site? Need Help?

All times are GMT. The time now is 11:47 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2