High Performance WM8741 Upsampling DAC New Version build thread (show 'n tell too) - Page 15 - diyAudio
Go Back   Home > Forums > Source & Line > Digital Source

Digital Source Digital Players and Recorders: CD , SACD , Tape, Memory Card, etc.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 28th March 2012, 09:58 PM   #141
Turbon is offline Turbon  Sweden
diyAudio Member
 
Turbon's Avatar
 
Join Date: Aug 2011
Location: South
OK, as a test I connected my LCD to the Aurdino, compiled the example "Hello World" and uploaded it - worked at once. Now the connectors which appears to be on the bottom of the LCD actually is on the top... My hello world came out upside down :-)

Still no input from our dear vendor about versions or code that works with the latest Aurdino...

Brgds

BTW, I changed the pins in the example code to 10, 9, 8, 7... If anyone connects as in our dear vendors drawings as I did.
__________________
These are my principles, and if you don't like them... well, I have others.

Last edited by Turbon; 28th March 2012 at 10:04 PM.
  Reply With Quote
Old 28th March 2012, 10:00 PM   #142
diyAudio Member
 
Join Date: Oct 2011
Oh, sorry I have no idea why it got posted here. Looks like I can't edit it either!
But thanks for the tips about how it's done.

Sorry for OT!
  Reply With Quote
Old 29th March 2012, 03:29 AM   #143
TheGimp is offline TheGimp  United States
diyAudio Member
 
TheGimp's Avatar
 
Join Date: Aug 2009
Location: Johnson City, TN
OK, I had my directory set up wrong.

Now I can open Arduino. load the blink sketch and run it.

I renamed Arduino UNO Code.txt to Arduino UNO Code.ino to be compatible with Arduino. I tried opening it and Arduino squawked it needed to be in a directory named "Arduino UNO Code, so I let it create the directory and move the file.

I can now open the file and compile it but I get a couple of error messages:

Error compiling.

core.a(main.cpp.o): In function `main':
C:\arduino-1.0\hardware\arduino\cores\arduino/main.cpp:11: undefined reference to `setup'
C:\arduino-1.0\hardware\arduino\cores\arduino/main.cpp:14: undefined reference to `loop'

Is this similar to what you did?

I need to go off and figure out how to communicate with the serial display before I can figure any of this out.

Last edited by TheGimp; 29th March 2012 at 03:31 AM.
  Reply With Quote
Old 29th March 2012, 04:54 AM   #144
Turbon is offline Turbon  Sweden
diyAudio Member
 
Turbon's Avatar
 
Join Date: Aug 2011
Location: South
Yes, I have seen them too.
__________________
These are my principles, and if you don't like them... well, I have others.
  Reply With Quote
Old 29th March 2012, 09:19 AM   #145
Turbon is offline Turbon  Sweden
diyAudio Member
 
Turbon's Avatar
 
Join Date: Aug 2011
Location: South
TheGimp - the problem seems to be that your folder and the file has the same name... I renamed my file to soundciti.ino and got other errors.

Very well, compile succeeded at last after fixing a bug in Wire.h - replacing a lot of Wire.send -> Wire.write - replaced 1 Wire.receive -> Wire.read - included Aurdino.h to the LCD cpp file - replaced a lot of void with size_t... ( I probalbly forgot something ).

Anyway it loaded and now shows the characters of line 1 and 3 fully illuminated (boxes). I don't know if this has to do with that I haven't connected the lines from the DAC yet. That will be for tonight to find out.

Brgds
__________________
These are my principles, and if you don't like them... well, I have others.
  Reply With Quote
Old 29th March 2012, 12:42 PM   #146
Turbon is offline Turbon  Sweden
diyAudio Member
 
Turbon's Avatar
 
Join Date: Aug 2011
Location: South
OK, the connection to DAC lines didn't help.

Code compiles but has logical errors. I will upload what I have tonight.

Brgds
Attached Images
File Type: jpg LCD_Arduino_Dac_O2.JPG (533.8 KB, 128 views)
__________________
These are my principles, and if you don't like them... well, I have others.
  Reply With Quote
Old 29th March 2012, 01:17 PM   #147
Turbon is offline Turbon  Sweden
diyAudio Member
 
Turbon's Avatar
 
Join Date: Aug 2011
Location: South
I wish someone pointed a finger on the HW an shouted - Haaa, how could you miss that!

Brgds
__________________
These are my principles, and if you don't like them... well, I have others.
  Reply With Quote
Old 29th March 2012, 02:51 PM   #148
TheGimp is offline TheGimp  United States
diyAudio Member
 
TheGimp's Avatar
 
Join Date: Aug 2009
Location: Johnson City, TN
Interesting,

I have my LCD connected to the six pin header at the top center of the UNO as you have it oriented.
  Reply With Quote
Old 29th March 2012, 03:03 PM   #149
Turbon is offline Turbon  Sweden
diyAudio Member
 
Turbon's Avatar
 
Join Date: Aug 2011
Location: South
Quote:
Originally Posted by TheGimp View Post
Interesting,

I have my LCD connected to the six pin header at the top center of the UNO as you have it oriented.
I haven't checked those pins out but I recon thats another way to do it.
My connections follows our grand gurus drawings.

I will grab the computer downstairs before it gets occupied by the kids and send the files I have tampered with. Save your originals and run a diff to see what I have done. Now, my code compiles without a hitch but does not work on the LCD. This should be rewritten to use the new LiquidCrystal library IF we don't get any more updates from the grand guru.

Brgds
__________________
These are my principles, and if you don't like them... well, I have others.
  Reply With Quote
Old 29th March 2012, 03:10 PM   #150
Turbon is offline Turbon  Sweden
diyAudio Member
 
Turbon's Avatar
 
Join Date: Aug 2011
Location: South
Quote:
Originally Posted by TheGimp View Post
Interesting,

I have my LCD connected to the six pin header at the top center of the UNO as you have it oriented.
I connected according to this:
Attached Files
File Type: pdf LCD HOOKUP.pdf (78.6 KB, 27 views)
__________________
These are my principles, and if you don't like them... well, I have others.
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
High Performance WM8741 Upsampling DAC New Version - Group buy heartwinter Group Buys 114 13th April 2012 04:56 PM
High Performance WM8741 Super Mini DAC with I2S Data Switching PCB - Group Buy heartwinter Group Buys 26 19th January 2012 01:12 PM
High Performance WM8741 Super Mini DAC PCB Group buy heartwinter Group Buys 18 30th August 2011 06:45 PM
Wolfson High Performance 117dB DAC m.parigi Digital Source 1 21st February 2002 08:51 PM


New To Site? Need Help?

All times are GMT. The time now is 01:41 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2