XMOS-based Asynchronous USB to I2S interface - Page 87 - diyAudio
Go Back   Home > Forums > Source & Line > Digital Source

Digital Source Digital Players and Recorders: CD , SACD , Tape, Memory Card, etc.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 4th June 2012, 03:57 AM   #861
kp93300 is offline kp93300  Malaysia
diyAudio Member
 
Join Date: Mar 2007
Default Intermittent dropout

Hi
My set up works quite well with Foobar but has intermittent dropouts . This dropouts is very bad with VLC player .
I adjusted the latency to safe and high buffer in the TUSB dialog that comes with the LUCKIT 1.56 driver .

I run the latency monitor program and attached is the print out of the report.

Hope somebody can take a look at the file and advice on this.

I quote ___Driver with highest DPC routine execution time: USBPORT.SYS - USB 1.1 & 2.0 Port Driver, Microsoft Corporation. Unquote .

How to change the driver for the USB port ?


thanks

kp93300
Attached Files
File Type: pdf xmos dropout .pdf (29.3 KB, 92 views)
  Reply With Quote
Old 4th June 2012, 09:12 AM   #862
diyAudio Member
 
Join Date: Nov 2007
Location: Scotland
Quote:
Originally Posted by kp93300 View Post
How to change the driver for the USB port ?
If I understand you correctly, that's not necessarily going to solve your problem.

BTW, I drive my WaveIO with a 1.1 GHz single-core Atom motherboard (i.e. a quarter or a fifth of the power of your 510) that is too slow even to upsample but I never get dropouts. It's definitely not a processor power issue.

Can you say what OS you use with the D510, what else is connected to it and what, apart from F2K, you run on it, esp AV and "security"?
  Reply With Quote
Old 4th June 2012, 09:31 AM   #863
kp93300 is offline kp93300  Malaysia
diyAudio Member
 
Join Date: Mar 2007
Hi Ryelands,
I am using 64 bit window7 .
I have removed the antivirus software.
There is a usb mouse , a CD rom, one 500gig hard disk and a samsung monitor tied to the mother board.
When playing at 16 bit 44.1 khz very rare to experience drop out
The dropout occurs more frequently with upsampling to 192 khz and 24 bit.

regards

kp93300
  Reply With Quote
Old 4th June 2012, 10:13 AM   #864
diyAudio Member
 
Join Date: Oct 2008
Location: Bologna, Italy
Default Teralink USB isolator based on ADuM4160

I purchased the board due to the low cost assuming the risk (or certainty?) that it couldn't work with WaveIO.
Yes, it doesn't work with WaveIO.
WaveIO is recognized by my Vista system as Class 1.0 through ADuM and as Class 2.0 with direct link.
Unfortunately the driver doesn't take into consideration a Class 1.0 unit so there's no way to have music played.
Attached Images
File Type: jpg usb_direct.jpg (5.5 KB, 574 views)
File Type: jpg usb_adum.jpg (6.2 KB, 564 views)
File Type: jpg usb_driver_adum.jpg (18.7 KB, 561 views)
File Type: jpg usb_WIO_adum.jpg (22.1 KB, 556 views)
  Reply With Quote
Old 4th June 2012, 11:11 AM   #865
reo is offline reo  Canada
diyAudio Member
 
Join Date: Nov 2008
Location: st-philippe de laprairie
Quote:
Originally Posted by kp93300 View Post
Hi
My set up works quite well with Foobar but has intermittent dropouts . This dropouts is very bad with VLC player .
I adjusted the latency to safe and high buffer in the TUSB dialog that comes with the LUCKIT 1.56 driver .

I run the latency monitor program and attached is the print out of the report.

Hope somebody can take a look at the file and advice on this.

I quote ___Driver with highest DPC routine execution time: USBPORT.SYS - USB 1.1 & 2.0 Port Driver, Microsoft Corporation. Unquote .

How to change the driver for the USB port ?


thanks

kp93300
first off make sure you have your usb input for Wave connected to the dedicated usb2 of your motherboard., foobar gives you the option of preferences when opening it up to see what is happening when playing a file.
In the preferences you can open the output window and you will see which device is playing ., from there use luckit audio 2.0 among all of the choices given. If using other choices like Luckit Asio driver you might experience dropouts when playing streaming files, so experiment as you go along .
Also in the Foobar components the Asio support 2.1.1 should appear . With that in mind your foobar should work fine . if not well advise .
  Reply With Quote
Old 4th June 2012, 03:33 PM   #866
kp93300 is offline kp93300  Malaysia
diyAudio Member
 
Join Date: Mar 2007
Hi
I check the drivers and these are as suggested by you.
Playing 16/44.1 files are OK . Anything higher results in drop out evven with Foobar.

regards

kp93300.
Attached Images
File Type: jpg 2012-06-04_23-02-45.jpg (93.7 KB, 519 views)
File Type: jpg 2012-06-04_23-03-10.jpg (98.0 KB, 97 views)
File Type: jpg 2012-06-04_23-03-42.jpg (106.5 KB, 94 views)
File Type: jpg 2012-06-04_23-02-20.jpg (101.3 KB, 94 views)
  Reply With Quote
Old 4th June 2012, 09:13 PM   #867
reo is offline reo  Canada
diyAudio Member
 
Join Date: Nov 2008
Location: st-philippe de laprairie
WaveI/O driver is recognized by Win,7.
Like in your 4th photo i have set mine to 192/24 instead of 14100/44 and it runs well .
Could it be your Dac ? i will investigate further to see why your signal comes and goes .

or try this site for further investigating .
regards
reo

Listen to high quality internet radio stations online with 192 kbps
  Reply With Quote
Old 4th June 2012, 11:43 PM   #868
Wolfsin is offline Wolfsin  United States
diyAudio Member
 
Join Date: Aug 2009
Blog Entries: 2
Quote:
Originally Posted by m.massimo View Post
WaveIO is recognized by my Vista system as Class 1.0 through ADuM and as Class 2.0 with direct link.
Thanks for saving me the purchase price.
__________________
'gardz, Dick
  Reply With Quote
Old 5th June 2012, 06:09 AM   #869
ENSen is offline ENSen  Sweden
diyAudio Member
 
Join Date: Dec 2010
How long is your USB cable?

Quote:
Originally Posted by kp93300 View Post
Hi
My set up works quite well with Foobar but has intermittent dropouts . This dropouts is very bad with VLC player .
I adjusted the latency to safe and high buffer in the TUSB dialog that comes with the LUCKIT 1.56 driver .

I run the latency monitor program and attached is the print out of the report.

Hope somebody can take a look at the file and advice on this.

I quote ___Driver with highest DPC routine execution time: USBPORT.SYS - USB 1.1 & 2.0 Port Driver, Microsoft Corporation. Unquote .

How to change the driver for the USB port ?


thanks

kp93300
  Reply With Quote
Old 5th June 2012, 09:23 AM   #870
Telstar is offline Telstar  Italy
diyAudio Member
 
Join Date: Dec 2007
Location: Italy
Quote:
Originally Posted by m.massimo View Post
I purchased the board due to the low cost assuming the risk (or certainty?) that it couldn't work with WaveIO.
Yes, it doesn't work with WaveIO.
WaveIO is recognized by my Vista system as Class 1.0 through ADuM and as Class 2.0 with direct link.
Unfortunately the driver doesn't take into consideration a Class 1.0 unit so there's no way to have music played.
I asked the same thing to Lorien and he said that the firmware forces highspeed usb2, therefore it wont work with anything that limits the speed under 480Mbit.
He may release a different firmware in the future.
__________________
"The total harmonic distortion is not a measure of the degree of distastefulness to the listener and it is recommended that its use should be discontinued." D. Masa, 1938
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
exaU2I - Multi-Channel Asynchronous USB to I2S Interface exa065 exaDevices 1357 3rd March 2014 08:51 PM
Introducing miniStreamer: Native 24/96 USB to I2S / SPDIF interface minidsp miniDSP 39 5th January 2014 11:00 PM
Ultimate USB to I2S interface sampler Digital Source 206 30th January 2012 03:45 PM
Is it possible to develop a ASIO driver for PCM2900 based USB Audio interface? cxhawk Digital Source 7 3rd December 2010 02:30 PM
interface I2S with USB mermoz Digital Source 0 21st February 2003 10:34 AM


New To Site? Need Help?

All times are GMT. The time now is 03:50 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright ©1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2