Open-source USB interface: Audio Widget - Page 163 - diyAudio
Go Back   Home > Forums > Source & Line > Digital Source

Digital Source Digital Players and Recorders: CD , SACD , Tape, Memory Card, etc.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 13th June 2012, 08:17 PM   #1621
gioz is offline gioz  Italy
diyAudio Member
 
gioz's Avatar
 
Join Date: Jul 2008
Hi, I've two problems with usb>I2S module (red version, clock on board):

1) If I connect the module to my Mac (running 10.7.4) the device appear in audio setting with limit up to 48Khz (Probably UAC1 mode) and work ok.
If I push for 5 seconds prog button and than reset button for a moment (To switch from uac1 to uac2) I think the module reboot (led flashing) the module desappear from audio device on my Mac and no sound. I tried to disconnect usb and reconnect to my mac but not work....

2) when I play music I've strange problem:
The music play pretty well, but after 8/9 minutes I hear music with metallic sound for 2 or 3 seconds, after this the music is again ok, but the problem is repeated after a further 8/9 minutes...

Last edited by gioz; 13th June 2012 at 08:19 PM.
  Reply With Quote
Old 13th June 2012, 09:55 PM   #1622
borges is offline borges  Norway
diyAudio Member
 
Join Date: Dec 2003
Location: Oslo, Norway
Hi Gioz,

I'm no Mac expert, so someone else will have to respond to 1). When it comes to 2) please see how often this appears and what the module LEDs are doing. I had a similar experience on Windows a long time ago when the feedback was disfunctional. You'll have to make a detailed error log with when the sound is strange and what the module LEDs are doing.

BÝrge
  Reply With Quote
Old 13th June 2012, 10:14 PM   #1623
1audio is offline 1audio  United States
diyAudio Member
 
Join Date: Mar 2004
Location: SF Bay Area
Blog Entries: 3
Gioz:
Which firmware is in the module? Lets make sure its correct for this application and not some other variant.
__________________
Demian Martin
Product Design Services
  Reply With Quote
Old 13th June 2012, 10:16 PM   #1624
diyAudio Member
 
oneoclock's Avatar
 
Join Date: Oct 2010
The window is Blackman-Harris. With Tektronix (without MOTU jitter) I've done zoom just on the skirt and I have tried other windows.

Measure are very well. This is with 1Audio power suply.
Now I not have original AB power suply to measure .

Jtest-44.1Khz.
Click the image to open in full size.

Jtest-48 Khz
Click the image to open in full size.


The peak jitter is -130 dB. The value peak of 11,025 and 12,000 on the tektronic are 0 dB but the Jtest teoric value of these signals is -3 db . The signal must go down 3 dB relative the scale.

The signal of 1 kHz I have made with CoolEdit to 44 Khz at -1 dB 24 bit. And best measured channel L green (R pink).
Click the image to open in full size.
  Reply With Quote
Old 13th June 2012, 10:42 PM   #1625
1audio is offline 1audio  United States
diyAudio Member
 
Join Date: Mar 2004
Location: SF Bay Area
Blog Entries: 3
The 1 KHz distortion spectrum is similar to what I measured. It just meets spec and has a lot of upper harmonics.

The jitter may be lower. Finding the jitter floor of the capture system is difficult. You need to get a really clean source (I use a 10MHz oscillator divided down to 10 KHz and a 4M point FFT with 10 averages (1/2 hour of data collection and crunching) to get the noise out so I can see the residual jitter of the ADC. Needless to say the jitter is not an issue with this hardware. The DAC is limited by other aspects.

I was going to repeat my measurements but I sent my sample off to a programmer who is working on fixing issues in the Linux USB audio stack. I should have it back in a few weeks.
__________________
Demian Martin
Product Design Services
  Reply With Quote
Old 14th June 2012, 07:51 AM   #1626
borges is offline borges  Norway
diyAudio Member
 
Join Date: Dec 2003
Location: Oslo, Norway
Quote:
Originally Posted by 1audio View Post
Gioz:
Which firmware is in the module? Lets make sure its correct for this application and not some other variant.
For all practical purposes the red modules have shipped with what has been in the audio-widget branch for quite some time.

I made the binaries using the 2.7 toolchain on Cygwin.

Again, I had a similar issue before. When It happened I spent half a day playing music and looking at the module LEDs. Whenever the LEDs broke out in a different pattern, or whenever the sound changed, I recorded the time and the behaviour.

We had a lengthly discussion on this some time ago. Please see if any of those experiences match what you are observing on your Mac. Look at the Audio-Widget email archive for threads named:
* Async UAC1 on Win7, weird noise...
* Audio buffers
* Metallic sound captured Win7-64 / UAC1


BÝrge
  Reply With Quote
Old 14th June 2012, 12:00 PM   #1627
2A3SET is offline 2A3SET  Canada
diyAudio Member
 
Join Date: Dec 2003
Location: Toronto
Prefer PCM5102 (with IIR filter mode) for redbook material with better presence.
With Hi-res material, both are good, ES seems a bit better dealing with big pieces.

Borge, I think full scale (0db?) signal is kind of extreme condition. I've heard it can be resolved on ES9023 by using 3.6V AVCC. PCM5102 should have similar issue as well. Since these are rare condition, I guess we can ignore it.

Quote:
Originally Posted by 2A3SET View Post
Audio-widget driving ES9023 and PCM5102, with dual stage Salas Shunt regulators and I2S isolator.
  Reply With Quote
Old 14th June 2012, 01:40 PM   #1628
1audio is offline 1audio  United States
diyAudio Member
 
Join Date: Mar 2004
Location: SF Bay Area
Blog Entries: 3
I wish FS in a track was a rare condition. I have on very popular track I use to test for overload that does go to FS on extended bass hits. Its possible for a producer to get real close and "win" the loudness war with some of the current DAWs and VST compressors.

When my AB1.1 returns I'll check the AVCC. There is also a resistor ratio tweak for the reference voltage that plays into this I think.
__________________
Demian Martin
Product Design Services
  Reply With Quote
Old 14th June 2012, 03:26 PM   #1629
diyAudio Member
 
oneoclock's Avatar
 
Join Date: Oct 2010
Many commercial expensive DAC would like to have this QNKT jitter measure and 1 KHz. and 19-20 Khz. distortion. Stereophile do not dare to publish most of DAC the 1 Khz distorsion.

If Borges sell me AB 1.12 1.13 (PCM5102 and AK4430) all the components soldiers I buy to test and measure. I dare not soldered SMD.

Try to measure the ADC Jitter MUTU with the measuring equipment Tektronix to 10 Khz. But MOTU measured quite well for the price it costs and adds little jitter. I think now it is very difficult and expensive overcome the measures this card.
  Reply With Quote
Old 15th June 2012, 08:02 AM   #1630
borges is offline borges  Norway
diyAudio Member
 
Join Date: Dec 2003
Location: Oslo, Norway
Hi Oneoclock,

I'll see what I can do in terms of putting together boards for test. I have an AB-1.13 which plays using the AK4430. It is currently out of the house for audio testing. If I find the time I can put toghether an AB-1.12 with PCM5102 for your testing. I will equip one of the two with SPDIF output.

BÝrge
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Async 192Khz USB - the SDR-Widget collaborative project SunRa PC Based 5 26th April 2011 06:38 PM
usb audio interface david12 Equipment & Tools 14 10th October 2010 02:58 AM
Cheap Audio Interface (USB?) to PC agm2003 Instruments and Amps 11 16th September 2007 07:48 AM
Open call for suggestions on Open Source DIY Audio Design gfergy Everything Else 1 15th April 2007 07:33 AM
USB Interface Perfect?- Computer Audio fmak Digital Source 3 4th December 2004 10:24 PM


New To Site? Need Help?

All times are GMT. The time now is 02:24 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright ©1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2