Open-source USB interface: Audio Widget - Page 162 - diyAudio
Go Back   Home > Forums > Source & Line > Digital Source

Digital Source Digital Players and Recorders: CD , SACD , Tape, Memory Card, etc.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 10th June 2012, 10:59 PM   #1611
1audio is offline 1audio  United States
diyAudio Member
 
Join Date: Mar 2004
Location: SF Bay Area
Blog Entries: 3
PM me and I'll send you my test files.

I have not been impressed by the ESS dacs and the measurements met spec so I was not expecting more. I'll redo the IM and THD measurements with the latest firmware and post them. I also have a proto from Borge with a different USB interface I can plot for comparison. Perhaps the chip is broken or ???

Most of the fir in the IM plot is from the motu or a grounding problem between it and the AB1.1. If you can upgrade the clocks or improve the bypassing you should see it reduce or go away.
__________________
Demian Martin
Product Design Services
  Reply With Quote
Old 11th June 2012, 06:36 AM   #1612
starn02 is offline starn02  Italy
diyAudio Member
 
Join Date: Jul 2005
Location: Italy
Hi Borge, hi Alex,

after a lot of attempts I was able to revive the board, loaded the latest firmware with DFU and now it's working (in UAC2). I'll leave it this way to avoid
further problems.

Anyway, two details.

- My module is yellow.
- I removed the pullup resistor and capacitor to ground on reset line, the Atmel datasheet states that there is a pullup internal to the chip on RESET_N, so they should not be necessary (and my idea was that they were interfering with the reset signal coming form the Dragon). I got no change, the reset works equally well without them in place, and the Dragon is not working in the same way.
- My final idea is that there is something in the code or fuses that prevents the JTAG resent signal to be interpreted correctly (the chip should understand that it's the start of a JTAG / ISP session, and instead it resets as usual). I don't believe that a JTAG ICE II would improve things, but if you confirm that the JTAG is working on other installations I'll try to find one to see if it's better. If nobody has recently used it with JTAG ... maybe it's a waste of time, maybe the code has changed since your last successful attempts.

Anyway, thank you to everybody for your support.
  Reply With Quote
Old 11th June 2012, 02:28 PM   #1613
diyAudio Member
 
oneoclock's Avatar
 
Join Date: Oct 2010
Congratulations Starn02. I can´t helped you. But I come read you with interest and congratulations for insisting to solve the problem.
I guess you had us all impatient with the result ....
  Reply With Quote
Old 11th June 2012, 02:56 PM   #1614
diyAudio Member
 
oneoclock's Avatar
 
Join Date: Oct 2010
1Audio. PM send.

Do not know why, my AB.1.1 makes sometimes measures similar to yours, but are fixed by simply moving the connectors or the DAC. There seems to be a problem for the ground.

The measurement of intermodulation, The MOTU card is not bad mass, only occurs when I measuring the test signal of 19 and 20 kHz. If you look is periodic noise, its not groud noise. I guess the charge pump power requirement is excessive, or there is interference between tracks, or would affect the external power.
With a signal of 1 kHz, for example, the ground noise is much cleaner.
The MOTU has no background noise as low as your system but is not bad, you can make measurements with a dynamic range of 140 dB by Line Input.
The microphone input is not very good.

The bad notice is that it only has 44.100 crystal and therefore only make good measurements or recordings at 44,100 Hz.and multiple.
48,000 Hz synthesized, and are bad measures and recording at this frecuence and multiple.
  Reply With Quote
Old 11th June 2012, 03:03 PM   #1615
1audio is offline 1audio  United States
diyAudio Member
 
Join Date: Mar 2004
Location: SF Bay Area
Blog Entries: 3
I'm sending you the files. Let me know if it all works.

I usually try to measure with a different non-synced sample rates so there are no hidden artifacts. The measurements are tedious to get right.

USB has a 1 KHz or 4 KHz update rate for the data transfers. It can cause some jitter artifacts as an interaction between the different clocks. Measuring with the same computer that is generating the signals can further challenge the measurement process.
__________________
Demian Martin
Product Design Services
  Reply With Quote
Old 12th June 2012, 05:51 PM   #1616
2A3SET is offline 2A3SET  Canada
diyAudio Member
 
Join Date: Dec 2003
Location: Toronto
Default Here is the mess

Audio-widget driving ES9023 and PCM5102, with dual stage Salas Shunt regulators and I2S isolator.
Attached Images
File Type: jpg aw-duo-1.jpg (166.2 KB, 284 views)
  Reply With Quote
Old 12th June 2012, 07:44 PM   #1617
borges is offline borges  Norway
diyAudio Member
 
Join Date: Dec 2003
Location: Oslo, Norway
Looks cool!

Any audible difference between the two DACs? Are you able to give them a full-scale square signal? That tends to overflow the ES9023 output. The AK4430 is safe. I'm curious how the PCM5102 handles that.

Børge
  Reply With Quote
Old 12th June 2012, 09:49 PM   #1618
diyAudio Member
 
oneoclock's Avatar
 
Join Date: Oct 2010
Jitter 48 Khz. ES9023
Click the image to open in full size.
  Reply With Quote
Old 12th June 2012, 10:58 PM   #1619
1audio is offline 1audio  United States
diyAudio Member
 
Join Date: Mar 2004
Location: SF Bay Area
Blog Entries: 3
Looks good. What are the FFT settings? Most of the skirt could be from the FFT window.

What distortion spectrum do you get at -1 dB 1 KHz?
__________________
Demian Martin
Product Design Services
  Reply With Quote
Old 13th June 2012, 12:45 AM   #1620
diyAudio Member
 
Join Date: Apr 2011
wei,

Impressive mod :-)

How is the sound ?

Alex
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Async 192Khz USB - the SDR-Widget collaborative project SunRa PC Based 5 26th April 2011 06:38 PM
usb audio interface david12 Equipment & Tools 14 10th October 2010 02:58 AM
Cheap Audio Interface (USB?) to PC agm2003 Instruments and Amps 11 16th September 2007 07:48 AM
Open call for suggestions on Open Source DIY Audio Design gfergy Everything Else 1 15th April 2007 07:33 AM
USB Interface Perfect?- Computer Audio fmak Digital Source 3 4th December 2004 10:24 PM


New To Site? Need Help?

All times are GMT. The time now is 02:51 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright ©1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2