Open-source USB interface: Audio Widget - Page 158 - diyAudio
Go Back   Home > Forums > Source & Line > Digital Source

Digital Source Digital Players and Recorders: CD , SACD , Tape, Memory Card, etc.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 1st June 2012, 12:09 AM   #1571
diyAudio Member
 
Join Date: Apr 2011
1. The spreadspectrum clocks, SICK and LRCK, amd the SDATA, are all gemerated by the SSC in the Atmel chip and if u read the Atmel reference docs u can see they conform to i2s requiremts.

2. The jitter will be introduced by the opto/magneto isolater and internal dividers/plls of the Atmel chip.

3. The low jitter MCLK goes to the DAC direct. It is not used for clocking SDATA.

Alex
  Reply With Quote
Old 1st June 2012, 12:19 AM   #1572
borges is offline borges  Norway
diyAudio Member
 
Join Date: Dec 2003
Location: Oslo, Norway
There are usually some requirements that clocks are synchronous. As long as setup times are consistenst a few ns in delay variance is a good thing. But it may make sense to look at the clock signals in a scope to see if there is a danger of signals arriving too early or too late for the edge which latches it.

In digital design, using two D-flip-flops in series is a common way to cross clock domains. The flip-flops are then clocked by the clock of the destination.

But in our case tings are synchronous. We just need to make sure that hold and setup times are within spec. I'm travelling right now, so i can't scope this myself now. I'm tempted to get a few isolators and start playing with them. We can still test propagation delays by inserting the isolators without having to actually separate the supply domains.

BÝrge
  Reply With Quote
Old 3rd June 2012, 06:43 PM   #1573
borges is offline borges  Norway
diyAudio Member
 
Join Date: Dec 2003
Location: Oslo, Norway
Has anybody had success with installing Nikolay's drivers on non-English XP? I'm stuck with a Norwegian installation. In UAC1 I'm able to follow the instructions and run Widget-Control.exe. In UAC2 the yellow question mark comes up in Devmgr. It then does not find relevant hardware in the .inf file.

BÝrge
  Reply With Quote
Old 3rd June 2012, 08:07 PM   #1574
sampler is offline sampler  Lithuania
diyAudio Member
 
Join Date: Jan 2010
Hi Borge,
are you sure that language pack has something to do with this problem ? I had similar issue when installing Nikolay's driver on english XP per his guide. When doing driver update, the list from Audio-Widget.inf was empty. Hit back, select "Don't search I will choose driver to install" (or whatever that sounds in Norwegian), next and Audio-Widged was in the list.
Hope this helps.
P.S. Playback on XP (sp3 and all latest updates) with higher bitrates (192k,96k) was terrible. Frequent drop outs and metal affects every 2 to 10 seconds without any other active processes on background. Same thing with Thesycon drivers. Don't know if it was some specific problem with my hw, but after clean install of Win7 same machine plays ok, although random dropouts and "metal effects" do pop out, but only at heavy/medium cpu and hdd utilization. Well... windoze was never a real time os.
  Reply With Quote
Old 3rd June 2012, 08:10 PM   #1575
borges is offline borges  Norway
diyAudio Member
 
Join Date: Dec 2003
Location: Oslo, Norway
OK, I will try again. Found an old computer with a US SP3 installation of XP.

What I'm trying to do here is to simplify the test procedure for the AB-1.2 manufacturing and make sure both crystals do what they are supposed to. So today I created two wav files at 44.1 and 48 using Octave. They both play 1s 1kHz left, then 1s 2kHz right. So the two should sound the same to the test guys but play using different oscillators. That worked well with XP and UAC1.

BÝrge
  Reply With Quote
Old 5th June 2012, 06:15 PM   #1576
gioz is offline gioz  Italy
diyAudio Member
 
gioz's Avatar
 
Join Date: Jul 2008
A switch is PROGRAM?
B switch is RESET?

correct?
Attached Images
File Type: jpg Schermata 06-2456084 alle 20.12.44.jpg (51.9 KB, 210 views)
  Reply With Quote
Old 6th June 2012, 10:18 AM   #1577
borges is offline borges  Norway
diyAudio Member
 
Join Date: Dec 2003
Location: Oslo, Norway
Reset is the one closest to the unmounted JTAG header.

BÝrge
  Reply With Quote
Old 6th June 2012, 11:46 AM   #1578
diyAudio Member
 
merlin el mago's Avatar
 
Join Date: Sep 2009
Location: Catalonia - Europe
Borges your USB-I2S device support Windows Vista? if yes wich software have I to download & where can I download? have I to install Xtals & more components to connect to Twisted Pear Sidecar?
  Reply With Quote
Old 6th June 2012, 09:55 PM   #1579
juanito is offline juanito  Europe
diyAudio Member
 
juanito's Avatar
 
Join Date: Nov 2006
Quote:
Originally Posted by borges View Post
Juanito,

Here are some questions which may help to sort things out:
- Are you using an updated firmware version?
- Are you using UAC1 (green front light) or UAC2 (red)?
- If you open up the case, how do the red and green LEDs on the module behave?

I had similar problems a long time ago on previous firmware. In that case the module LEDs started acting up a little while before the audio imperfections started.

BÝrge
About the lights behavior: when I plug the mini USB to the DAC, first comes the red light then the red one. In 5 seconds or so the turn off in the same order, first red then green. Noise is still there.

By the way I tried the USB DAC with EXOPC tablet. Works wonderful. The Tablet it's just a pc netbook with touch screen. I't very handy because it has two USB, so you can use simultaneously the DAC and Hard drive where I store my Flacs.
I curious about the Ipad and the usb camera kit: will that work?
  Reply With Quote
Old 7th June 2012, 09:10 AM   #1580
UnixMan is offline UnixMan  Europe
diyAudio Member
 
UnixMan's Avatar
 
Join Date: Apr 2005
Location: Perugia + L'Aquila, Italy
Send a message via ICQ to UnixMan
Quote:
Originally Posted by merlin el mago View Post
have I to install Xtals & more components to connect to Twisted Pear Sidecar?
you may get the option with XOs (and related parts) already mounted, see: Q N K T C USB-I2S Module and Analog Board
__________________
Quote:
"We should no more let numbers define audio quality than we would let chemical analysis be the arbiter of fine wines." N.P.
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Async 192Khz USB - the SDR-Widget collaborative project SunRa PC Based 5 26th April 2011 06:38 PM
usb audio interface david12 Equipment & Tools 14 10th October 2010 02:58 AM
Cheap Audio Interface (USB?) to PC agm2003 Instruments and Amps 11 16th September 2007 07:48 AM
Open call for suggestions on Open Source DIY Audio Design gfergy Everything Else 1 15th April 2007 07:33 AM
USB Interface Perfect?- Computer Audio fmak Digital Source 3 4th December 2004 10:24 PM


New To Site? Need Help?

All times are GMT. The time now is 04:46 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright ©1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2