Arcam Alpha 5 CD - playback problem - diyAudio
Go Back   Home > Forums > Source & Line > Digital Source

Digital Source Digital Players and Recorders: CD , SACD , Tape, Memory Card, etc.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 28th October 2010, 09:41 PM   #1
diyAudio Member
 
Join Date: Oct 2010
Location: Cork
Default Arcam Alpha 5 CD - playback problem

This is my first post here so Hi to Everyone

Recently I've bought Arcam Alpha 5 but unfortunately some problems appeared soon after

It reads TOC every time but playback is delayed. Well sometimes it's OK but other time you have to wait few minutes until it plays. No matters what CD, CD-r, scratched or not. There is playback icon on display but no activity on laser head. Once it can be all day OK while other day you have to wait long every time CD is inserted

Other thing that I've noticed is that when I'm pressing the load button, laser doesn't wait until drawer pull back but it's "checking" immediately is there a CD while it's not yet in the position and it's displaying "no disc". When I'm pushing the drawer by finger it's OK

I've replaced CDM-9 laser pickup but it didn't help. I haven't found any cold joints or leaking caps

After few simple mods player plays very nice so I'm desperate to restore it to full health.

Any advices and ideas are welcome

Best Regards
Kamil
  Reply With Quote
Old 29th October 2010, 06:39 AM   #2
Mooly is offline Mooly  United Kingdom
diyAudio Moderator
 
Mooly's Avatar
 
Join Date: Sep 2007
Not familiar with the playe,r but the player thinking there is a disc present when there isn't points to a possible problem with the drawer/tray microswitches that tell the system control what state the player is in.
__________________
-------------------------------------------------------
A simulation free zone. Design it, build it, test it.
  Reply With Quote
Old 29th October 2010, 08:54 PM   #3
diyAudio Member
 
Join Date: Oct 2010
Location: Cork
Hi Mooly
After your suggestion I've checked the micro switch - it's very simple and it works fine so problem is somewhere else.

I'm suspecting one of the microprocessors that is processing signal from the switch and laser but I have no idea which one could it be and how to check it if find it.
  Reply With Quote
Old 30th October 2010, 06:51 AM   #4
Mooly is offline Mooly  United Kingdom
diyAudio Moderator
 
Mooly's Avatar
 
Join Date: Sep 2007
It's never the microprocessor as a general rule... I say that from years of experience as a service tech.

The next step is to locate a manual and to go around every pin on the system control and uprocessor with both a DVM and a scope and make sure everything is what you would expect. That includes grounds and supplies too.
You have to be logical...
__________________
-------------------------------------------------------
A simulation free zone. Design it, build it, test it.
  Reply With Quote
Old 30th October 2010, 10:12 AM   #5
diyAudio Member
 
Join Date: Oct 2010
Location: Cork
Thanks Mooly, what you're saying has sens so I will follow that.
I've already mailed arcam requesting pcb schematics so it looks like I will have to do my homework from theoretical and practical electronics.

But in the first place I will replace rest of capacitors that I haven't replace before.
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Arcam Alpha 9 problem Colin151 Solid State 14 20th January 2011 09:54 PM
Arcam Alpha 5 Problem Grizzard Solid State 6 24th August 2010 05:46 AM
Arcam alpha plus cd player help Scrappydoo Digital Source 29 1st March 2010 07:31 AM
Arcam Alpha 5 CD remote planetbass Digital Source 17 10th December 2009 01:00 AM
Arcam Alpha 9 CD - I am an idiot dmsims Digital Source 11 11th December 2008 09:17 PM


New To Site? Need Help?

All times are GMT. The time now is 10:03 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2