Rotel RCD-965 BX problem - diyAudio
Go Back   Home > Forums > Source & Line > Digital Source

Digital Source Digital Players and Recorders: CD , SACD , Tape, Memory Card, etc.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 28th August 2010, 11:13 AM   #1
diyAudio Member
 
Join Date: Aug 2010
Default Rotel RCD-965 BX problem

Hello!

I have a Rotel The problem is: read CDs only beginning, if you use the buttons to change tracks from the player read error.

It can be a mechanical problem?

THANKS
  Reply With Quote
Old 30th August 2010, 07:55 AM   #2
amc184 is offline amc184  New Zealand
diyAudio Member
 
amc184's Avatar
 
Join Date: May 2007
Location: Christchurch
It sounds like the the laser mechanism's radial arm is not moving as smoothly as it should. Take the top off of the player, lift the CD clamp and give the arm a bump. It should move very freely, without any friction.
  Reply With Quote
Old 9th October 2010, 11:55 PM   #3
diyAudio Member
 
Join Date: Aug 2010
The previous problem has been resolved (doing nothing). Now, no longer able to read the TOC, the laser remains in a "central" as you can see from this video:

http://www.repo.intilinux.com/rcd965bx/MOV01466.MPG

Previously, the laser power is positioned to read the TOC at the beginning :-(

Any ideas? CDM 4 / 19.
  Reply With Quote
Old 10th October 2010, 02:55 AM   #4
amc184 is offline amc184  New Zealand
diyAudio Member
 
amc184's Avatar
 
Join Date: May 2007
Location: Christchurch
It looks like the radial control servo isn't working at all.

Before I suggest anything, what tools do you actually have to troubleshoot this? A multimeter, an oscilloscope? This doesn't look like it will be a particularly easy problem to solve.
  Reply With Quote
Old 10th October 2010, 08:16 AM   #5
diyAudio Member
 
Join Date: Aug 2010
A multimeter.

Initially, the lens worked perfectly (it was in the right position to read the TOC). Then I adjusted the laser trimmer (VR302) and trimmer which indicates the height of the lens, but things have not changed. Then I realized that the lens power did not come back earlier but remained in the center position as shown in the video.
I have not noticed anything broken in the mechanism and I put everything perfectly. Maybe the magnet does not reach the correct voltage? :-(

THANKS
  Reply With Quote
Old 10th October 2010, 11:50 AM   #6
poynton is offline poynton  United Kingdom
diyAudio Member
 
poynton's Avatar
 
Join Date: Mar 2005
Location: A life on the ocean waves when I'm not at home in N. Wales (but I'm not Welsh so no sheep jokes!)
Sounds like the laser is now blown after you adjusted the laser trimmer !
__________________
If it ain't broke, break it !! Then fix it again. It's called DIY !
  Reply With Quote
Old 10th October 2010, 01:01 PM   #7
diyAudio Member
 
Join Date: Aug 2010
All fixed. :-) The problem was the cable slightly disconnected. I then set up a laser according to the official technical manual, and now everything is back to normal.
  Reply With Quote
Old 10th October 2010, 10:45 PM   #8
amc184 is offline amc184  New Zealand
diyAudio Member
 
amc184's Avatar
 
Join Date: May 2007
Location: Christchurch
Well, I would've expected that you had checked the simplest things before you posted on here, but well done for getting it going anyway.
  Reply With Quote
Old 11th October 2010, 07:33 AM   #9
diyAudio Member
 
Join Date: Aug 2010
I still have an error (this even before the event): button to click on> | or <|, the display shows "error" for a second, no problem reading the audio track. Any ideas?
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
rotel RCD 965 BX paul_peraic Digital Source 22 24th October 2010 05:58 AM
Rotel RCD-971 tray problem... Skorpio Digital Source 15 31st August 2010 11:39 AM
Rotel RCD 971 Carriage Problem trombone Digital Source 13 31st August 2008 05:54 PM
RCD 965 Muting Transistors to a Relay. How? (components or something I buy/install) KP11520 Digital Source 16 11th July 2007 04:17 PM


New To Site? Need Help?

All times are GMT. The time now is 04:35 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2