RCD-955AX CDM 4/19 weak spindle motor? - diyAudio
Go Back   Home > Forums > Source & Line > Digital Source

Digital Source Digital Players and Recorders: CD , SACD , Tape, Memory Card, etc.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 17th June 2010, 02:44 AM   #1
tooch is offline tooch  Australia
diyAudio Member
 
Join Date: Jun 2010
Default RCD-955AX CDM 4/19 weak spindle motor?

Greetings all!

I have a Rotel RCD-955AX here which uses the CDM-4/19 transport, and I'm having trouble with it.

The laser appears to be working as I can see the red dot, and the machine attempts to spin up the cd but it only goes for a second or so before stopping, and the display says 'error'. It doesn't seem to spin it very fast either. I've removed the transport and cleaned out the motor and lubed it up, and also removed a whole heap of hair that was wrapped around the motor shaft.

Does it sound like the spindle motor may be worn and is not providing enough torque?

Thanks Click the image to open in full size.
Click the image to open in full size.
  Reply With Quote
Old 19th June 2010, 07:59 AM   #2
amc184 is offline amc184  New Zealand
diyAudio Member
 
amc184's Avatar
 
Join Date: May 2007
Location: Christchurch
Quote:
Does it sound like the spindle motor may be worn and is not providing enough torque?
I doubt it, that's not a problem that a CDM-4/19 would normally suffer from. It sounds like the laser is successfully focusing, but can't read the TOC of the CD.

Putting it into service mode may help diagnose the problem, but unfortunately the RCD955 service manual doesn't tell how this can be done. Try turning the player on with the 'Stop', 'Track >' and 'Track <' buttons held down. That's a bit of a stab in the dark though, the equivalent Philips model uses this, but the Rotel could be different, or not have a service mode at all.

Let me know how you get on.
  Reply With Quote
Old 21st June 2010, 01:46 AM   #3
diyAudio Member
 
Join Date: Jan 2009
This one is easy ................ I had EXACTLY the same problem on my 955AX a few months ago - you'll find that if you remove the top cover and help the motor out with your finger during the TOC phase - then it will play fine afterwards - yeah ok that's not really practical - but it does confirm the fault.

Do you have a schematic? - if not pm me and I'll send you one.

The problem is a blown BC328/338 driver transistor on the spindle motor drive - these transistors deliver a higher current than the ic can manage on it's own - they are especially needed during the TOC/ start up phase - afterwards the ic can just about supply the current on it's own - hence it will play ok from then on. Mine blew T103, the BC338 - I imagine yours has done the same.

Click the image to open in full size.

BC328/338 look like small signal transistors but in fact they have a particularly high Ic - hence their use in this application. They are easily got at on the board and are near the front panel.

The 955AX IS NOT EASY to take apart however - so good luck with that - there are almost NO plugged leads - almost everything is soldered!! - you'll see

anyway - there it is - like I said if you want a schematic, pm your email address.

good luck
__________________
Graeme
  Reply With Quote
Old 21st June 2010, 06:14 AM   #4
diyAudio Member
 
Join Date: Jan 2009
Ooops - typo to above - mine blew T103 - which is the PNP BC328!

From memory it's the BC328 that is used the most during normal operation - ie. it's the one conducting when the spindle drive motor is rotating the normal way. The positive output/BC338 is just there to provide a brake for the spindle/cd with a quick burst of +ve.

You'll probably find that after it cannot read the TOC, the spindle rotates backwards for a sec - this is the +ve voltage/brake kicking in.
__________________
Graeme
  Reply With Quote
Old 21st June 2010, 11:58 AM   #5
tooch is offline tooch  Australia
diyAudio Member
 
Join Date: Jun 2010
Wow thanks so much for the helpful replies guys! I only just got back from interstate today so I will try out your suggestions tomorrow at work where the CDP is

Will report back here with results!
  Reply With Quote
Old 23rd June 2010, 01:13 AM   #6
tooch is offline tooch  Australia
diyAudio Member
 
Join Date: Jun 2010
Ok, I had another look at the unit yesterday. Can't seem to get into service mode, maybe this model doesn't have one?

Also, I desoldered T102 and T103 and gave them a check with my DMM, they appear to be ok based on my basic knowledge of testing transistors (conducting one way, not the other, between the various pins). Are there any other failure modes of transistors i.e. a performance degeneration, or do they just either work or not?

Also, if it helps, I attempted to 'help' the machine by spinning the cd while it was trying to read the TOC, to no avail. It doesn't appear to spin backwards after its attempt either.

Thanks for the help so far!
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Looking for ROTEL RCD-955AX schematic olaychang Digital Source 4 16th December 2011 06:22 PM
Fs rotel rcd 955ax like new! nvrgdenuf Swap Meet 0 8th November 2009 10:50 PM
Source for CDM 4 Spindle Motor auric Digital Source 1 13th November 2008 03:48 PM
Difference between CDM 4/19 and CDM 4/19/31 bezobraznia Digital Source 1 28th October 2005 10:08 AM
rotel rcd 855 spindle motor spins backward P Howard Digital Source 2 18th April 2004 10:03 PM


New To Site? Need Help?

All times are GMT. The time now is 11:57 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2