Arcam Alpha mods - Page 53 - diyAudio
Go Back   Home > Forums > Source & Line > Digital Source

Digital Source Digital Players and Recorders: CD , SACD , Tape, Memory Card, etc.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 8th January 2012, 01:08 PM   #521
SimontY is offline SimontY  United Kingdom
diyAudio Member
 
SimontY's Avatar
 
Join Date: May 2003
Location: Sheffield, North England
Send a message via MSN to SimontY
I just solder to the copper ground plane sometimes, works fine. Sure, it's not necessarily ideal but I'm not clever enough to do perfect grounding so I won't let it worry me too much.
  Reply With Quote
Old 8th January 2012, 02:19 PM   #522
diyAudio Member
 
Join Date: Jun 2008
Exactly the answer I was looking for - thanks.

How's it going at your end - have you found and fixed the problem ?
  Reply With Quote
Old 8th January 2012, 02:21 PM   #523
SimontY is offline SimontY  United Kingdom
diyAudio Member
 
SimontY's Avatar
 
Join Date: May 2003
Location: Sheffield, North England
Send a message via MSN to SimontY
Nope, I can't be bothered right now. I've just bought a new car so that's taking up most of my "hobby" attention. I just turn it on, listen to an album, then turn it off to cool down ready for the next one. I know that is very poor and I will do some proper fault-finding soon.
  Reply With Quote
Old 26th January 2012, 10:12 PM   #524
diyAudio Member
 
Join Date: Mar 2010
Hi

I have just got my hands on an Alpha One? I'm quite impressed with it considering it's age, especially with the size of the soundstage. Do any of you Alpha mods apply to the alpha one?

My frst problem is with the drive which will read cds if I give the disc a little spin myself, to get it started. If not it struggles, gives up and says no disc. Once it's going there are no probs with the sound. Any idea how I ight fix this?

I'll put it through my DACMAGIC eventually so I imagine it's not worth replacing the DAC, is that right?

I was going to leave the opaps to begin with to see if I could work with the character of the current ones, however I'm always open to interesting suggestions!

Finaly if anyone had the service manual I'd be very grateful if you would share it with me.

Many thanks
  Reply With Quote
Old 5th February 2012, 02:25 PM   #525
acccruz is offline acccruz  Portugal
diyAudio Member
 
Join Date: Nov 2009
Post SRPP I/V output stage

Hi:

After trying several op-amps in my moded Arcam Alpha 5, running in class A, I must agree with Mr. Fikus when he said: "there is no better op-amp like no op-amp"!

Again I must agree with lampizator when he said the tube I/V output alone represents more than all mods you can do in the CD player.

Here my mods:
All digital caps changed for Os-con SPEC;
All power caps changed for Rubycon ZL;
Changed the resistors board for PRP metal film and some Takman;
LM regulators changed for best Motorola;
Diodes changed for Motorola;
Added some inductors before the power resistor of the digital chips;
NetAudio Clock;
NOS;
DEM;
Op-amps (tryed several among the best) running in class A;
SRPP 6N2P-EV tube stage for I/V output (the best!)

Here some pics about my I/V srpp tube output stage.

It is not look nice but it sounds amazing!
Attached Images
File Type: jpg DSC_3912_.jpg (40.7 KB, 180 views)
File Type: jpg DSC_3913_.jpg (71.4 KB, 174 views)
  Reply With Quote
Old 5th February 2012, 04:54 PM   #526
acccruz is offline acccruz  Portugal
diyAudio Member
 
Join Date: Nov 2009
Default Some aditional notes

Future plans:

Make my salas shunt reg to feed the TDA1541A and SAA7310;

Feed all other chips with is own regulator (LM337T or LM317T);

Make two wood boxes like these ones for Arcam Alpha:

Sell my reference (until today, because the Arcam sound much more additive!) Electrocompaniet EMC1-UP player;

Read this: Electrocompaniet

Make my OWN opinion about the debate: which sounds better? vinil or cd?

ENJOY the music and pray for the sun! The winter are cold in Portugal.
Attached Images
File Type: jpg DSC_3925_.jpg (65.1 KB, 171 views)
File Type: jpg Wood Boxes.jpg (86.7 KB, 167 views)
File Type: jpg DSC_3923_.jpg (31.7 KB, 165 views)
File Type: jpg DSC_3932_.jpg (454.0 KB, 77 views)
File Type: jpg DSC_3915_.jpg (36.1 KB, 71 views)
  Reply With Quote
Old 14th April 2012, 12:56 AM   #527
acccruz is offline acccruz  Portugal
diyAudio Member
 
Join Date: Nov 2009
Default DEM mod

Hi Andrew:

I have done your sugested DEM mod but I have a lot of noise in the sound!

Will you help me to solve the problem please?

Thank you,
Antonio



Quote:
Originally Posted by AndrewGM View Post
Final implementation as attached.

Just running unit now - too early to say.
Works great though - more later
  Reply With Quote
Old 14th April 2012, 02:34 AM   #528
diyAudio Member
 
Join Date: Jun 2008
Tell me what you have done and I'll do my best to help.
I made some mistakes too - don't mind admitting it.

Andrew
  Reply With Quote
Old 14th April 2012, 11:54 AM   #529
acccruz is offline acccruz  Portugal
diyAudio Member
 
Join Date: Nov 2009
Default DEM mod

Hi again Andrew:


I follow your schematic.

I forget to say I have the player running in NOS mode - may it will be the noise cause...

Soon I will post some pics.

Many thanks for you quick reply,
Antonio
  Reply With Quote
Old 14th April 2012, 12:39 PM   #530
diyAudio Member
 
Join Date: Jun 2008
It might be NOS thats a problem - but the real problem is I don't know these things technically enough to make a statement - sorry.
In the end I took it ( DEM mod ) off because I too had some noise problems with it and instead I concentrated more on the power supplies which gave me really significant gains.
A little bit like SimonT's work but without so much reserve VA

Do you like the NOS sound ?
I recently did it on an Alpha 5 and removed the SAA7220 completely. There are certainly gains in sound quality in the bottom end and midrange but I'm still not sure about the hf roll off. I'm sure I can hear it.

It's never going to be a match for my old Alpha even without DEM mod.
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Arcam Alpha 5 cd schematics and mods wanted Chivvyp Digital Source 5 21st March 2010 11:36 AM
Arcam Alpha Plus amc184 Digital Source 6 17th January 2008 07:01 PM
arcam alpha 7 big jim Solid State 3 19th June 2006 12:40 PM
Arcam alpha 9 pumpkin Solid State 0 5th October 2005 07:31 PM
Arcam Alpha 8 ManUtd Digital Source 4 5th April 2004 03:23 PM


New To Site? Need Help?

All times are GMT. The time now is 01:38 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2