CDP-X333es / KSS-271a - Tracking / Offset Probs - diyAudio
Go Back   Home > Forums > Source & Line > Digital Source

Digital Source Digital Players and Recorders: CD , SACD , Tape, Memory Card, etc.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 9th November 2009, 07:24 PM   #1
diyAudio Member
 
Razorblade's Avatar
 
Join Date: Jun 2008
Default CDP-X333es / KSS-271a - Tracking / Offset Probs

Hello,

i need some help here. I picked up a "broken" Sony CDP-X333es from a thrift store. I did read no discs,i veryfied that the laser is not broken with a digicam in the store and took it home.

Focus and tracking gain were readjusted and now it reads the TOC of the CDs within a second. But as soon as I press play it sounds like its searching for the first track but doesnt find it.

So everything is fine unti its past the TOC read, unfortunately i dont have the service manual for this player, but for the X555es that has the same powersupply and servo control PCB.

I own a Fluke 29, a pretty beaten up 20MHz Oscilloscope and have done Laseradjustments on serveral used "broken" thriftstore and ebay Playersfor training and learning reasons , but the KSS-271a is another league, i dont wont to screw things up so i come here to ask for your advice.

I checked most of the Voltages and found two errors :

1. Testpoint FEO is 250mV ... The service manual says it should be 0V and if i am not totally wrong this should be the focus offset, but which of the 3 pots on the laser unit is to adjust the focus offset?

2. The +/- 8V lines that power the Servos (and should be +10.9V and -11.5V according to the manual) are both about 0.5V to low, could this point to a problem with the two thermistors in the power supply?

So far i have not hooked up the scope yet, so i cant comment on the RF Signature, but maybe someone has occured the same problem with his X333es / X555es or has experience servicing these units.

I am quite sure the Laser is still healthy and would really like to keep this machine alive.
Mechanism and pickup were diassembled, cleaned with isopropanol and lubed.

Hope you can help me get this baby working again, thanks for your help
  Reply With Quote
Old 9th November 2009, 07:37 PM   #2
jurijvi is offline jurijvi  United States
diyAudio Member
 
Join Date: Nov 2009
Hi, do you have the service manual of the CDP X333ES? I have problems with this unit too. Could be of help if you could tell me where to get it?
  Reply With Quote
Old 9th November 2009, 08:47 PM   #3
diyAudio Member
 
Razorblade's Avatar
 
Join Date: Jun 2008
I only got the Service Manual for the 555es, but power supply and Servo board are identical to the 333es you can find it here http://www.electronica-pt.com/index....rby,2/page,10/

The manual for the 333es is also available but its encrypted and cannot be viewed without a password.

If anyone hast the Service Manual of the 333es i would be happy to get a copy.
  Reply With Quote
Old 10th November 2009, 12:26 AM   #4
diyAudio Member
 
Razorblade's Avatar
 
Join Date: Jun 2008
So here is a scope picture,

RF p-p is 1.2V perfect, but waveform is pretty screwed up, this is the RF waveform when i press play after TOC is read:
Click the image to open in full size.

Looks like the RF-waveform from my cdp990 when its loading a disc or searching for next track, also RF-Offset is way to high, can somebody help me out with the functions of the 3 pots on the laserunit itself?
I know one is for LD power ( no panic, i dont want to touch it) the two others are focus and tracking offset i guess?
  Reply With Quote
Old 23rd January 2010, 10:37 AM   #5
diyAudio Member
 
tiefbassuebertr's Avatar
 
Join Date: Jul 2005
Location: D-55629 Schwarzerden
Quote:
Originally Posted by Razorblade View Post
So here is a scope picture,

RF p-p is 1.2V perfect, but waveform is pretty screwed up, this is the RF waveform when i press play after TOC is read:
Click the image to open in full size.

Looks like the RF-waveform from my cdp990 when its loading a disc or searching for next track, also RF-Offset is way to high, can somebody help me out with the functions of the 3 pots on the laserunit itself?
I know one is for LD power ( no panic, i dont want to touch it) the two others are focus and tracking offset i guess?
This looks like a overdrived APC potentiometer for the right value for laser power. Then the laser diode is damaged. But if the setting of pot does still have the original position from the manufacturer, then it must be actually only a noise interference, resulting through bad grounding (e.g. as a consequence of the transition resistors in the crimp terminal connections for the GND - unfortunately not easy to find)

In such cases the best way it is to buy a used cd player, but exactly the same model. Now you can change all units and cables until the observed fault moves too.

In the attachement you will find some schematics regarded the KSS-272A - compare it to yours. As I know there are no electrical differences to KSS-271A, but I am not absolutely shure.



P.S. for Mitsubishi's M52102 (OPIC from KSS-271A) I need a datasheet, but I don't find anywhere.
Attached Files
File Type: pdf KSS-272A-eig. Plan - CDPX505ES - CDPX559ES.pdf (188.4 KB, 146 views)
File Type: pdf KSS-271A im CDPX555ES.pdf (59.4 KB, 130 views)
  Reply With Quote
Old 24th January 2010, 02:02 PM   #6
diyAudio Member
 
tiefbassuebertr's Avatar
 
Join Date: Jul 2005
Location: D-55629 Schwarzerden
in this case this thread could be of interest (include a little gallery and some schematic samples):
All Diyaudio Threads about not available Optical Pickup's from Sony's KSS-Series
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Sony cdp-x333es pika_ Digital Source 4 9th July 2010 01:17 PM
SOny CDP-X333ES DMC Digital Source 0 7th September 2007 04:42 PM
xbosoz pre probs dhole Pass Labs 1 2nd September 2005 03:11 PM


New To Site? Need Help?

All times are GMT. The time now is 05:53 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2